1. KenSchreiber's Avatar
    I've gotten fairly proficient in doing all sorts of things with my jailbroken phone including technical problems that arise, but suddenly I have a really strange and aggraving problem that I've researched online and find almost no useful information, mainly because this hasn't happened to anyone but me (that I can determine)

    When I tap the "Settings" icon on my springboard it takes me of course to the main settings page. But when I tap the "General" icon, all I get is a blank page with grey background. So, I cannot access some of my important settings like lock down time etc. I've tried every trick in the book to try to get my general settings back but no luck. If I were to try to do a restore via Itunes, it would update my firmware to 3.1.3 and that can't be jailbroken.

    If anyone has any suggestions, I would greatly appreciate it.
    02-18-2010 02:49 PM
  2. big9erfan's Avatar
    When you jailbroke your phone, did you go into Cydia and choose "Make My Life Easier"?

    If so you can restore to 3.1.2 through iTunes, but you have to modify your hosts file.
    02-18-2010 02:52 PM
  3. Ipheuria's Avatar
    We need a little more info than you've tried everything. You should let us know what you've tried? What did you use to JB? So not knowing what you've tried already I would suggest

    powering off and then back on by holding down the hold button on top of the phone. Then if the same thing occurs reboot via holding the hold and home buttons.

    Then I would suggest re-JB but this is where I would need to know what you used to JB? If you used pwnage tool then you could just open iTunes with the shift to allow you to pick your ipsw file. If you used blackra1n wait for someone else's input but can't you just get the 3.1.2 OEM ipsw and do the key combo for iTunes to allow you to pick the ipsw? then you would choose 3.1.2 OEM then re-JB the way you did before.

    Also since your phone was fine what did you do before you noticed this problem?

    Also get SBSettings in Cydia and see if you're able to toggle things like Wifi, BT, Phone-Airplane mode in it or not.
    02-18-2010 02:58 PM
  4. KenSchreiber's Avatar
    Thanks for the fast response--Here's some more info--Everday I check Cydia and Appcake for new apps and download a few each week. I jailbroke with Blackra1n.
    I've always had an issue with the number of icons on my springboard. If any apps spill on to page 8, then springboard crashes, and goes into safe mode. So, I do my best not to let that happen. I think my missing general settings page problem started after one such crash---if it happened after downloading a particular app, I'm not sure what that would be. I have started removing many cydia apps that I never use. I have SB settings and can use to some change some of my missing settings. Also, I have tried rebooting to no avail. I also did jailbreak again, but no change. Is there a way to do a restore via Itunes without at the same time changing my firmware to 3.1.3?
    I haven't tried taking my SIM card out, and putting back. Do you think that might help? Or would it be a waste of time? Again,thanks for trying to help---this is quite frustrating.
    02-18-2010 03:27 PM
  5. big9erfan's Avatar
    Have you done a full restart? Hold home and power at the same time until the phone shuts down, continue holding power ( only ) until the Apple comes up and let it restart.

    If that doesn't fix it, go into Cydia and on the main page it will say "This device has SHSHs on file for iPhone OS: ...." if it says 3.1.2 you can follow these steps to restore to 3.1.2 Caching Apple's Signature Server - Jay Freeman (saurik)
    02-18-2010 04:15 PM