1. busnut44's Avatar
    My 3GS phone was jailbroken and unlocked. Unfortunately, it ran to empty power and I needed to jailbreak it again. When I did, it was already unlocked but would not connect to Wi fi.

    I've tried to jailbreak a few times again and on occaison, it will show my Wi fi as being connected to my router, but without a valid IP address.

    Any suggestions?
    02-10-2010 01:40 PM
  2. big9erfan's Avatar
    This usually fixes it

    To fix the WiFi issue after blackra1n issue, you can simply reset the network settings. Go to “Settings” -> “General” -> “Reset” and select “Reset Network Settings”. Tap on the “Reset Network Settings” button again to confirm. After resetting, the WiFi issue should be fixed.
    This is also the first result in googling "blackra1n wifi problem".
    02-10-2010 02:27 PM
  3. busnut44's Avatar
    Thanks for the information. I tried resetting the network settings but the phone then went into reboot and subsequently went into restore mode. After jailbreaking again, no WiFi again (tried it a few times)

    Any other ideas?
    02-10-2010 03:48 PM