1. leggy77's Avatar

    This is my first post....I have searched for this, honest.

    I have the iPhone 3G S with 3.0.1 (7A400) and I have been trying to JB with redsn0w 0.8 and the the iPhone2.1 3.0 7Ae341 IPSW (the A400 was not recognised by redsn0w).

    It keeps on getting to "waiting for reboot" screen and then it just hangs. I had a search around and all I could find was that to get round this I just needed to unplug the USB and put it back in. I tried this though, and it never worked - it just remained on the same screen.

    Has anyone else seen this, or know how to get round it?

    09-04-2009 10:25 AM
  2. anon(153966)'s Avatar
    ...when you plugged the device back into the USB, did you use the same port?

    If so, try another USB port. The pc should see it as a new device, etc, etc...
    09-04-2009 10:44 AM
  3. leggy77's Avatar
    I just tried this and the same thing happens, just keeps on hanging there. I am running Windows 7 if that makes any difference.
    09-04-2009 11:02 AM
  4. Skywalker's Avatar
    I had the hang up as well until I realized that I had the wrong 3.0 firmware. I updated a 2G phone with 3.0 firmware to a 3GS. I had to download the 3.0 firmware for the 3GS and my jailbreak worked great.

    Make sure you have the right 3.0 or just download the right one and replace yours just to be safe.
    09-04-2009 12:38 PM