Apple Watch Series 6 deals at Amazon: Starting at $320!

  1. ridhwan's Avatar
    hi everyone,
    Got my new iphone 3GS (no contract )from states, as i have said i stay in saudi arabia. I have jailbreaken the phone using the redsn0w and installed purplesn0w for unlocking the iphone. But the problem is that i have inserted my sawa (stc) sim in the iphone but the network is not there, is there something i have missed or overlooked, any suggestions or comments are welcome.
    Appreciate your efforts in advance.,
    Thanks for looking at it.
    p.s. forgot to mention that before jailbreaking i have added some songs from itunes on it, later while jailbreaking kept the at&t sim, not much sure about which sim should be present whether the one i want to use or the at&t one. it looks in the cydia that purplesn0w has been installed but i am unable to get the network signal.

    Last edited by ridhwan; 07-21-2009 at 05:09 PM. Reason: adding
    07-21-2009 03:58 PM
  2. Matt74's Avatar
    To use purplesn0w, you have to jailbreak with purplera1n. Personally, I prefer using Geohot's stuff, so if it were me, I'd restore and jailbreak again with purplera1n.

    However, you might prefer to just unlock using ultrasn0w. It's definitely your fastest way to unlock the phone, as it works with redsn0w.

    To unlock via ultrasn0w, yust open Cydia, add as a repostitory and install ultrasn0w. No clue what 3G technology they use in Saudi Arabia, so it's a toss up whether or not the iPhone 3G will work or not. If you fail to connect with 3G enabled, just disable it and you'll probably be fine.
    07-21-2009 05:16 PM
  3. ridhwan's Avatar
    thanks matt74

    i have tried to use ultrasn0w but cydia comes up with this error size mismatch every time and i am unable to install ultrasn0w.

    But would activation has something to do.

    Anyways if have to use purplera1n,i should have to restore and how should i do that because itunes is offering to upgrade the OS, i mean if i use the restore button under the summary tab in the itunes when iphone is connected directly.

    For the 3g technology in saudi arabia, there is a service provider which offers iphone 3g (which are unlocked and can be used on my service provider as well).

    Anymore suggestions are welcome.
    Last edited by ridhwan; 07-21-2009 at 08:28 PM.
    07-21-2009 08:25 PM
  4. Matt74's Avatar
    You can try this to fix Cydia.

    HowTo: Fix Cydia Suddenly Crash | FSMdotCOM
    07-21-2009 10:02 PM
  5. ridhwan's Avatar
    The cydia is not crashing, it works fine i am able to install winterboard theme and also was able to install purplesn0w. i have read what you have pointed out.

    Could you let me know how do i restore my iphone without upgrading.

    Thanks again!
    07-22-2009 07:21 AM
  6. Jedi's Avatar
    You need to upgrade. All of the above jailbreak methods only work on the latest OS 3.0
    07-23-2009 07:09 AM
  7. Matt74's Avatar
    In the original post, he said that he has a 3GS... so I'm not sure what he'd be upgrading to. The 3GS comes with 3.0, which is the newest version of the iPhone OS.

    If you jailbroke with redsn0w, I really cannot see a reason why you're unable to install ultrasn0w.

    Perhaps you can try installing Icy, and then use Icy to install ultrasn0w. Icy uses the same repositories as Cydia, so you'd just need to add
    07-23-2009 08:12 AM
  8. Matt74's Avatar
    For the repository, did you use the number zero in the word sn0w? Its supposed to be a number and not a letter.
    07-23-2009 08:17 AM
  9. ridhwan's Avatar
    i used the repo name exactly.. actually i had got that repo name memorized.
    the cydia problem was not temporary... it was for atleast 2days. However
    I happened to try it later on with the same approach and it worked.
    Although i think the problem could have been related to the wifi provider, because when i changed the wifi i got ultrasn0w installed in the first go itself.
    Plus the good think was the at&t sim was also activated.
    So guys thanx a lot...
    Your efforts are really appreciated...

    07-24-2009 12:08 PM
  10. sourouge's Avatar
    HELP... I am trying to unlock my iphone unfortunatly i am getting the message that i need to install the depended file mobilesubscribe?? i is impossiblefor me to find it.. searched in cydia + tried to install other applications like sbsettings but always the same message needs the depended file mobilesubscribe... i'm getting CRAZYYY PLZ HELP
    08-03-2009 10:58 AM