Grab AirPods Pro for just $190 on Prime Day!

  1. KeLLStaR's Avatar
    I am wondering if anyone can help me.

    I've been trying to JB my iPhone 3G but it won't work. I have tried Redsn0w 7.2 & 8.0. I select the IPSW file that I downloaded, and then keep going. I follow the DFU instructions exactly but after I've finished with the Home button, it keeps saying "Waiting For Reboot" & the iPhone stays black (I don't get the "hard drive" picture). It's as if it just won't detect the phone.

    If I go into iTunes it detects the iPhone in recovery mode & wants to do a restore. If I reboot the phone it shows the apple symbol & starts normally (non JB).

    I'm at my wits end and wish I didn't upgrade to 3.0.

    Can anyone help me please?

    I'm running Vista, the latest iTunes. I have given Redsn0w permission to be run as Admin, I have also tried disabling Firewall & AVG.

    Thank you in advance.

    PS: I just tried to do this on another computer running XP after installing iTunes. Anti Virus was turned off. It does the same thing, sticking on "waiting for reboot" and the phone never reboots.
    Last edited by KeLLStaR; 07-13-2009 at 11:33 PM. Reason: Adding more to post (tested on XP too)
    07-13-2009 08:47 PM
  2. KeLLStaR's Avatar
    Just to let you know I have solved this issue. I went through everything and realised that I was using the wrong IPSW file. A website provided the direct link but did not mention it was only for 2G. I found the following quote for the specific files for each phone on a website ( I think).

    I hope this helps someone else!

    Andrew.Kay Writes:

    Here's the break down for each software (taken from

    3.0.0 (2G): iPhone1,1_3.0_7A341_Restore.ipsw
    3.0.0 (3G): iPhone1,2_3.0_7A341_Restore.ipsw
    3.0.0 (3GS): iPhone2,1_3.0_7A341_Restore.ipsw
    07-13-2009 11:36 PM