Score a saving on iPad Pro (2021): $100 off at Amazon

  1. Tana's Avatar
    Hi, these iphones are never ending stress causers. anyways, I have an iphone 3G, i was running the os 2.2.1 on it with the rebel simcard to let me use any sim. it worked just grand. I then updated to os 3.0 via itunes, activated with its original sim, O2. It now just keeps saying waiting for activation and there is no service. i've tried with the rebel simcard and still nothing. any ideas? have i buggered my iphone? thanks in advance
    07-06-2009 05:53 AM
  2. Savio's Avatar
    Is the original SIM card you used currently activated with O2?

    I'm not very familiar with Rebel SIMs or Turbo SIMs, but is the kind you have made to work with the 3.0 FW?

    I'd try activating and unlocking your iPhone using redsn0w.
    How to:
    Last edited by Savio; 07-07-2009 at 03:58 AM. Reason: fix link
    07-07-2009 03:34 AM
  3. Tana's Avatar
    The original sim, the O2 one, worked to activate my iphone with 2.2.1 software and the rebel simcard worked fine with other sims. i've installed cydia on to the phone but i need some sort of internet source to unlock it tho, no? no such thing as wi-fi in these parts. maybe ill just have to wait til im in a more civilised place. thanks for your suggestion tho.
    07-07-2009 06:59 AM