1. krisk's Avatar
    I have searched through the forum and cannot seem to find anyone who has posted this problem.

    I used redsn0w to jailbreak my iPhone 3G, and everything seemed to work fine. After it was finished and the phone restarted Cydia was not on the springboard. I have tried numerous times to restore the phone, jailbreak again; remove all 3rd party apps, restore, jailbreak again; all with no success. If I check the box to install Icy (or both Cydia and Icy), then Icy appears on the springboard, but no Cydia.

    I am going nuts not having Intelliscreen back on my phone after the 3.0 upgrade, and Icy bombs out when attempting to install it. I have never had a problem with Cydia in the past.

    Someone please HELP!!!
    06-26-2009 01:02 PM
  2. krisk's Avatar
    Anyone have any ideas?
    06-27-2009 05:47 PM
  3. gerritg's Avatar
    I got exactly the same problem. I have now downloaded redsnow 7.2 ver. and afte jailbreaking I restart and can't find either ICY or CYDIA application.

    I have no idea what I did wrong

    Please help!!!!
    06-28-2009 09:30 AM
  4. Cagey47's Avatar
    I think you have to either install 1 or the other, personally i prefer icy at the moment until they get this problem figured out and i could use both.
    06-28-2009 10:26 AM
  5. gerritg's Avatar
    Neither one works if you select ICY or Cydia

    I think the problem lies that redsnow has not been successfull installed. I am trying now install this on the mac
    06-28-2009 12:22 PM
  6. BradM73's Avatar
    I had the same problem the first time I jailbroke, so I restored back to firmware 3.0, and then rejailbroke the phone with RedSn0w. I made sure not to install ICY, by deselecting it during the Redsn0w process, and when I was done jailbreaking, Cydia worked fine. When everything was done, I still had ICY on there for some reason but everything seemed to work fine. Maybe give that a try?
    06-28-2009 01:34 PM
  7. Billlyrms's Avatar
    I had the same problem, until I restored my phone as a new phone. And then jailbreak it. But before doing that I sick my contacts to windows with iTunes. And save all my pictures. Try that. And jailbreak it again it should work fine. And then to get your contacts back on your jailbreaked iPhone just sinc it one more time.
    06-28-2009 02:22 PM
  8. gerritg's Avatar
    Thank for your input.

    Currently I have the damage than either redsnow can be run on my mac and pc. I am working 4 hours straight to get a solution.

    I am now deinstalling i tune 8.2 and installing 8.1.
    06-28-2009 02:23 PM
  9. gerritg's Avatar
    Okay I have found the solution.

    When you think that redsnow installs in 2 mins you are wrong.
    First, the ramdisk will upload and after you have the screen "Done" and you think you can click on finish you are again woring. The iPhone than rocks on installing lots of data and you will see lots of updates on your iphone running with a nice logo. From there on you will need at least 4 mins after it has finished installation.

    My soultion to this problem was that my vista on my desltop somehow didn' let me prope run redsnow. So I installed redsnow on my laptop and run the software and everything worked out fine. Everything is working perfect.
    06-28-2009 05:40 PM
  10. waz#IM's Avatar
    This is not for you Krisk...sorry for using your thread!

    hey all you guys who cracked (AKA unlocked) the iphone, what did u do with the AT&T plan??? Disabled? How?

    I'm so worried!!!:o
    06-29-2009 01:45 AM
  11. shadowslay's Avatar
    I had a similar problem when going from a jailbroken (but not unlocked) 2.2.1 firmware to 3.0 . When you very first restore or upgrade the phone to 3.0 and use redsn0w it and install cydia the icon is there. But once I did a sync with itunes and restored from a previous iphone backup (it also backups the configuration of the icons on your phone) It got rid of the cydia icon and it was nowhere to be found. I am thinking that it might have something to do with the poof application that hides icons or the categories app that lets you store icons in certain sub folders for organizational purposes. I noticed that every icon I had store in a subfolder from my previously jailbroken 2.2.1 setup had magically dissapeard and was nowhere to be found. This included important stuff such as the settings icon. My suggestion when upgrading from one jailbroken firmware to a newer virginized firmware is to be sure to unhide every icon in spoof as well as uncategorize everything in the categories app, effectively making every possible icon on your phone on the main screen area. Also be sure to make one last backup in itunes with all these icons on the main screen so that it will be restored as such when you restore from that backup.

    Hope that was helpful and not too confusing.
    My first post btw.


    06-30-2009 12:31 PM
  12. krisk's Avatar
    Thanks Shadowslay, that was exactly what the problem was. I was running the SBSettings on the Jailbroken 2.2.1 and had Cydia hidden in the docked programs, not on the springboard. I couldn't find SBSettings in Icy, but found an add-on that installed the program at the same time it did the add on. Sure enough, when I checked the docked applications, there was Cydia.

    Thanks again for the much needed help. Now I know to move all the programs back to the springboard before upgrading the firmware.
    06-30-2009 03:53 PM
  13. zimmyntrn's Avatar

    I am experiencing the same issue you had list in your post about jailbreaking and cydia not appearing.

    Did you need to downgrade to 2.2.1 in order for cydia to reappear?

    I tried the return to manufacter's conditions in Itunes and it left me in 3.0.1 and still unable to see cydia after Jailbreak.

    Any help would be appreciated as I am not super iphone savy it appears.

    Thank you,
    08-20-2009 05:46 PM