1. bergman's Avatar
    Is there a "How to" guide for jailbreaking the 1st gen iPhone using 2.2 and windows? I'm not finding it. The 3G How to says that it applies only to 3G. I don't care about unlocking right now.
    I know that I saw a posting about jailbreaking 2.2 on the 2G iPhone, but cannot find it. I had 2.1 jailbroken, upgraded to 2.2 and just need to know which tool to use to re-jailbreak my 2G iPhone.
    Last edited by bergman; 12-27-2008 at 10:40 AM. Reason: Clarification
    12-26-2008 01:46 PM
  2. bergman's Avatar
    In case anyone else is wondering...QuickPwn does work with the 2G iPhone. here is the Readme file:
    Please visit http://www.QuickPWN.com to stay up to date with the latest jailbreaking methods and subscribe to our RSS feeds.

    QUICKPWN (Codename "Pwnmetheus") 2.2-1

    This is a GUI created by poorlad for the iPhone Dev Team's QuickPwn tool.



    This software is copyright the iPhone Dev Team, all rights reserved.
    Certain portions of this tool may be released in the near future under
    the terms of the GNU Public License, version 3, please check the dev team wiki
    for the details of this possible release.

    Modification, reproduction and redistribution without written consent by the
    iPhone Dev Team is strictly prohibited. You are hereby granted a limited
    license to redistribute this package provided all files herein are intact
    and providing no monies or fees are charged or solicited during the
    redistribution of this application and associated files.


    * Support for FW v2.0.1, v2.0.2, v2.1.0, v2.2.0
    * Jailbreaking and Pwning iPhone 2G, iPhone 3G and iPod Touch 1G
    * Unlocking iPhone 2G
    * Adding Cydia and Installer
    * Replacing boot logos


    * Functionality under virtualized environments is not guaranteed.
    * iTunes must be installed prior to use.


    * The usual suspects

    CHANGES FROM 2.1-1

    * Support for firmware 2.2
    12-27-2008 01:14 PM
  3. tooki's Avatar
    Quickpwn didn't work for me, unfortunately.

    It runs, and builds the ipsw, but I always have trouble entering DFU. I have to disconnect the phone and then do the 10-secs-both buttons and 10-secs-home button procedure again, and quit iTunes which can't be convinced to not open.

    Then it successfully uploads the files to the phone, and the phone thinks for about 1/2 hour, but in the end it reboots and has been neither jailbroken nor unlocked.

    It's an original EDGE (2G) iPhone 8GB with firmware 2.2 (5G77), running on a white MacBook with Mac OS X 10.5.6 and iTunes 8.0.2.

    Any clues, or how to proceed with alternatives? I tried using PwnageTool, but I can't find a bootloader 3.9 that it will accept.
    01-16-2009 07:13 AM
  4. tooki's Avatar
    Update: a friend of mine advised that 10.5.6 prevents entering DFU mode, so I tried on a system running 10.5.4, and indeed much more seemed to be happening, and in the end, I did have it jailbroken (installer.app, etc), but it still rejects the non-ATT SIM.
    01-16-2009 12:20 PM
  5. vvelvetelvis#CB's Avatar
    this is what you need... link
    01-17-2009 02:17 AM
  6. MrEClass's Avatar
    Make sure that you are also unlocking the phone as well.
    01-18-2009 08:30 PM