1. pttptppt's Avatar
    Since I've updated to 9.3, whenever I turn on wifi, it takes so long to connect to wifi. Anyone else notice this?
    03-22-2016 05:58 PM
  2. gordol's Avatar
    Nope. Then again, I leave WiFi on all the time.
    03-22-2016 07:48 PM
  3. Ledsteplin's Avatar
    Works fine for me. Try tapping the circled i. Tap "forget this network". Then add it back.
    03-22-2016 07:52 PM
  4. pr1nce's Avatar
    Mine is working fine.
    03-23-2016 12:27 AM
  5. robertk328's Avatar
    I don't see any issues here. I'm on a 6s.
    03-23-2016 06:02 AM
  6. Just_Me_D's Avatar
    Count me in among those who are not having trouble connecting to a Wi-Fi network.
    03-23-2016 07:47 AM
  7. scruffypig's Avatar
    No trouble with Wi-Fi or Bluetooth. Seems like both are pretty snappy now with connecting with iOS 9.3.
    03-23-2016 09:02 AM
  8. Sherry_B's Avatar
    I noticed it took a little longer on my iPod 5th Gen, but no issue on my iPhone 6s. The wifi box is sitting right on my desk, too.
    03-23-2016 12:05 PM
  9. decypher44's Avatar
    Unlike most here, I am having this issue. It's not too bad, but it's there.
    03-24-2016 11:03 AM
  10. JamesCinAustin's Avatar
    iPhone 6s Plus here - massive issues with 9.3. I've clean installed, setup as a new device, and all of the same problems persist -

    Slow to connect to wifi
    Cannot download apps over wifi
    Battery draining about 75% faster than pre-update

    Freaking ridiculous.
    03-24-2016 10:37 PM
  11. pttptppt's Avatar
    iPhone 6s Plus here - massive issues with 9.3. I've clean installed, setup as a new device, and all of the same problems persist -

    Slow to connect to wifi
    Cannot download apps over wifi
    Battery draining about 75% faster than pre-update

    Freaking ridiculous.
    I only have the wifi problem in common

    To clarify for everyone, the wifi most of the time connects automatically to a network (usually pretty slow through) although sometimes, it won't even connect at all and I have to go in settings app and press on the network to connect
    03-24-2016 11:57 PM
  12. Ledsteplin's Avatar
    No issues on my 6s Plus. I have Comcast wifi.
    03-25-2016 07:08 AM
  13. robertk328's Avatar
    Not sure how much it will affect it, but does anyone with wifi issues have wifi assist turned on or off?

    Settings -> Cellular (look at the bottom for wifi assist)

    I'm wondering if that has anything to do with the issue since it seems random.
    03-25-2016 07:46 AM
  14. pttptppt's Avatar
    Not sure how much it will affect it, but does anyone with wifi issues have wifi assist turned on or off?

    Settings -> Cellular (look at the bottom for wifi assist)

    I'm wondering if that has anything to do with the issue since it seems random.
    I have wifi assist off
    03-25-2016 02:10 PM
  15. robertk328's Avatar
    I have wifi assist off
    Ok thanks -- same here, but no issues.
    03-25-2016 08:25 PM

Similar Threads

  1. iOS 9.3 and battery indicator issue
    By EricfromTx in forum iOS 9
    Replies: 6
    Last Post: 03-25-2016, 07:24 PM
  2. Replies: 7
    Last Post: 03-23-2016, 02:43 PM
  3. Replies: 2
    Last Post: 03-22-2016, 05:56 PM
  4. Replies: 1
    Last Post: 03-22-2016, 05:34 PM
  5. Replies: 0
    Last Post: 03-22-2016, 05:33 PM
LINK TO POST COPIED TO CLIPBOARD