1. Fit24's Avatar
    Downloaded and installed iOS 9.3 Public Beta 3. No problems except for the status bar time bug.
    02-10-2016 10:56 PM
  2. Garz's Avatar
    Um no? The entire point of the beta is to collect feedback on issues. It's not so that you or I can "have a new OS to play with". Also, the point of releasing multiple consecutive versions of the beta is to refine it and fix bugs, then repeat the testing for more bugs.
    Yes and as you fix bugs, it breaks other things. That has been the norm with betas. Eventually by the time is goes officially, most big issues are solved. Betas aren't meant for everybody.
    02-10-2016 11:39 PM
  3. Garz's Avatar
    Um no? The entire point of the beta is to collect feedback on issues. It's not so that you or I can "have a new OS to play with". Also, the point of releasing multiple consecutive versions of the beta is to refine it and fix bugs, then repeat the testing for more bugs.
    Also for the people who are devs, we can see the release notes in Dev center. Many things were posted as fixed from previous beta. Many things fixed, one thing broke. Not too shabby if you ask me.
    02-10-2016 11:41 PM
  4. qmtc83's Avatar
    After downloading and installing I found some of my apps like Netflix and others are like kinda greeted out and when you tap on them they just say waiting and don't work and I also can't delete them.
    02-11-2016 01:05 AM
  5. robertk328's Avatar
    This happened to me the fist time unlocking my iPhone 6S after the update. Hasn't happened since. I just figured it was part of the finishing update process and booting, since it just finished an install to the OS. I guess I will keep an eye on it and if it happens again or a few times, I will do a restore and that probably will fix it.
    Mine's done it even after multiple times. Just did a reboot and it still took a few seconds to appear.
    02-11-2016 05:45 AM
  6. robertk328's Avatar
    does everyone have the clock bug?
    Downloading now - will let you know!
    I do, but it's minor. It shows up after a few seconds.
    02-11-2016 05:48 AM
  7. Phill_UK's Avatar
    does everyone have the clock bug?
    I do, but it tends to be random. Sometimes it appears straight away after unlocking, and other times it takes a few seconds to appear. Not a major problem, but it is still a bug.

    As for News App articles opening from the suggested search screen, that works perfectly for me.
    02-11-2016 06:35 AM
  8. vincie76's Avatar
    Just in case anyone like me wonder how to turn sunset to sunrise setting for night shift I found it in location services -system setting-setting time zone must be on to have that option
    02-11-2016 06:45 AM
  9. Rob Phillips's Avatar
    While the FAQ seems to be geared towards android devices, it appears Verizon will try and use the cellular network if available

    From Verizon:


    Wi Fi Calling FAQs | Verizon Wireless
    Thanks for the info! Very interesting. My Verizon service at home is pretty reliable so I don't know how much I'll actually utilize wifi calling but it's a nice backup if I'm in a weak signal area.
    02-11-2016 07:01 AM
  10. brodyj97's Avatar
    Anyone else have Game Center bug? Mines been broken since iOS 9 and hasn't fixed yet even on iOS 9.3 pb 3
    02-11-2016 07:10 AM
  11. nikkisharif's Avatar
    I downloaded the other day & my wifi seem slow to connect. I've rebooted a few times and there's still a delay. It's no biggie though. I also noticed the clock issue but that seems to be resolved by the reboot.
    02-11-2016 09:42 AM
  12. njlx2016's Avatar
    I can't believe that beta 3 is still this buggy. 9.3 is by far the worst beta yet compared to other 9.x versions.

    I did a clean install of 9.2.1 and I'm staying there. I am missing Night Shift, however.
    02-11-2016 09:55 AM
  13. ghostface147's Avatar
    I can't believe that beta 3 is still this buggy. 9.3 is by far the worst beta yet compared to other 9.x versions.

    I did a clean install of 9.2.1 and I'm staying there. I am missing Night Shift, however.
    What? A beta development that fixes things at some releases and breaks others at other times? That's asinine. Who would think a beta process can break things and be even more buggier than previous releases?
    02-11-2016 11:17 AM
  14. SnakeHaveYou's Avatar
    Are the Grayscale and Inverted Colors on Accessibility Settings new?
    02-11-2016 11:39 AM
  15. robertk328's Avatar
    I can't believe that beta 3 is still this buggy. 9.3 is by far the worst beta yet compared to other 9.x versions.

    I did a clean install of 9.2.1 and I'm staying there. I am missing Night Shift, however.
    Because the clock doesn't show?

    The worst one for me was the one that drained my battery like crazy. Had to revert with that one. There have been some quirks so far otherwise can't complain.
    Rob Phillips likes this.
    02-11-2016 02:16 PM
  16. mattdistro's Avatar
    I noticed a weird issue after upgrading to 9.3 beta 3. Whenever I try and download an attachment over 1MB from my work email (Exchange 2010) it appears to download but does not open, when I close the Mail app and retry it says "cannot download attachment"

    There's reports of this exact issue happening with 9.2+ and Exchange 2003, I'd post a link but I can't.

    Not sure if it existed in 9.2 and I never noticed or not. It's driving me crazy though, because everyone is saying it's Exchange 2003, but I'm seeing it on Exchange 2010. I just want to find someone else with the same
    02-11-2016 02:54 PM
  17. scruffypig's Avatar
    Are the Grayscale and Inverted Colors on Accessibility Settings new?
    No. These features have been around for quite some time.
    02-11-2016 03:25 PM
  18. ghostface147's Avatar
    I noticed a weird issue after upgrading to 9.3 beta 3. Whenever I try and download an attachment over 1MB from my work email (Exchange 2010) it appears to download but does not open, when I close the Mail app and retry it says "cannot download attachment"

    There's reports of this exact issue happening with 9.2+ and Exchange 2003, I'd post a link but I can't.

    Not sure if it existed in 9.2 and I never noticed or not. It's driving me crazy though, because everyone is saying it's Exchange 2003, but I'm seeing it on Exchange 2010. I just want to find someone else with the same
    Try it on wi-fi. I do have a bug report open on this.
    02-11-2016 03:57 PM
  19. tsparks1's Avatar
    Because the clock doesn't show?

    The worst one for me was the one that drained my battery like crazy. Had to revert with that one. There have been some quirks so far otherwise can't complain.
    I have to agree, the only bug I've found so far is the clock issue and while it needs to be fixed but it's certainly not a showstopper. Every thing else (at least that is of any import to me) is smooth as silk.
    02-11-2016 04:17 PM
  20. hVarun's Avatar
    Except for the clock issue Occasionally.. Feels pretty solid on my 6s plus. ...
    trparky likes this.
    02-11-2016 04:58 PM
  21. kch50428's Avatar
    9.3 beta 3 on Verizon & wifi calling...

    My observations thus far, with the field test mode enabled to see signal as numbers rather than bars... if the signal drops below -110, it switches to wifi... and if the signal goes back up it will switch back to cellular - at something between -110 and -100 -- which is two dots/bars... and will stay on cellular with 3 dots/bars| -100 or better signal.
    Rob Phillips and robertk328 like this.
    02-11-2016 05:02 PM
  22. Rob Phillips's Avatar
    9.3 beta 3 on Verizon & wifi calling...

    My observations thus far, with the field test mode enabled to see signal as numbers rather than bars... if the signal drops below -110, it switches to wifi... and if the signal goes back up it will switch back to cellular - at something between -110 and -100 -- which is two dots/bars... and will stay on cellular with 3 dots/bars| -100 or better signal.
    Thank you for sharing.
    02-11-2016 05:37 PM
  23. tsparks1's Avatar
    9.3 beta 3 on Verizon & wifi calling...

    My observations thus far, with the field test mode enabled to see signal as numbers rather than bars... if the signal drops below -110, it switches to wifi... and if the signal goes back up it will switch back to cellular - at something between -110 and -100 -- which is two dots/bars... and will stay on cellular with 3 dots/bars| -100 or better signal.
    Yeah, I'm seeing the same on 6S+, looks like I'll be in wifi when I'm home, now if I could only think of someone I actually wanted to talk to in order to try it out!
    02-11-2016 05:38 PM
  24. arindambhoumick's Avatar
    Garming vivosmat now connects syncs and notifies all working in 9.3 public beta 3
    02-12-2016 02:20 AM
  25. hVarun's Avatar
    iOS 9.3 Beta 7 for Public is live-imoreappimg_20160212_001536.jpgOne more bug I noticed .. Anyone else also same thing?
    02-12-2016 03:16 AM
702 ... 1213141516 ...

Similar Threads

  1. watchOS 2.2 beta 6 gets seeded to developers
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 03-07-2016, 01:30 PM
  2. The Staad Attach is a classy briefcase alternative for your iPad Pro
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 03-07-2016, 01:12 PM
  3. OS X El Capitan 10.11.4 beta 6 heads out to developers and public testers
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 03-07-2016, 01:12 PM
  4. Apple releases iOS 9.3 beta 6 to developers and public testers
    By iMore.com in forum iMore.com News Discussion
    Replies: 1
    Last Post: 03-07-2016, 01:10 PM
  5. Replies: 0
    Last Post: 03-07-2016, 12:00 PM
LINK TO POST COPIED TO CLIPBOARD