1. eyecrispy's Avatar
    So this started a few days ago for no good reason. I've changed no settings or usage patterns. My battery life has totally sucked compared to previously and i don't know why and I'm hoping you fine folks can help me.

    For some reason, my mail app is absolutely killing my battery. It seems to be running all the time. I have three accounts - one exchange (push), gmail (fetch hourly), yahoo (fetch hourly). My email volume hasn't changed over the last few days and neither has my usage pattern.

    Look at the screenshot and you can see that my phone is never idle. I don't know why. Can someone shed any light? I can barely make it through 12 hours. In fact, when I was typing this email, the phone shut down with 8% battery remaining, which is really unusual.

    I've even changed my non-exchange accounts to fetch manually and it has made zero difference.

    To give you a point of reference, I usually have somewhere between 5-8 hours is usage and 12-14 hours of idle but now usage is much higher. I'm wondering if there's a run away process in mail.

    I'm on 8.1.1.

    Mail causing battery drain-imageuploadedbytapatalk1417844521.867718.jpg
    12-06-2014 12:42 AM
  2. warcraftWidow's Avatar
    Not sure about the standby time but 11 hours of usage time is great battery life.
    You could try deleting the email accounts from the device and re-adding them.
    12-06-2014 12:46 AM
  3. eyecrispy's Avatar
    Not sure about the standby time but 11 hours of usage time is great battery life.
    You could try deleting the email accounts from the device and re-adding them.
    I was thinking about trying that. But 11 hrs or usage isn't actually 11 hours of usage. For example, two of the hours were the phone just sitting in my gym bag tonight while I was in Tae Kwon Do class. It wasn't being used. And yes, I know things run in the background and all that, but my point is that the phone has never behaved like this before.
    12-06-2014 12:52 AM
  4. warcraftWidow's Avatar
    If you can try deleting them one at a time and wait a day or so to see which one, if any, is the culprit. Since the gmail
    And yahoo accounts are on fetch, I'm guessing that something's up with the Exchange account. It could even be something on the server end.
    12-06-2014 12:55 AM
  5. eyecrispy's Avatar
    If you can try deleting them one at a time and wait a day or so to see which one, if any, is the culprit. Since the gmail
    And yahoo accounts are on fetch, I'm guessing that something's up with the Exchange account. It could even be something on the server end.
    Good point. If deleting the yahoo and Gmail don't work, I'll ask my coworkers to see if they're having similar issues.
    12-06-2014 01:04 AM

Similar Threads

  1. Replies: 1
    Last Post: 12-05-2014, 10:25 PM
  2. Replies: 3
    Last Post: 12-05-2014, 07:07 PM
  3. Why is my battery draining when switched off?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 12-05-2014, 05:31 PM
  4. Why is my mail showing as read?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 12-05-2014, 03:45 PM
  5. Why I'm not receiving mail on any apple products?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 12-05-2014, 09:49 AM
LINK TO POST COPIED TO CLIPBOARD