1. megability's Avatar
    For years I've been able to get incoming iCloud email, but send as from my own domains, using my own SMTP outgoing server, all with just 1 account set up, but it no longer works.

    It was set up as an "other" email choice, not iCloud, and I *used* to just use "imap.mail.me.com" or alternative "p09-imap.mail.me.com" as the incoming server, and my iCloud ID and password, and it worked beautifully.

    I was able to add my external domain email addresses as address options (the iCloud option won't let you) and then those would flow through to the mail app as options to send email from.

    As I said, it *used* to work just fine, but no longer, any idea what I have to tweak under iOS8.1 to fix it?

    Many thanks...
    10-23-2014 12:45 AM
  2. Just_Me_D's Avatar
    Great question, but unfortunately, I don't have an answer for you. Hopefully, one of our knowledgable members will comment soon...
    10-23-2014 05:01 PM
  3. HankAZ's Avatar
    Absolutely just a guess, since Apple changed the domain from me.com to icloud .com a while back, have you tried imap.mail.icloud.com?
    10-23-2014 05:56 PM
  4. warcraftWidow's Avatar
    http://support.apple.com/kb/ht4864

    Do you need these mail server settings?

    You can use the mail server settings in this article to manually set up your email app to send and receive email with an iCloud email account. However, you shouldn't need to do that if you meet the iCloud system requirements and can use any of these setup methods:

    OS X Lion v10.7.4 or later: Use iCloud Preferences.
    Microsoft Windows with Microsoft Outlook 2007 or later: Use the iCloud Control Panel.
    iOS 5 or later: Use iCloud settings.
    If you're using the Mail app in OS X Snow Leopard v10.6, use the mail server information in the iCloud Mail setup instructions for Snow Leopard instead of the settings below.

    Mail server settings

    Refer to your email app's documentation for information about how to use these settings. iCloud Mail uses the IMAP and SMTP standards supported by most modern email apps. iCloud does not support POP.

    IMAP information for the incoming mail server
    Server name: imap.mail.me.com
    SSL Required: Yes
    If you receive errors when using SSL, try using TLS instead.
    Port: 993
    Username: The name part of your iCloud email address (for example, emilyparker, not emilyparker@icloud.com)
    Password: Your iCloud password
    SMTP information for the outgoing mail server
    Server name: smtp.mail.me.com
    SSL Required: Yes
    If you receive errors when using SSL, try using TLS or STARTTLS instead.
    Port: 587
    SMTP Authentication Required: Yes
    Username: Your full iCloud email address (for example, emilyparker@icloud.com, not emilyparker)
    Password: Your iCloud password
    10-23-2014 08:01 PM
  5. megability's Avatar
    Thanks, I had not tried that yet, but it does not work either ;(
    10-24-2014 05:27 PM
  6. megability's Avatar
    Thanks Hank, I had not tried that yet, but I just did it does not work either ;(

    Thanks Karen, but yes that's the same link I've seen for years and have worked off of, notice my IMAP link is the one suggested, but like I said it no longer works, but it *used* to before 8.1...
    10-24-2014 05:31 PM
  7. megability's Avatar
    Turns out p99- works as a server (so p99-imap.mail.me.com) at least it doesn't crash the mail app when I try and change my "from" email address to my personal domain, but it does throw up an error box that it can't connect to iCloud about 50% of the time... frustrating.

    Why can't iCloud just allow us to send using a personal domain!?
    10-24-2014 06:03 PM
  8. Ledsteplin's Avatar
    Have you tried deleting the email account from your phone, Then do a hard reset, Then add the email account back in as you have been?


    Sent from my ancient but trustworthy iPhone 5.
    10-24-2014 06:21 PM
  9. megability's Avatar
    Thanks Ledsteplin, I did try that too, but no luck...

    Ok I found the problem, it's Apple's own 2-factor identification option.

    I turned it on at about the same time I upgraded to 8.1, for greater security of course, but noticed it causing problems on other devices and not recognizing my iCloud ID sometimes too...

    So, I turned it off just now and all my mail showed up again! AND I am once again able to send mail using my own domain's address as sender, rather than Apple's forced icloud.com or me.com extensions...
    Last edited by megability; 10-27-2014 at 04:22 PM.
    10-27-2014 12:56 PM
  10. Mark Goverde's Avatar
    Hi, a late reaction but it is possible to have 2-factor authentication and manual imap active. In your account settings of Apple you need to generate a password for other apps, that password you can use. I have both my iPad and iPhone now working with my private email address.
    02-14-2015 05:09 AM

Similar Threads

  1. iOS 8.1 working Jailbreak Apps/Tweaks
    By fb2 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 115
    Last Post: 12-06-2014, 06:26 PM
  2. How do I exit recovery mode on the iPod 5th gen?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 10-24-2014, 07:15 AM
  3. Kudos to Verizon Wireless
    By CrackOne in forum iPhone 6 Plus
    Replies: 6
    Last Post: 10-23-2014, 11:10 PM
  4. What am I doing wrong? Can't seem to get Handoff to work....
    By TiggerRPh in forum OS X Yosemite (10.10)
    Replies: 1
    Last Post: 10-23-2014, 07:38 PM
  5. Replies: 1
    Last Post: 10-23-2014, 06:42 PM
LINK TO POST COPIED TO CLIPBOARD