1. jdhooghe's Avatar
    Go to Settings->Messages->Send&Receive and make sure your iCloud email address is checked. Ask for another code and hopefully it works.

    Thanks to the person on Apple forums for this suggestion.
    10-20-2014 07:32 PM
  2. Ledsteplin's Avatar
    Go to Settings->Messages->Send&Receive and make sure your iCloud email address is checked. Ask for another code and hopefully it works.

    Thanks to the person on Apple forums for this suggestion.
    Ask who for what code?


    Sent from my ancient but trustworthy iPhone 5.
    10-20-2014 07:40 PM
  3. jdhooghe's Avatar
    Ask who for what code?


    Sent from my ancient but trustworthy iPhone 5.
    Receiving regular text messages on your iPad or Macbook with OS X Yosemite. When you turn on text messaging forwarding on your iPhone, it says the device that you want to pair will display a code. Many users are requesting such a code and it is not appearing on said device. Checking your iCloud email address in Send and Receive cleared up the issue with me and my Macbook finally gave me a code.
    10-20-2014 07:44 PM
  4. lv1's Avatar
    Still doesn't work for me.
    10-20-2014 07:45 PM
  5. lv1's Avatar
    Receiving regular text messages on your iPad or Macbook with OS X Yosemite. When you turn on text messaging forwarding on your iPhone, it says the device that you want to pair will display a code. Many users are requesting such a code and it is not appearing on said device. Checking your iCloud email address in Send and Receive cleared up the issue with me and my Macbook finally gave me a code.
    Checked icloud email no message/code received.
    10-20-2014 07:55 PM
  6. HankAZ's Avatar
    Checked icloud email no message/code received.
    To enable "Text Message Forwarding", both (all) devices must be signed into the same iCloud account and connected to the same WiFi network. You set the SMS Message Forwarding from your iPhone:

    1. Go to Settings > Messages
    2. Tap Text Message Forwarding
    3. Turn on forwarding for the computers/tablets that you want to use
    4. Each computer/ tablet will get a popup with a 6 digit code
    5. Enter that code to activate the Text Message Forwarding on that computer/tablet
    10-20-2014 07:56 PM
  7. jdhooghe's Avatar
    The other thing I tried was to turn off iMessage on both devices and turn them back on and then restart my phone as text message forwarding wasn't listed so it might be a combination of these and the above; I'm not sure. Worth a try though! Good luck!
    10-20-2014 08:00 PM
  8. BreakingKayfabe's Avatar
    To enable "Text Message Forwarding", both (all) devices must be signed into the same iCloud account and connected to the same WiFi network. You set the SMS Message Forwarding from your iPhone:

    1. Go to Settings > Messages
    2. Tap Text Message Forwarding
    3. Turn on forwarding for the computers/tablets that you want to use
    4. Each computer/ tablet will get a popup with a 6 digit code
    5. Enter that code to activate the Text Message Forwarding on that computer/tablet
    The problem with that is that the code isn't popping up for some of us no matter how many times we use those steps.
    10-20-2014 08:06 PM
  9. lv1's Avatar
    Exactly. Not working for me with Ipad and IPhone. Both devices on same wifi, and signed into same icloud account. The code never shows up on the iPad. Is it supposed to be a pop-up notification, iMessage, email ??
    10-20-2014 08:28 PM
  10. HankAZ's Avatar
    Exactly. Not working for me with Ipad and IPhone. Both devices on same wifi, and signed into same icloud account. The code never shows up on the iPad. Is it supposed to be a pop-up notification, iMessage, email ??
    It’s an alert popup on the device. It looks exactly like the messages that you get when you add a new device to your iCloud account. I just deactivated SMS Forwarding on my iPad Mini and re-added it. Here's the popup:

    Attachment 68972
    10-20-2014 08:39 PM
  11. lv1's Avatar
    This is what I get on the iPhone but nothing pops up on iPad.

    If text message forwarding isn't working for you, try this:-image.jpg
    10-20-2014 08:54 PM
  12. qnelson#CB's Avatar
    What worked for me was to sign out of iCloud on on my devices and delete all content. I than signed backed in with my iCloud email instead of my iTunes email on all devices. You have to use use your iCloud or Me email. After I did that everything automatically started connecting. I'm now receiving SMS messages on all devices.
    10-20-2014 09:03 PM
  13. HankAZ's Avatar
    This is what I get on the iPhone but nothing pops up on iPad.
    Yeah, that is the first/last step. The popup in my screenshot is the middle piece.

    I’m curious to see what you have in your Messages app for "You Can Be Reached by iMessage At" setting on both devices. It should include the same phone number and the same email address".
    10-20-2014 09:07 PM
  14. lv1's Avatar
    Yeah, that is the first/last step. The popup in my screenshot is the middle piece.

    Im curious to see what you have in your Messages app for "You Can Be Reached by iMessage At" setting on both devices. It should include the same phone number and the same email address".
    I think you identified the problem for me. The phone number was grayed out on the iPad. As soon as I activated tapped on it a check mark appeared next to the phone number and the I got the code.
    Last edited by lv1; 10-20-2014 at 10:01 PM.
    10-20-2014 09:28 PM
  15. BreakingKayfabe's Avatar
    I made my iCloud email address available for iMessage and the OP's method worked. I was able to disable the iCloud email address and it has continued working.
    10-20-2014 09:33 PM
  16. BreakingKayfabe's Avatar
    This is making me think that that the SMS messages are actually being routed through our registered iCloud email addresses.
    10-20-2014 09:42 PM
  17. zerog46's Avatar
    Yup I enabled my email and it popped right up.
    10-20-2014 10:06 PM
  18. Jonathan Russell2's Avatar
    There is no "Text Message Forwarding" option. I am really starting to hate this. What happened to "It just works"?
    10-23-2014 04:47 PM
  19. jdhooghe's Avatar
    There is no "Text Message Forwarding" option. I am really starting to hate this. What happened to "It just works"?
    I'm assuming you have restarted your phone already. Are both your devices configured to Send and Receive from your iCloud account in Messages under Settings? It doesn't show the Text Messaging Forwarding if you only have one device registered with your iCloud account.
    10-23-2014 05:28 PM
  20. BreakingKayfabe's Avatar
    There is no "Text Message Forwarding" option. I am really starting to hate this. What happened to "It just works"?
    Make sure you're logged into Messages on the Mac.
    10-23-2014 05:30 PM
  21. STrRedWolf's Avatar
    Here's what worked for me, and I'm using an iPhone 5 on a 2008 iMac. Old hardware to "why did they even think about putting Yosemite here" hardware. If your iCloud account end in me.com, and you're having problems, this may help.

    1. Sign out of iCloud on Messages in both the Mac and the iOS devices. You can leave the stuff on there but you gotta log out.
    2. Sign in, but with your icloud.com domain. Same username and password, just with an icloud.com domain.
    3. In iOS, I found the "Text Fowarding" to have disappeared. Go back to the Settings main page, then hit Messages again, and it will show back up.
    4. Make sure Messages on the Mac is running!
    5. Try Text Forwarding again, and give it a few minutes. It's not instant, but mine popped the code in about 2 minutes on the old 2008 iMac.
    6. Enjoy.
    10-25-2014 07:24 PM
  22. Lukas Egger's Avatar
    thank you sir!
    03-09-2015 11:56 AM
  23. Dave Lumby's Avatar
    This fix worked for me ...
    1. On the iPhone go into Settings -> Messages and turn off iMessage
    2. Power-cycle the iPhone
    3. On the iPhone go back into Settings -> Messages and enable iMessage
    4. On the iPhone go into Settings->Messages -> Text Message Forwarding and select the device. The pop-up notification with the authentication code should now appear on the device
    06-04-2015 07:37 AM
  24. MikeElmendorf's Avatar
    Over the last couple of days, text message forwarding has turned itself off on my phone for both devices I had set up--my iPad and my MacBook Air.

    I turned it back on, and today it had gone off again.

    Has anyone seen this? Any fixes? Thanks.
    06-08-2015 02:05 PM
  25. iDummi's Avatar
    This is what I get on the iPhone but nothing pops up on iPad.

    Click image for larger version. 

Name:	image.jpg 
Views:	44 
Size:	107.3 KB 
ID:	68975
    Having exact same issue. Wondering if you found a solution?
    I'm using Mini3 with a 5s.
    Checked phone number, email address, signed out and back in to imessage and icloud,
    did the reboots, am able to get pop-up to enter code, just no code comes thru on ipad.
    Is it possible that notifications are blocked on my ipad?
    Please help...
    04-14-2016 03:53 AM
30 12

Similar Threads

  1. How can I work around error 50 when moving iTunes to NAS?
    By kent1915 in forum Ask a Question
    Replies: 2
    Last Post: 10-20-2014, 10:55 PM
  2. iOS8 predictive text woes
    By olliegrl in forum iPhone 6
    Replies: 6
    Last Post: 10-20-2014, 10:13 PM
  3. How do you flip the camera on an iPhone 5s?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 10-20-2014, 05:27 PM
  4. Replies: 1
    Last Post: 10-20-2014, 05:22 PM
  5. How do I use fingerprint reader for Dropbox?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 10-20-2014, 03:53 PM
LINK TO POST COPIED TO CLIPBOARD