1. CTFaninNJ's Avatar
    My calendar is now displaying the GMT time on each event. The event's time is posted correctly, however, the GMT is included in the description. I do not want to see the GMT because, when rushed, I could mistake the GMT for the actual time.
    Any way to turn this off?
    09-18-2014 10:59 AM
  2. jnachbar said: Best Answer

    This happens to me with appointments I export from Outlook 2010 into Google that then syncs up with Calendar. NOT with events I enter manually into the iPhone, or enter in Calendar on any of my macs running Mavericks or if I enter events directly into google cal.

    GMT only show up on the iPhone, nowhere else. I'm guessing maybe something is in the file I'm importing into google that gets passed on to iOS 8. I do wish I could turn it off, it is annoying and I don't want to have to re-enter appts. Sure wish Microsoft Outlook, Apple Calendar and Google Cal would play nice, but I guess that's no more likely than world peace.

    Not sure I'd call this a bug with all the syncing and exporting I have going on, probably something relating to timezone support?? but would be nice to get iOS 8 to be able to turn this off.
  3. jq_richardson's Avatar
    I have the same issue, CT. I've been trying to change my settings to get rid of that myself. Other than that though, no issues with ios8 on 5s.
    09-18-2014 12:58 PM
  4. llckll's Avatar
    My calendar is now displaying the GMT time on each event. The event's time is posted correctly, however, the GMT is included in the description. I do not want to see the GMT because, when rushed, I could mistake the GMT for the actual time.
    Any way to turn this off?
    I'm having the same issue. I'm assuming it's a bug and they fix it in the first patch release. Other than that, everything else seems to work fine.
    09-20-2014 03:48 AM
  5. samplin's Avatar
    What PIM do you use with the Calendar app. I am having the same Issue and when I enter a appointment with the calendar app I do not see the GMT but if I enter the appointment with Chaos Software's Intellect I get the GMT.

    Joe
    09-20-2014 07:13 PM
  6. eb_therebel's Avatar
    What PIM do you use with the Calendar app. I am having the same Issue and when I enter a appointment with the calendar app I do not see the GMT but if I enter the appointment with Chaos Software's Intellect I get the GMT.

    Joe
    I use an app from my tablet to import my work schedule to my Gmail calendar and I have that linked to my iphone/iPad and I get the same issue. When I enter it manually, it shows the right time. Has to be a bug because it only started happening on the GM
    09-20-2014 11:50 PM
  7. jnachbar's Avatar
    This happens to me with appointments I export from Outlook 2010 into Google that then syncs up with Calendar. NOT with events I enter manually into the iPhone, or enter in Calendar on any of my macs running Mavericks or if I enter events directly into google cal.

    GMT only show up on the iPhone, nowhere else. I'm guessing maybe something is in the file I'm importing into google that gets passed on to iOS 8. I do wish I could turn it off, it is annoying and I don't want to have to re-enter appts. Sure wish Microsoft Outlook, Apple Calendar and Google Cal would play nice, but I guess that's no more likely than world peace.

    Not sure I'd call this a bug with all the syncing and exporting I have going on, probably something relating to timezone support?? but would be nice to get iOS 8 to be able to turn this off.
    Last edited by jnachbar; 09-24-2014 at 12:40 AM.
    09-24-2014 12:23 AM
  8. NeverEnough02's Avatar
    Same issue here. People sending events and they are showing the same as everyone above.
    09-24-2014 04:53 PM
  9. Ledsteplin's Avatar
    I don't see GMT on my calendar events. I'm still on my iP 5. IOS 8.


    Sent from my ancient but trustworthy iPhone 5
    09-24-2014 05:34 PM
  10. sau124's Avatar
    My calendar is now displaying the GMT time on each event. The event's time is posted correctly, however, the GMT is included in the description. I do not want to see the GMT because, when rushed, I could mistake the GMT for the actual time.
    Any way to turn this off?
    Can you provide more information on the problem? Are these events created on the iPhone itself (auto generated or manual)? or are these events imported to the calendar from something else, like Google or Outlook?
    09-26-2014 01:01 PM
  11. eb_therebel's Avatar
    It looks like every event that is imported from an outside source into iOS are the ones with the issue. I import my Google calendar and it shows fine on Google but it shows GMT instead of eastern time in my iOS calendar
    09-26-2014 01:25 PM
  12. HofstraJet's Avatar
    Here's how I fixed mine: I noticed that Time Zone Override was set to on with London set as location (unsure how this happened). Apparently, I set up my Exchange account while this feature was on. I turned the feature off, deleted my Exchange account from the phone, and then re-added the account back to the phone with the Time Zone Override feature off. Everything synced and is back to normal. I would expect the same behavior with Gmail or any other provider. Good luck!
    09-27-2014 12:54 AM
  13. eb_therebel's Avatar
    Here's how I fixed mine: I noticed that Time Zone Override was set to on with London set as location (unsure how this happened). Apparently, I set up my Exchange account while this feature was on. I turned the feature off, deleted my Exchange account from the phone, and then re-added the account back to the phone with the Time Zone Override feature off. Everything synced and is back to normal. I would expect the same behavior with Gmail or any other provider. Good luck!
    Didn't fix the problem for me. I'm noticing though that when I click on one of the imported events, it shows two times. One in my time zone which is eaten and one in gmt as if it created two entries during the import. Even weirder is that if I create an event on the Web, it shows up fine on my devices

    Just got off the phone with Apple support. Apparently, when iOS imports the data from Google that's where the problem is happening. If I create an event on my calendar on my device it syncs to Google perfectly but not the other way around. The engineers are aware of this and it's a known issue. Sucks for us
    Last edited by eb_therebel; 10-01-2014 at 04:40 PM.
    09-27-2014 11:01 PM
  14. Garafraxa's Avatar
    I am encountering the same issue as the OP. I'm concerned I'll accidentally glance at the GMT time and be 4 hours late for my event. Critically, it's my shifts at work and flight times that appear incorrectly!

    My primary calendar is Calengoo and I am not seeing the issue there. It's just all the goodies in iOS 8 that access and display calendar events that are a problem.
    10-02-2014 12:26 PM
  15. eb_therebel's Avatar
    I am encountering the same issue as the OP. I'm concerned I'll accidentally glance at the GMT time and be 4 hours late for my event. Critically, it's my shifts at work and flight times that appear incorrectly!

    My primary calendar is Calengoo and I am not seeing the issue there. It's just all the goodies in iOS 8 that access and display calendar events that are a problem.
    If you use the stock calendar, there's nothing that you can do about it. I had to switch to Calendars 5 at least until they get the bug fixed
    10-02-2014 08:46 PM
  16. rct2323's Avatar
    Did this ever get resolved?
    10-22-2014 05:49 PM
  17. jq_richardson's Avatar
    No, it hasn't been resolved with iOS 8.1
    Garafraxa likes this.
    10-22-2014 06:27 PM
  18. Steve Penny's Avatar
    My calendar events were all for the right time, but displayed the GMT time in brackets next to it (my iCloud account etc is UK, but I live in Finland, so not sure if this may have something to do with it). I had Time Zone Override on (and set to Helsinki), but have found that since turning this off, I no longer see the GMT time as well.
    10-23-2014 01:57 AM
  19. janicebeattie's Avatar
    How to prevent gmt time zone from appearing in calendar appointment
    11-15-2014 10:19 AM
  20. kloudy52's Avatar
    I have iphone 6. My calendar is a google email account that I only use for the calendar. I manually added it through the "add account" on the phone. When I enter an appointment on the calendar on the phone it displays the GMT time in the "Location" slot. It is on my calendar in the right place, but how do I stop it from showing the GMT?
    12-09-2014 11:33 AM
  21. Hughes Law's Avatar
    I agree and am still looking for the answer to this...I think it is a bug because I entered it manually and it is still showing up.
    12-09-2014 11:59 AM
  22. Brett Harris's Avatar
    I found an article relating to Timezone support for google calendar....I'd link it here but, alas...I am a newby to this forum. HoHum....

    I can presume from this information that when adding event to iCal (from phone) and it syncs the entry, Google then add's in UTC support and then iCal displays(???).


    Search for google calendar timezone support explained

    perhaps??
    support.google.com/calendar/answer/2367918?hl=en-GB
    melmurphy likes this.
    12-10-2014 06:36 AM
  23. rjfreitas's Avatar
    Turning off the automatic time zone feature in Settings, general, date and time fixed my calendar right way.

    This happened once before and went away then came back. I think iOS updates turn on the auto time zone feature which creates the problem.

    Good luck
    12-12-2014 01:23 PM
  24. powerhall's Avatar
    To fix this,
    Open your Calendar app
    On the top tool bar, select CALENDAR then PREFERENCES
    Click on the ADVANCED tab
    Make sure that Time Zone support is OFF (not clicked)
    Now, your invitations will stay in the same time zone set on your computer's clock.
    12-16-2014 07:19 PM
  25. Shelley 101's Avatar
    The override thing worked for me for a matter of one second, until my iphone synced to Google, then BAM back to the GMT in brackets...
    12-17-2014 02:21 PM
  26. Shelley 101's Avatar
    This problem only has occurred since I did the very latest update...dammit! I have tried your solution as well, and the problem still occurs. UGH.
    12-17-2014 02:28 PM
42 12

Similar Threads

  1. Wifi problems with my iPhone 6
    By SciTeach3 in forum iPhone 6
    Replies: 11
    Last Post: 06-21-2015, 06:28 PM
  2. Replies: 2
    Last Post: 09-21-2014, 05:50 AM
  3. Replies: 2
    Last Post: 09-21-2014, 02:13 AM
  4. Replies: 1
    Last Post: 09-20-2014, 05:58 PM
  5. iPhone 6 having problems streaming in wifi
    By SciTeach3 in forum Ask a Question
    Replies: 1
    Last Post: 09-20-2014, 05:44 PM
LINK TO POST COPIED TO CLIPBOARD