1. Cheryl Lynn Rella Payne's Avatar
    I have the same issue, CT. I've been trying to change my settings to get rid of that myself And I hv the 5c
    12-19-2014 03:14 AM
  2. Ted Vineland's Avatar
    I just installed IOS 8.1.2 and the the problem is gone - no more GMT
    12-19-2014 07:25 AM
  3. marv_mart's Avatar
    I have the same issue. Creating events on the iPhone & iPad, appears correctly at first but within a few seconds shows GMT in brackets. When I try to edit the event, only GMT time is shown. A real pain in the A! Have to re select Adelaide time zone and correct the times, then Ok from then on. Is this a known bug? Will it be fixed with iOS 8.2?
    Who do we tell at Apple to get this issue raised up the fix-it list?
    Using iPad Air2, iPad Air1 and iPhone 6 all on iOS 8.1.2
    Latest update DID NOT fix it.
    Tried all combinations of Time Zone Override On and Off in Calendars and Time Set Automatically On & Off in Date & Time.
    Nothing fixes this very annoying issue/bug!
    12-21-2014 03:41 AM
  4. GwenJorgensen1's Avatar
    Ok. The only thing that worked for me, was to go in and turn my location service on. Then I checked the calendar, and the GMT went away. I then went back in and turned ny location services back off, and the GMT is still off the calendar. Hope this works for someone else.
    12-22-2014 08:32 PM
  5. fightcrazy's Avatar
    This has recently started on both MY iPhone and iPad. Have my calendar synced with my Google calendar, May have started after 8.1.2 download. Whatever changes I make it always shows the GMT time zone. I googled this problem and many people on IOS are having this Issue. Someone HELP.
    THANKS, VINNY


    Sent from my iPad using Tapatalk
    12-25-2014 04:45 AM
  6. CarrieN's Avatar
    Yes, If you imput all your calendar data in Google calendar activate the "time zone" and highlight your timezone press-done, then save. Then go to your Iphone/Ipad calendar program, press edit on the event that is showing the "GMT". Click on the start time with the gmt then press save and the darn thing will disappear off you calendar.
    12-26-2014 07:50 PM
  7. fightcrazy's Avatar
    Called Apple Support, they know about this problem and are working with Google on resolving the problem. "Working with Google" I hope so, I use just about all of Google Apps on my iPhone and iPad.


    Sent from my iPad using Tapatalk
    12-27-2014 03:40 PM
  8. areyes1010's Avatar
    I have an iPhone 6 with iOS 8.1.2 and am having the same problem. I wonder if it is due to the update. I don't recall it happening before. I have tried everything and cannot fix the problem. I read Google's info on time zones and they use GMT. However it is supposed to adjust to whatever time zone you are in. Hopefully Apple will rectify this issue soon.
    12-29-2014 12:02 AM
  9. HankAZ's Avatar
    This thread is more evidence that Google is evil. Ok, I’m kidding, kind of.

    We have an app for our organization that uses Google calendar as our calendar of events. For that app, the calendar events appear correct, but if you try to share the event via the app, the time gets converted to GMT. It’s a bug with the whole Google calendar API. They have also recently changed the API which temporarily broke the way our app worked. I’m guessing that the time would coincide with the sudden onset of the problems with sharing Google calendar events with iOS.
    12-29-2014 12:16 AM
  10. areyes1010's Avatar
    I am having the same problem in NJ. I have an iPhone 6 w/ 8.1.2, an iPad Mini w/ 8.1.2, an iPad2 w/ 8.1.2, and a Mac Book Pro. It happens on every device.
    12-29-2014 12:18 AM
  11. Craig L's Avatar
    Just go to the calendar item, click on start time, and it will show you the GMT. You can then enter the time zone/city for your location. Not sure if this will fix overall but it fixes it for calendar item. Still working on it....
    12-30-2014 10:50 PM
  12. dmord's Avatar
    I just changed the view to month on the top half of the screen and day on the bottom half. Nice view and no more GMT.
    01-07-2015 10:02 AM
  13. bobbyfp's Avatar
    Try this. On iPhone, go to Settings, General, Date & Time, "Set Automatically" .....Turn this OFF. This will fix GMT Problem. Thanks.
    01-08-2015 12:51 AM
  14. Steve Penny's Avatar
    Mine seemed resolved, then all of a sudden today ....

    Is there any way to prevent my Calendar from displaying in GMT on each event?-img_0283.png
    01-08-2015 01:08 AM
  15. sjhstoltz's Avatar
    I had this problem, too. A guy at Verizon solved it for me. Try saving your calendar to the iCloud, instead of Google (gmail). That fixed it for me - really simple.
    01-16-2015 05:01 PM
  16. etrnlflame's Avatar
    Definitely didn't work. I even tried turning the override ON and setting it to my timezone and it didn't work. It just seems to be a glitch with Apple... they seem to be getting worse with every release >.< Maybe an Android will be in my future.
    02-02-2015 11:10 AM
  17. skmadden11's Avatar
    I fixed it by logging to gmail, adwords, google calendar, with my non-gmail email address. If you have ever used you primary(non gmail email address with a google product, it will also have a calendar. So, login using non gmail address, for me it was my work provided account, which is my main email on my iPhone. Use that address and log into google calendar and check the timezone. Mine was set to something other than my normal eastern time. This finally fixed the problem. Sound weird, but some how google would see that the email were going to my workemail and it added the timezone info before they were set up. My company does have some corporate google apps linked to out active directory, so this could be also part of the problem. Good Luck.
    11-05-2015 10:29 AM
42 12

Similar Threads

  1. Wifi problems with my iPhone 6
    By SciTeach3 in forum iPhone 6
    Replies: 11
    Last Post: 06-21-2015, 06:28 PM
  2. Replies: 2
    Last Post: 09-21-2014, 05:50 AM
  3. Replies: 2
    Last Post: 09-21-2014, 02:13 AM
  4. Replies: 1
    Last Post: 09-20-2014, 05:58 PM
  5. iPhone 6 having problems streaming in wifi
    By SciTeach3 in forum Ask a Question
    Replies: 1
    Last Post: 09-20-2014, 05:44 PM
LINK TO POST COPIED TO CLIPBOARD