1. iMore Question's Avatar
    what's going on ? the links show up.. you can see the 'click' happen only once
    but it doesn't go to safari like it use to.. it just stays in email
    and then re-trying it does nothing at all.

    What the heck did Apple do to mess that up?

    There are so many emails from business related subscriptions that
    one can go to see an update or a display easily by clicking the link
    in the email but now it doesn't work at all...

    Don't know why I don't see more people with this problem and an apple explanation.

    There should be no requirement to reset every setting.. that would be terrible
    but even more so I can't even find a setting that would stop this problem.
    09-27-2013 06:16 AM
  2. Just_Me_D's Avatar
    what's going on ? the links show up.. you can see the 'click' happen only once
    but it doesn't go to safari like it use to.. it just stays in email
    and then re-trying it does nothing at all.

    What the heck did Apple do to mess that up?
    Apple didn't do anything. When I tap on a link in my Mail app, I am immediately taken to the site via the Safari browser on my device.

    There are so many emails from business related subscriptions that
    one can go to see an update or a display easily by clicking the link
    in the email but now it doesn't work at all...
    Like I stated above, it works for me so you can try one of the following:

    1. Turn off your device, wait 30 seconds and then turn it back on and then see if you're taken to your browser after tapping on the link(s)
    2. backup your device via iCloud and/or iTunes and then connect it to iTunes, if you haven't already, and then select to restore it.

    Don't know why I don't see more people with this problem and an apple explanation.
    Others may not be having that problem.

    There should be no requirement to reset every setting.. that would be terrible
    but even more so I can't even find a setting that would stop this problem.
    There is no "requirement" to reset everything, but it is an available option that would more than likely fix your problem. Still, the choice is entirely up to you. You can either deal with the issue you are having or take the time to restore your device so that you won't have those problems. Still, try the reboot first. Hopefully, that will fix it for you.
    09-27-2013 09:31 AM
  3. Ipheuria's Avatar
    It's a long shot but do you have the "open links in the background" option under Safari in Settings? Have you actually opened Safari to see if your links have actually opened but Safari just didn't respond? Perhaps when you tap the links they are opening in Safari but because of the setting I mentioned Safari is not opening. I didn't think it worked that way but just a thought.
    09-27-2013 03:04 PM
  4. Jaguarr40's Avatar
    what's going on ? the links show up.. you can see the 'click' happen only once
    but it doesn't go to safari like it use to.. it just stays in email
    and then re-trying it does nothing at all.

    What the heck did Apple do to mess that up?

    There are so many emails from business related subscriptions that
    one can go to see an update or a display easily by clicking the link
    in the email but now it doesn't work at all...

    Don't know why I don't see more people with this problem and an apple explanation.

    There should be no requirement to reset every setting.. that would be terrible
    but even more so I can't even find a setting that would stop this problem.
    Apple didn't do anything. When I tap on a link in my Mail app, I am immediately taken to the site via the Safari browser on my device.

    Like I stated above, it works for me so you can try one of the following:

    1. Turn off your device, wait 30 seconds and then turn it back on and then see if you're taken to your browser after tapping on the link(s)
    2. backup your device via iCloud and/or iTunes and then connect it to iTunes, if you haven't already, and then select to restore it.

    Others may not be having that problem.

    There is no "requirement" to reset everything, but it is an available option that would more than likely fix your problem. Still, the choice is entirely up to you. You can either deal with the issue you are having or take the time to restore your device so that you won't have those problems. Still, try the reboot first. Hopefully, that will fix it for you.
    To the OP I am not by any means jumping on any bandwagon but my links are working perfectly fine and have yet to have issuew, When i click on a live link which is the key - Live , It takes me right to where it was meant to take me in Safari. Make sure these are indeed live links that whoever is sending them to you is sending you a 'Clickable' link. Good luck and thank you for thinking about coming to iMore for help.

    I hope you decide to join and become a member.
    09-27-2013 08:38 PM
  5. Paula Burke's Avatar
    I have this same problem but the real problem is that Safari disappeared with the upgrade. Gone. Can't find it anywhere even by searching. Using Chrome now but it won't open when email links are clicked... So I ask... Do you still have safari on your phone? No clue how to get it back as it is not a downloadable app.
    10-12-2013 10:25 AM
  6. warcraftWidow's Avatar
    I have this same problem but the real problem is that Safari disappeared with the upgrade. Gone. Can't find it anywhere even by searching. Using Chrome now but it won't open when email links are clicked... So I ask... Do you still have safari on your phone? No clue how to get it back as it is not a downloadable app.
    Check Settings, General, Restrictions. Inside there is an option to disable Safari.
    10-12-2013 10:41 AM
  7. kathy Vajo's Avatar
    Having same issue and not help seen posted anywhere. Ios7 really screwed up the email links. Where is the outrage?
    10-19-2013 07:43 AM
  8. Just_Me_D's Avatar
    Having same issue and not help seen posted anywhere. Ios7 really screwed up the email links. Where is the outrage?
    I highly doubt there will be outrage being that only a handful of people, in my opinion, are having this problem.
    10-19-2013 11:01 AM
  9. Eugene McDonald's Avatar
    My iPhone 5 with ios 7.03 is same. Can't click on link from email to go to the address.

    Using standard email for ios7 and Safari ios7.
    Not jail broken.
    Reset but still does not work.

    Help anyone, besides "mine is working
    11-12-2013 10:45 AM
  10. weathergeekee's Avatar
    You're not crazy, I had the same issue. Shutting the phone completely off and back on fixed the problem in my case. Press and hold the power button on the top of the iPhone for 5 seconds and then on the screen, slide the 'Slide to Power Off' indicator to off. Once the phone powers down and is off, press and hold the power button again until the iPhone comes back on and then release. The phone will then boot up and come back on. Then try your links from an email message. Hope this helps, a lot of people never turn off their iPhone and don't realize they are just in standby when the screen goes dark. Press and HOLD the power button to turn the power off just like on the old phones. Hope this works for you.
    11-24-2013 09:39 AM
  11. soder606's Avatar
    I am having a similar problem. The links that i try to insert in my emails to others no longer work. This is critical as I have a big event coming up and am unable to get the link to the invitations working.
    12-01-2013 08:38 AM
  12. Jenson Nick Steel's Avatar
    I am having the same problem with links on ios7. It drives me nuts.
    12-05-2013 11:46 AM
  13. Neilon Rocha's Avatar
    I just have sorted a same problem here...

    It was simple,
    Go to your setting - General - Restrictions
    then allow the safari..
    :-)
    01-13-2014 07:18 AM
  14. Big_Jobe's Avatar
    You're not crazy, I had the same issue. Shutting the phone completely off and back on fixed the problem in my case. Press and hold the power button on the top of the iPhone for 5 seconds and then on the screen, slide the 'Slide to Power Off' indicator to off. Once the phone powers down and is off, press and hold the power button again until the iPhone comes back on and then release. The phone will then boot up and come back on. Then try your links from an email message. Hope this helps, a lot of people never turn off their iPhone and don't realize they are just in standby when the screen goes dark. Press and HOLD the power button to turn the power off just like on the old phones. Hope this works for you.
    I was having the same issue with links in mail and the old turn it off and on again worked for me.
    04-04-2014 05:12 PM
  15. Sally Kirkpatrick's Avatar
    If you are still having problems, I had the same issue all you need to do is add the link to your reading list by holding on the link until the option comes up then go to the safari browser and into the reading list (next to browser history) and it should be there.
    04-24-2015 05:19 AM

Similar Threads

  1. Why can't I accept Outlook calendar invitations on iOS 7?
    By iMore Question in forum Ask a Question
    Replies: 5
    Last Post: 01-03-2015, 10:53 AM
  2. Going back to iOS 6
    By jphillips1963 in forum iPad 4
    Replies: 12
    Last Post: 11-09-2013, 07:53 PM
  3. Cydia Updates?
    By WreakingHavoc in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 4
    Last Post: 09-27-2013, 01:27 PM
  4. iPad 3 resetting randomly after iOS 7 installation
    By apple_power_user in forum iPad 3
    Replies: 2
    Last Post: 09-27-2013, 10:09 AM
  5. Custom grid in IOS 7.
    By stranjal7 in forum iOS 7
    Replies: 6
    Last Post: 09-27-2013, 09:29 AM
LINK TO POST COPIED TO CLIPBOARD