1. gigatigga's Avatar
    Hi everyone, i work at an apple developer shop and so i had legal access to the ios 7 beta to install on my Sprint iphone 5. Needless to say, its not ready and i wanted to attempt to go back to 6.1.4.

    Everything seems fine and dandy, the phone restores, back to 6.1.4, i get passed itunes activation and everything seems smooth...accept, my 3g data isn't working.

    My phone seems to be programmed correctly in Settings > general > about, and i'm able to use the phone and SMS portions, but 3G shows, then flips to the o (1x) icon, then finally says "unable to activate data network". I have spent hours on the phone with sprint in attempts to fix it and they are saying there is nothing wrong on their end.

    Few things, wifi is fine. also, if the phone locks on to 1x, aka the o symbol, i can get dialup like data, so there is data moving! but as soon as it sees 3g again and connects up, i'm back in this state. I have tried ##update# about a billion times, some times its successful some times it fails, but i'm at a loss here. I've tried reseating the sim card I've tired restoring back to ios 7, same problem, restored back to 6.1.4, still the same problem. i'm currently on 6.1.4 and when i step away from wifi, i'm without data. Anyone experiencing this? Any clues as to how i can get my 3g working again?
    06-14-2013 04:37 PM
  2. kch50428's Avatar
    A visit to an Apple Genius Bar may be in order... sounds like you've done everything you could do on your end of the deal...
    06-14-2013 04:41 PM
  3. Just_Me_D's Avatar
    Go to Settings-General-Reset and them select "Reset Network Settings". Afterwards, wait about 30 seconds and then reboot your iPhone. See if that'll fix it for you.
    06-14-2013 04:49 PM
  4. gigatigga's Avatar
    Sorry i forgot to mention i've done this probably 15 times it gives the same error about not activating the data connection every time
    06-14-2013 05:33 PM
  5. Laelipoo's Avatar
    You may also want to update your data profile. I've found this to be very helpful with Sprint phones.

    Steps:
    From the dial pad type in: ##873283# (##UPDATE#) and press call.A message should appear stating the update has been initiated.Once complete a new message should appear stating the update has either completed or failed. If the update fails, ensure the device is in Sprint Network coverage, power cycle the device and try again.
    06-14-2013 05:35 PM
  6. sickofsprint's Avatar
    Same prob here. Just got off the phone sprint said to take it to apple store. I can tell you I think this issue ink seems to be an issue with sprint. I have a friend in ky with a carrier by the name of bluegrass they piggy back off Verizon because they are a very small company. They have 4g lte with ios 7 and no issues at all. I know this doesn't help your issue but at least you know this is a common prob with ios7 on sprint iPhone 5. Curious to know if you found a fix
    06-17-2013 07:47 PM
  7. shx91's Avatar
    I have a sprint iPhone 4s and i'm having almost same problem... I haven't tried calling sprint yet but I was wondering if you found a solution to this problem.

    My 3G is very spotty (pretty much the o 65% of the time) and as of 24 hours after downgrading my iMessages have completely stopped working and the sprint ##Update# failed.

    anyone else having similar issues or find a solution?
    06-18-2013 07:40 PM
  8. sickofsprint's Avatar
    I think I found the problem. You need to turn off your wifi from settings as opposed to doing it from the control panel.
    06-19-2013 09:07 AM
  9. Thekid_TJ's Avatar
    Dial ##873283# then call to update your profile/PRL
    06-24-2013 11:00 PM
  10. cheesenbroccoli's Avatar
    Don't worry your not alone, Ever since Ive installed iOS 7 ive been experiencing the same issue, and I thought the iOS 7 beta 2 would have corrected the issue but it hasn't. my LTE works like a charm but when im not in and LTE coverage and its my 3g, **** doesn't want to cooperate with me and I get the 1x icon and it takes awhile for it to load just the google site
    06-26-2013 06:19 PM
  11. Tiziana Messina's Avatar
    Same issue here. I tried to turn off wifi from the settings instead of the control panel but it did not help.
    07-17-2013 04:34 PM
  12. andreget's Avatar
    I been without 3G for about 3days after downgrading ios7 beta6 to ios6.1.3 and I finally managed to get it work
    Follow this steps
    1.Turn off 3G,cellular data,& location services
    2.Reset network settings
    3.Restart phone
    4.Go to cellular data network & insert your carrier's APN (if u don't know visit carrier's site)
    5.Now turn on 3G,cellular data, and location services wait for 10 seconds
    6.After 10 seconds restart phone
    7.After this let the phone search for signal(you can turn on airplane mode & wait till carrier disappears & turn off mode again)
    8.you might have to do that 3 or 4 times finally you will get 3G back on
    If this method don't work then you must edit the network plist and delete entries of carrier info
    08-22-2013 06:08 AM
  13. andreget's Avatar
    Try turning off location service 3G & cellular data then restart your phone then enter your carrier'S APN then turn on 3G cellular data and location service restart phone again let phone search for signal either by reinserting sim or turning airplane mode on then off..if this don't work you need to edit the network plist in root directory and delete carrier entries
    08-22-2013 06:21 AM
  14. khim serrano's Avatar
    it worked to my ip4s thanks!
    09-19-2013 05:18 AM
  15. weikertd's Avatar
    Thank you. This worked for me without entering the APN of the carrier.
    09-19-2013 10:36 AM
  16. Cfc Wph's Avatar
    I have lost 3G data when I updated my iPhone 5S to ios 7.0.4. How will I fix it?
    11-20-2013 08:32 PM
  17. Just_Me_D's Avatar
    I have lost 3G data when I updated my iPhone 5S to ios 7.0.4. How will I fix it?
    Reboot your computer. You may have to go to Settings->General->Reset and then select "Reset All Settings".
    11-20-2013 08:34 PM
  18. elnafaty's Avatar
    I have tried that and all other suggestions - except visiting apple store - but still same problem, no 3G after upgrading to 7.0.4. With the multiple complaints on the problem from a wide range of users across the globe, I think the problem has to do with the software update. Please apple should do something on this.
    12-30-2013 01:22 PM
  19. Niels Seaton's Avatar
    Thanks very much for this advice - worked first time

    All services restored

    Niels
    04-26-2014 07:28 PM

Similar Threads

  1. Totally stuck after trying to downgrade from IOS 5 Beta 7
    By red-5 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 6
    Last Post: 10-05-2011, 11:03 AM
  2. Replies: 0
    Last Post: 07-30-2011, 03:46 PM
  3. How to downgrade from iOS 5 to 4.3.3
    By hpcomputergeek in forum iOS 5
    Replies: 7
    Last Post: 07-07-2011, 06:47 AM
  4. How to unlocked 3g after downgrade to iOS 3.1.3
    By dudu in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 1
    Last Post: 04-23-2011, 03:24 PM
  5. NO Cellular Data after 3.0 Update
    By elmonquis1219 in forum iPhone 4
    Replies: 10
    Last Post: 06-26-2009, 08:35 PM
LINK TO POST COPIED TO CLIPBOARD