1. jakeless.123's Avatar
    On my iPad 2 and my 4S, when i attempt to download an app on the device, it pops up and says waiting... But then nothing happens!

    I've done hard resets to no avail. I tried this on my wife's iPod touch 2nd gen and this situation did not occur.

    Any thoughts?


    Sent from my iPhone via Tapatalk
    03-17-2012 10:45 AM
  2. Just_Me_D's Avatar
    The only time I seem to see the 'waiting' prompt is when I attempt to simultaneously download several apps that I've previously downloaded and usually after I have restored my device as new. My apps still download successfully. Sometimes, I've had to tap on the app waiting to download to cause it to pause. When I tap it a second time, it downloads. Give it a try, if you haven't already.


    Just Me, D
    Tapatalk (iPhone 4S)
    03-17-2012 10:59 AM
  3. kch50428's Avatar
    Also keep in mind there are thousands upon thousands of people with upgraded and/or new iPads hitting the app store to fetch new & updated things - so patience is a virtue.
    03-17-2012 11:08 AM
  4. sherlock's Avatar
    I was updating a couple of apps last night and it took forever. I would bet its a bandwidth issue.


    Sent from my iPhone using Tapatalk
    03-17-2012 11:14 AM
  5. jakeless.123's Avatar
    Thank u everyone for your feed back! I have tried to just wait, and it eventually loads.

    I noticed this starting around thursday night, so its seems that you guys are onto something.


    Sent from my iPhone via Tapatalk
    03-17-2012 10:59 PM
  6. jakeless.123's Avatar
    Not sure if this will help anyone in the future. But since my last post the problem did not get any better until I did a restore as new & since then I have not seen any issues.
    03-24-2012 06:53 AM
  7. Just_Me_D's Avatar
    Thank you for the update and have a great weekend.


    Just Me, D
    (Tapatalk - iPhone 4S)
    03-24-2012 07:05 AM
  8. itsalexaye's Avatar
    thanks for sharing that with us.
    03-24-2012 12:03 PM
LINK TO POST COPIED TO CLIPBOARD