1. ddthld's Avatar
    Hey All,

    I have an iPad2 with iOS 5.0.1 and was wondering if anyone else is having an issue with the iTunes Wi-Fi sync. It appears that I have everything checked correctly, but it just doesn't seem to work!

    Does anyone have a solution or a workaround? Using the cable isn't that bad, but WTF I thought that this was one of the benefits of iOS 5!
    12-22-2011 10:24 PM
  2. Alli's Avatar
    The WiFi sync is hit or miss. The culprit is iTunes.
    12-22-2011 10:48 PM
  3. phessler's Avatar
    It could also be a firewall issue. I had to allow iTunes and Bonjour to have UDP access and then it works fine.
    12-23-2011 07:21 AM
  4. oklanole's Avatar
    I have the same issues with my 4s and the wife's. Both are setup properly and the wireless sync option is greyed out on both phones.

    Sent from my iPhone 4S using Tapatalk
    12-23-2011 07:47 AM
  5. Alli's Avatar
    The funny thing is my iPad always shows as connected, and syncs the instant I plug it into a power source. My iPhone...not so much.
    12-23-2011 09:07 AM
  6. SirSupernice's Avatar
    I have the same issue with my iPhone 4..
    Sometimes iTunes pops-up with the error, it couldnt sync..
    12-23-2011 08:41 PM
  7. hellomiggy's Avatar
    My answer would be, when you plug in your iDevice. Let it sync and back up and all that mess, and click the Sync using Wifi. So the box is unchecked and sync again. Close your iTunes and Plug it in again and check the box to sync over Wifi, sync it and see if it works. I notice sometimes it works, try that sometimes it works with a restart. So hopefully it works...
    12-27-2011 11:57 AM
  8. ddthld's Avatar
    I was playing around with my computer yesterday and decided to turn off its wifi and just connect the LAN cable. I then opened iTunes and was playing around when I noticed that my iP2 was recognized. I clicked sync and what do ya know it worked.

    Then today I unplugged the LAN cable and went back to the wifi connection and it doesn't work!

    So now I guess I get to dig around in my wireless settings to see if something might be blocking the connection (firewall?).

    Though this might help for others!
    01-05-2012 05:53 PM