1. DannyMichel's Avatar
    Marc, you may be onto something. I had the exact same thing happen today.

    jkk4
    Same here, for a while now


    Sent from my iPhone using Tapatalk
    11-06-2011 08:40 AM
  2. phreddyl's Avatar
    Sorry but you are incorrect here. I have used Yahoo for years and so does everyone else that I know and we have never had any problems related to Yahoo. I am also a member on some of these forums that you mentioned and there have never been "hundreds" of threads related to Yahoo. I also don't recall many threads here on TiPb related to Yahoo mail not pushing to the iPhone..... Hmm, funny how this one only came up "after" the iOS 5 update came out.
    There have been a few threads on this. Not sure why there aren't more but I know that I have had on and off issues with it not pushing for awhile now. What I was told on forums when I first looked into it was that it was a yahoo thing. Not sure why or how you have the luck but I do not. Do you have it set up as exchange? I don't I have my gmail set up as exchange. Maybe that's my issue. Not sure.
    11-06-2011 11:47 AM
  3. Eileen89's Avatar
    There have been a few threads on this. Not sure why there aren't more but I know that I have had on and off issues with it not pushing for awhile now. What I was told on forums when I first looked into it was that it was a yahoo thing. Not sure why or how you have the luck but I do not. Do you have it set up as exchange? I don't I have my gmail set up as exchange. Maybe that's my issue. Not sure.
    My statement above wasn't to say that there aren't any issues related to push mail but rather that it isn't only Yahoo and doesn't happen all the time with Yahoo as the member who I quoted was making it out to be. I have used exchange in the past with Yahoo but currently have it set up through the regular Yahoo mail. Neither one gave me issues. Not saying that Yahoo is perfect or anything, however, I have read threads where people have push issues with other email carriers as well.
    11-06-2011 12:47 PM
  4. ThePinkChameleon's Avatar
    my yahoo has been on and off today also since getting my 4S on Friday, BUT i will add, prior to my 4S i had a bb 9650, and sometimes i had issues with my yahoo email on it also.

    Yesterday i was rec'ing yahoo mails no prob, today sometimes they will come in and sometimes i had to go into the mail icon to get it to come in. Perhaps its a certain area issue thing, idk. i'm not worried really, on occassion i will ck my mail and if theres anything new it will update
    11-06-2011 08:56 PM
  5. kenh4495's Avatar
    I have had the 1st Gen iPhone, the 3-G and now the iPhone 4 and have used the same Yahoo email account and it worked flawlessly until I updated to this latest Ios5 software. That's my experience!
    11-07-2011 08:38 PM
  6. Eileen89's Avatar
    I have had the 1st Gen iPhone, the 3-G and now the iPhone 4 and have used the same Yahoo email account and it worked flawlessly until I updated to this latest Ios5 software. That's my experience!
    This is exactly the reason that I think this is a software issue.
    11-07-2011 10:22 PM
  7. bonesb's Avatar
    Sorry but you are incorrect here. I have used Yahoo for years and so does everyone else that I know and we have never had any problems related to Yahoo. I am also a member on some of these forums that you mentioned and there have never been "hundreds" of threads related to Yahoo. I also don't recall many threads here on TiPb related to Yahoo mail not pushing to the iPhone..... Hmm, funny how this one only came up "after" the iOS 5 update came out.
    Whatever. I have 32 employees, all have smartphones. I allow them to use them to check their personal stuff - they're going to do it anyway. I have a Palm Pre+ I use to ping my email and notify me when a client emails me (it's running a hacked kernel) - ALL of our smartphones fail at least weekly with Yahoo email - I came from the BBOS, and Yahoo is always failing. Going back to 2005, yeah, there's hundreds of threads *****ing about Yahoo email timing out, forgetting passwords, not pushing. So, yeah, I'm not incorrect. Yahoo email, however popular it is, uses it's own proprietary push mechanism. Look, don't pick on me - let's not get personal. I'm relating what I've read, what I've experienced, and what my employees gripe about and you've got no basis for telling me I'm incorrect.
    11-08-2011 02:25 AM
  8. Gixxer07's Avatar
    Didn't you basically say the same thing to me? Get over it. It's an Internet forum
    11-08-2011 02:43 AM
  9. Eileen89's Avatar
    Whatever. I have 32 employees, all have smartphones. I allow them to use them to check their personal stuff - they're going to do it anyway. I have a Palm Pre+ I use to ping my email and notify me when a client emails me (it's running a hacked kernel) - ALL of our smartphones fail at least weekly with Yahoo email - I came from the BBOS, and Yahoo is always failing. Going back to 2005, yeah, there's hundreds of threads *****ing about Yahoo email timing out, forgetting passwords, not pushing. So, yeah, I'm not incorrect. Yahoo email, however popular it is, uses it's own proprietary push mechanism. Look, don't pick on me - let's not get personal. I'm relating what I've read, what I've experienced, and what my employees gripe about and you've got no basis for telling me I'm incorrect.
    Nobody is picking on you or making this personal. However I'm flat out telling you that your are exaggerating very badly as there are NOT "hundreds" of threads on this yahoo issue as you have stated here. I'm a member of those other forums that you were talking about that had hundreds of threads on this topic and again, you were exaggerating. While I do come across a thread related to yahoo from time to time, it ain't hundreds and they are few and far between. I've seen the same amount of threads related to MSN mail and Gmail issues as well.....
    11-08-2011 07:44 AM
  10. body80's Avatar
    Here's something I've noticeed. When I receive an email with an attachment like a .wmv file. My email will lockup with it loading. It'll never completely load any of the email, even just the text part.

    It'll drain the battery and won't push anymore emails even after deleting the locked up email.
    Then the only way to get it to push is to delete the yahoo account and sign up again.
    I've never had this problem till OS 5.
    11-09-2011 07:18 PM
  11. jlb21's Avatar
    I've solved my particular push problems......

    The company I am consulting for has me in a cube right next to a data center. There's tons of interference with all the metal and concrete, etc.

    The client recently let me go onto their wifi with my phone and since then, push has been perfect. So at least for me, it seems like a weak cel signal can effect mail delivery......
    11-10-2011 10:16 AM
  12. jeffreys zone's Avatar
    I have had the same problem repeatedly... I have found that I go to iphone general settings, then scroll down to reset, then go to reset network settings... It works everytime for me...
    03-26-2012 09:59 AM
  13. Optic Dev's Avatar
    Even though I have my Yahoo and Outlook e-mails set to push, it seems only the Outlook account actually is doing it and the Yahoo one just sits dormant, especially when on a charger I've noticed, until I open the account then it will retrieve the e-mail, often times finally showing me stuff that was hours old that I was not alerted to earlier.

    Is this happening to anyone else. Any suggestions? I have Fetch set to an HOUR, I could try moving that up to 15 minutes but I also don't want to kill my battery either.

    I thought this happened before and it was on Yahoo's end and nothing I did fixed it until it magically started working again...
    If there is a way to set it up with Exchange, you're probably better off doing that.
    03-27-2012 01:24 PM
  14. edd's Avatar
    After I got my 4S my Yahoo account pushed pretty reliably. Funny thing is, I never had push turned on for the mail. After a few months it just stopped pushing on it's own. I don't really care because I just check it a few times a day. I figure I save a bit of battery having it turned off.
    03-30-2012 05:44 AM
39 12
LINK TO POST COPIED TO CLIPBOARD