1. kevlar x's Avatar
    The wifi network in my workplace has the type of wifi where you connect fine but then when you try to use it up pops a webpage asking for your login details. The problem is I have to enter these details every time I want to reconnect. I was in the same situation recently while staying at a hotel, I must have entered those damn login details 100 times in the five days I was there.

    Is there a way to save these details in network settings somehow? I have tried a few times but always still get the popup login screen.

    thanks in advance

    Kev
    11-01-2011 06:44 AM
  2. phoon61's Avatar
    Go into your settings, Safari.
    Enable "AutoFill" and on the next screen make sure Names & Passwords is set to ON.

    I dont see why that wont work.
    11-01-2011 10:22 AM
  3. kevlar x's Avatar
    Why didn't I think of that? Guess I was always thinking of it as a network problem, not safari. Thanks, I'll give it a try.
    11-01-2011 12:26 PM
  4. Nanci's Avatar
    I have this exact same problem. The two wifi networks where I work require log-ins to public networks, and autofill in Safari used to work, but stopped working either with iOS5 or the 4S or both. It _did_ work on the 3GS on iOS 4.3.x To avoid this, I just leave the phone on all day, but I still have to log in every morning and every time I lose the connection...
    11-01-2011 02:15 PM
  5. kevlar x's Avatar
    Update: enabling passwords in safari didn't help at all with wifi login at wok, I still have to enter username and password every time I want to reconnect.
    11-10-2011 03:43 AM
  6. Todd M's Avatar
    That's a requirement of the router. That will do that no matter what device you are using to connect. It has to re-authenticate after 'X' amount of time, or after the browser has been closed out. Security feature. You will find that on most new routers with a guest network. My Cisco router has that feature for anyone that uses the guest network.


    Guest Instructions
    When a guest wants Internet access in your home, provide
    these instructions:
    1 . On the guest computer, connect to the wireless guest
    network named on the Guest Access screen .
    2 . Open a web browser .
    3 . On the login screen, enter the password displayed on
    the Guest Access screen (password used during setup .
    4 . Click Login
    11-10-2011 06:39 AM
  7. marcinkomo's Avatar
    I believe I have figured out a solution to this 'lack of autofill' in wifi authentication problem. The following steps worked for me:

    1. Disable Auto-Login in WiFi settings for given network
      • go to Settings app
      • select "Wi-Fi"
      • tap on the blue ">" icon to the right of your network
      • disable "Auto-Login"
    2. Manually log into your WiFi authentication page using Safari (this should prompt you to remember the login as long as you have "Names & Password" AutoFill enabled in Safari Settings)
    3. Re-enable Auto-Login for your network (same steps as above)


    This got me working again. Hope it works for others.

    Cheers,
    Marcin
    11-16-2011 11:07 AM
  8. kevlar x's Avatar
    Thanks, will give it a try next time I'm in.
    11-16-2011 06:06 PM
LINK TO POST COPIED TO CLIPBOARD