1. felface's Avatar
    First i tried to upgrade my iPhone 3gs and iPad 1 to IOS 5 GM but it said that they weren't compatible i thought apple just didn't want me upgrading as a developer (strange though as it was the GM) then my dad (not a developer) with iPad on his account he notified through iTunes that IOS 5 was available then it said to him that the it wasn't compatible but iPad 1s are i don't where this problem comes from it falls when it checks with apple even though it's perfectly good and not downgrading can anybody help me please? btw i have an iMac with 10.7.2
    10-19-2011 04:26 PM
  2. kch50428's Avatar
    Make sure to run Software update on the iMac and get the latest OSX & iTunes updates, then update to iOS5.
    10-19-2011 04:32 PM
  3. felface's Avatar
    it still says the 'the iPad '---- iPad couldn't be restored because the firmware file is not compatible' any other ideas anyone on how to fix this?
    10-19-2011 05:39 PM
  4. DamienTyler's Avatar
    This is how I fixed it.


    https://discussions.apple.com/thread...rt=30&tstart=0

    Hope it works for you!
    10-20-2011 10:27 PM
  5. DamienTyler's Avatar
    it still says the 'the iPad '---- iPad couldn't be restored because the firmware file is not compatible' any other ideas anyone on how to fix this?
    Did you get this fixed?


    ---
    I am here: http://maps.google.com/maps?ll=40.210231,-88.503193
    10-25-2011 12:20 AM
  6. felface's Avatar
    Yer for some reason my computer has started to let my family update yesterday it said my mums iPad 2 was incompatible but today she updated it don't why it's just suddenly started letting letting people update
    10-25-2011 09:46 AM
LINK TO POST COPIED TO CLIPBOARD