1. RealAnthonyCamp's Avatar
    I have had my Yahoo account set up all of my iOS devices since 2007 and have never had an issue until now.

    I installed the iOS 5 GM on my iPhone 4 on Tuesday, after the keynote, and since then my Yahoo mail has been acting strange to say the least. It only shows a few messages from September 21st/22nd and shows the link under those messages that reads "Load More Messages..." When I click the link to load more messages nothing happens. I have 6 email accounts set up on my phone (2 GMail, 1 MobileMe, 1 Yahoo, and 2 Exchange) and this is the only one behaving this way. I even deleted the account in Mail settings and re-added it but it still fails.

    Anybody have any insight as to what might be going wrong?
    10-07-2011 12:44 PM
  2. Wyatt's Avatar
    Yahoo originally gave some people issues using IMAP and push. It may be that iOS 5 handles email a little differently now. I'll have to check my wife email to know for sure.
    10-07-2011 01:31 PM
  3. zackawee27's Avatar
    I have had my Yahoo account set up all of my iOS devices since 2007 and have never had an issue until now.

    I installed the iOS 5 GM on my iPhone 4 on Tuesday, after the keynote, and since then my Yahoo mail has been acting strange to say the least. It only shows a few messages from September 21st/22nd and shows the link under those messages that reads "Load More Messages..." When I click the link to load more messages nothing happens. I have 6 email accounts set up on my phone (2 GMail, 1 MobileMe, 1 Yahoo, and 2 Exchange) and this is the only one behaving this way. I even deleted the account in Mail settings and re-added it but it still fails.

    Anybody have any insight as to what might be going wrong?
    Wait, until the official iOS 5 comes out and see if that fixes you're problem.
    10-07-2011 03:03 PM
  4. immawaniac's Avatar
    I'm sure it'll be resolved soon. You might want to email Apple just to give em a heads up.
    10-07-2011 03:25 PM
  5. rstark18's Avatar
    Did you do a CLEAN restore or did you restore from a backup when you loaded GM. If you did a restore from a backup, that could be a source of problems. I know it's a PITA but you really should do a clean restore when upgrading major versions. I was helping a friend troubleshoot an iPad/Yahoo Mail problem (not the same as yours) and eventually we did a clean restore as a last resort. To my surprise it fixed his issue.

    BTW, if you're not a Dev you won't want to ask Apple about this until it's released.
    &
    The GM is the final version (unless they find some major issues) and is what will be released next week.
    Last edited by rstark18; 10-08-2011 at 02:46 AM.
    10-08-2011 02:44 AM
  6. ricko79's Avatar
    I have had my Yahoo account set up all of my iOS devices since 2007 and have never had an issue until now.

    I installed the iOS 5 GM on my iPhone 4 on Tuesday, after the keynote, and since then my Yahoo mail has been acting strange to say the least. It only shows a few messages from September 21st/22nd and shows the link under those messages that reads "Load More Messages..." When I click the link to load more messages nothing happens. I have 6 email accounts set up on my phone (2 GMail, 1 MobileMe, 1 Yahoo, and 2 Exchange) and this is the only one behaving this way. I even deleted the account in Mail settings and re-added it but it still fails.

    Anybody have any insight as to what might be going wrong?
    I have the same EXACT issue. I have 5 different emails setup, and all of them work fine after the iOS5 upgrade, except my Yahoo account. Whether it pushes or manually fetches, emails stop around Sept 20th and nothing beyond that point. New emails do not get delivered... However, if I log via a safari web session, then I see all my emails.

    Tried deleting the account, hard reset... nothing seems to restore the missing emails from Sept 20th to now and receivng new emails.

    This is odd... Cannot find any other recent threads with this issue besides this one...
    10-14-2011 12:51 AM
  7. Sansira's Avatar
    I have the exact same issue. I tried deleting and setting up yahoo mail again. My emails were only sept 20 and older. I deleted a couple and now it is sept 16 and older despite some messages existing for sept 20 up until today. I can view other folders and send messages. It seems to only impact the inbox.
    10-14-2011 01:09 AM
  8. Wefferson's Avatar
    Exactly the same for me. All other accounts work fine but yahoo won't sync properly. I've tried deleting and reinstalling the account several times but without success. All the folders have synced but there is nothing in them.

    Initially there were no messages but, after experimenting with changing the number of messages displayed (50 recent, 100 recent etc) some messages were downloaded but only up until 19 September. There was nothing more recent than that.

    It clearly knows something s wrong as it continually tries to check for mail.

    Having looked on the apple forums I see there has been a recent issue for some users with using yahoo mail with safari on the mac. I wonder if this is a related problem. I couldn't find, on the thread, anything to suggest that the problem had been addressed.

    Any suggestions?
    10-14-2011 02:26 AM
  9. ricko79's Avatar
    ok good - I am not alone!!!
    So frustrating... now I have to go through Safari and log in via the web to check my new incoming emails on Yahoo account.

    It's hard to determine if it's a Yahoo related issue to iOS 5. My Yahoo mail has been also very unstable for the past 2-3 weeks and getting support from either Yahoo or apple on these issues will be a PITA.

    I tried looking at new indexed forum posts in the past 2-3 days and no one besides "our" post seems to experience the same issue.

    Please - any nerd out there who wants to make other people happy with a solution or work around?!

    Thks
    10-14-2011 11:59 AM
  10. Sansira's Avatar
    I sent a bug report to apple. I'm sure it has something to do with ios 5. My yahoo mail has been sort of buggy but never like this. It started after ios 5. If its not solved soon, I think I'll try the apple geniuses at the store....hopefully the 4s lines will die down soon.

    Meanwhile...I did a hack. It only seems to affect the inbox. Create a folder, for example, Inbox2. Create a filter that forwards all emails to that folder. I had to do this using a computer web browser. I don't think they allow creation of filters from mobile clients. I just created the filter so all messages with a recipient containing an s, get forwarded. Both my name and email address have an s so this does all emails. I was able to fetch the emails. I'm still trying to test if push will work but fetch is better than nothing!
    Last edited by Sansira; 10-14-2011 at 01:15 PM.
    ilikerice likes this.
    10-14-2011 12:57 PM
  11. ricko79's Avatar
    Where did you report it? I'll do the same... That can't hurt if more than one reports the same issue.

    Thanks...
    10-14-2011 02:23 PM
  12. ilikerice's Avatar
    Yep, same exact problem here. I hate to revert to the old OS. Please help! Ideas of where to report it? I have told Yahoo...
    10-14-2011 07:07 PM
  13. bonesb's Avatar
    ok good - I am not alone!!!
    So frustrating... now I have to go through Safari and log in via the web to check my new incoming emails on Yahoo account.

    It's hard to determine if it's a Yahoo related issue to iOS 5. My Yahoo mail has been also very unstable for the past 2-3 weeks and getting support from either Yahoo or apple on these issues will be a PITA.

    I tried looking at new indexed forum posts in the past 2-3 days and no one besides "our" post seems to experience the same issue.

    Please - any nerd out there who wants to make other people happy with a solution or work around?!

    Thks
    FWIW, it's not just us, Yahoo Mail has had issues just about every day for the past few weeks. One of the first places I hit up for Yahoo Mail status is here: Is Yahoo Mail down? Check status and report outages at downrightnow - they reported that their last major disruption was just yesterday. I have a couple of devices talking to one account we have related to my domain (one iOS and one WebOS, and both have been kicked out several times this week and regularly prompting for a password. I'm just about done with Yahoo's web services. YMMV...
    10-14-2011 09:48 PM
  14. ehwang's Avatar
    I too had the same problem. the email on one of two yahoo account stopped at Sept 14. I observed those emails from Sept 14 to Sept 21 (~1 weeks) were not accessible ("There appears to be a problem loading the email "..." <retry>). Once I moved those emails to another folder (still not accessible). The inbox was back to normal. I suspect there could be something in these email contents and iOS5 is just more rigid to retrieve the email contents. Hope this helps
    10-14-2011 10:45 PM
  15. ricko79's Avatar
    I too had the same problem. the email on one of two yahoo account stopped at Sept 14. I observed those emails from Sept 14 to Sept 21 (~1 weeks) were not accessible ("There appears to be a problem loading the email "..." <retry>). Once I moved those emails to another folder (still not accessible). The inbox was back to normal. I suspect there could be something in these email contents and iOS5 is just more rigid to retrieve the email contents. Hope this helps
    i know what you're talking about. In the past few weeks, there are several emails (either in inbox, send or custom folders) that are were no longer accessible. You can click on it but you cannot see its details - it keeps displaying an error message. The funny thing is that I was no longer using the web interface in the last 2 weeks since I had better performance directly with my iPhone and iOS4. The initial issue reported here started immediately after the upgrade to iOS5.

    Someone suggested today that I forward all my Yahoo mail to my Gmail accnt until this is resolved (since receiving Gmail via iPhone is not an issue with iOS5). I tried doing that just a few minutes ago and the forward option in the Yahoo option says "We are experiencing issues, please try later". ****TY web mail....
    10-14-2011 10:55 PM
  16. ilikerice's Avatar
    I sent a bug report to apple. I'm sure it has something to do with ios 5. My yahoo mail has been sort of buggy but never like this. It started after ios 5. If its not solved soon, I think I'll try the apple geniuses at the store....hopefully the 4s lines will die down soon.

    Meanwhile...I did a hack. It only seems to affect the inbox. Create a folder, for example, Inbox2. Create a filter that forwards all emails to that folder. I had to do this using a computer web browser. I don't think they allow creation of filters from mobile clients. I just created the filter so all messages with a recipient containing an s, get forwarded. Both my name and email address have an s so this does all emails. I was able to fetch the emails. I'm still trying to test if push will work but fetch is better than nothing!


    THANKS!! I did the same and moved all messages prior to 10/12 (which was the most recent message that my iPhone would fetch for me) into a folder and out of my inbox. Suddenly my iPhone fetches messages just fine as it did before.

    Happy days are here again...
    Thomas
    10-15-2011 10:20 AM
  17. ricko79's Avatar
    THANKS!! I did the same and moved all messages prior to 10/12 (which was the most recent message that my iPhone would fetch for me) into a folder and out of my inbox. Suddenly my iPhone fetches messages just fine as it did before.

    Happy days are here again...
    Thomas
    Wow... that worked as well for me, and i mean... it instantly worked. How strange...

    smile smile - I'm a happy camper again!

    thank you.
    10-16-2011 12:14 AM
  18. mhk1999's Avatar
    I too have had problems since updating to ios 5. Strange thing is that I have 2 accounts at yahoo mail. Account 1 will not fetch or load additional messages. Account 2 works fine. I've deleted the accounts and set up only one at a time with no luck in getting Account1 to work. I've restored the iphone, no luck. Yahoo says on their site they are working with AT&T to resolve issues.
    10-16-2011 09:06 AM
  19. mr4523mr's Avatar
    I am having terrible problems using Yahoo folders on the iPad 2 (ios 5). The folders all show up and 99% of the time, I can move e-mails from one folder to the next. 1% of the time, however, they will appear (on the iPad) to move to the folder, but those e-mails either do not appear in the folder on my PC, or the e-mail header (with the From and Date info) will appear on the PC in the folder, but when I click it, I get "Error #4" and a message saying, "Your message doesn't seem to be here. Maybe you moved it or deleted it?" It's very frustrating and there seems to be no discernible pattern! Has anyone else had this problem?
    12-01-2011 11:24 PM
LINK TO POST COPIED TO CLIPBOARD