1. anishkurup's Avatar
    As it used to happen before, the GPRS setting for my Carrier is not getting detected by iOS 5 beta 7. But earlier there used to be an option to define Customer APN setting at Setting->General->Network->Cellular Data.

    But in iOS 5 beta 7 the Cellular Data Option is missing.

    Can someone help me in defining the custom APN setting as the GPRS is no longer working on my phone?


    Thanks
    09-02-2011 12:11 PM
  2. TheNightMare's Avatar
    I have the same problem no cellular data option
    09-02-2011 01:46 PM
  3. hggs's Avatar
    APN manual settings depend on the carrier profile that is sent to your phone when it first connects to their network, whenever they push it out, or when you reset your phone. If the carrier is not an official iPhone carrier, your iPhone will show the manual settings. If they are an official iPhone carrier, they have the choice of leaving the option in or removing it.

    My best thought on your problem is that it is not a beta issue, but a carrier issue. It seems your phone did not get your carrier profile before, but now it has. Please try contacting your carrier if they officially support manual APN settings. If not, then the only other option is to JailBreak your phone.
    Last edited by hggs; 09-03-2011 at 10:47 AM.
    09-02-2011 02:34 PM
  4. TheNightMare's Avatar
    Thanks for your reply, I did not face this problem neither with
    previous official or beta versions.
    I found this in another forum and it solved my problem

    Those with the data not working. I had the same problem.

    Here's how to "solve" it.

    Go (with iPhone, so wifi is needed) to help.benm.at -> tethering -> create your own.

    Fill in the fields, download/install it and reboot.

    The menu does not appear, but data network works now.
    anishkurup likes this.
    09-02-2011 02:53 PM
  5. hggs's Avatar
    Good to know you got it working, forgot about the benm.at profiles.
    09-02-2011 05:35 PM
  6. drusman's Avatar
    Hi there!

    The above feature does appear to solve the issue as I wasn't able to use my data due to lack of APN settings and now I can. But the Personal Hotspot which has been there in every iOS 5 beta till "beta 6" has not appeared even after creating a custom profile with benm.at profile even though my carrier fully allows tethering!

    Any suggestions?
    09-04-2011 08:12 AM
  7. anishkurup's Avatar
    benn.at profile has solved my problem for the time being..

    Thanks for providing the resolution....
    09-17-2011 03:19 AM
  8. djevolushun's Avatar
    Can someone make a custom one for tmobile? I'm afraid of doing it wrong. I'd hate to brick my phone now!
    09-18-2011 11:39 AM
  9. djevolushun's Avatar
    I guess I should clarify that I am not jailbroken but rather have a factory unlocked iPhone 4.
    09-18-2011 11:52 AM
LINK TO POST COPIED TO CLIPBOARD