1. Voojtaa's Avatar
    I've spent two days trying to restore/downgrade my iPad 2 from iOS 5 beta 4 to 4.3.x firmware. I tried EVERYTHING, but I still get errors like (This device is not eligible..., error 1604, error 11, ...). I've tried edit the hosts file, restoring in iTunes 10.5, iTunes 10.4, iTunes 10.3.1, restoring to 4.3.3, 4.3.4, 4.3.5, restoring from downloaded ipsw file, restoring by just clicking on "Restore" - NOTHING I didn't get any reply on Czech iPad forum, so I've decided to ask here. Please help me.

    P.S. I don't have any SHSH backup.
    08-04-2011 04:11 PM
  2. Xm_jdm's Avatar
    Good luck. My friend is trying to do the same thing and is having some similar problems. I almost went the beta route but decided to wait.
    08-06-2011 10:47 AM
  3. Alli's Avatar
    If you'll scan the iOS 5 forum, where this thread is now located, you'll see that the recommended method for downgrading is to put the device in DFU mode and then restore.
    08-06-2011 10:11 PM
  4. itsalexaye's Avatar
    or if you search, you'll find threads for each of the different beta's to downgrade to 4.3.3
    08-06-2011 10:45 PM
  5. llfloyd79's Avatar
    Also make sure you using the latest release iTunes to restore.....not iTunes Beta 5
    08-07-2011 02:30 PM
  6. iHaK_iOs's Avatar
    if u dont have your SHSH saved u cant restore.
    08-08-2011 01:55 PM
LINK TO POST COPIED TO CLIPBOARD