1. pr1nce's Avatar
    My email notification badges are not working consistently. It’s been hit and miss for awhile. I’ve checked all notifications, rebooted my device, turned off badges and turned them back on. Any suggestions?
    01-18-2019 10:37 PM
  2. salscott's Avatar
    My email notification badges are not working consistently. It’s been hit and miss for awhile. I’ve checked all notifications, rebooted my device, turned off badges and turned them back on. Any suggestions?
    Since the last update, mine don't work at all- just on email
    01-18-2019 10:46 PM
  3. pr1nce's Avatar
    Since the last update, mine don't work at all- just on email
    Mine works fine on everything except email.
    01-18-2019 10:57 PM
  4. eyecrispy's Avatar
    What iOS version are you using? I haven’t noticed that but will check.
    01-19-2019 04:43 AM
  5. doogald's Avatar
    What is your email service? Is it set to push, fetch, or automatic, and, if it’s fetch, how long between checking for mail?
    01-19-2019 07:14 AM
  6. pr1nce's Avatar
    What iOS version are you using? I haven’t noticed that but will check.
    I’m on iOS 12.1.2. My wife is having the same problem on iOS 12.1.
    01-19-2019 08:11 AM
  7. pr1nce's Avatar
    What is your email service? Is it set to push, fetch, or automatic, and, if it’s fetch, how long between checking for mail?
    I have 3 email services. Gmail, AOL and a work Exchange account. Gmail and AOL are set to fetch every 15 minutes, the Exchange account is pushed.
    01-19-2019 08:14 AM
  8. doogald's Avatar
    A few things I might check:

    Settings/Cellular. Is mail turned on?

    I might also think about deleting the mail accounts and them adding them back, to see if that makes it better. (Maybe corruption in the data storage for the account?)
    01-19-2019 08:21 AM
  9. pr1nce's Avatar
    A few things I might check:

    Settings/Cellular. Is mail turned on?

    I might also think about deleting the mail accounts and them adding them back, to see if that makes it better. (Maybe corruption in the data storage for the account?)
    Mail is turned on under Cellular. I think I’ll try deleting the email accounts. I think my personal accounts are better than my work account. I might have to wait until Monday to delete my work email account.

    Thanks for the suggestions.
    01-19-2019 08:29 AM

Similar Threads

  1. Delivered not showing underneath message
    By frz_23 in forum iMessage
    Replies: 7
    Last Post: 02-07-2019, 06:59 AM
  2. Why my iphone 7 back camera not working
    By Rashid Moideen in forum Ask a Question
    Replies: 2
    Last Post: 01-22-2019, 02:00 AM
  3. Traffic Not Showing
    By matt3166 in forum CarPlay
    Replies: 2
    Last Post: 01-18-2019, 09:06 PM
  4. Do Bluetooth headphones work with all Fitbit devices?
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 01-18-2019, 02:12 PM
  5. What is USB-PD and how does it work with Apple's Smart Battery Case?
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 01-17-2019, 08:51 AM
LINK TO POST COPIED TO CLIPBOARD