1. Graham Lee77's Avatar
    I own a multitude of devices which are all up to date.

    iPhone X with iOS12.
    MacBook Pro 2015 with macOS Mojave.
    iPad Pro 10.5” with iOS12.

    Both my iPhone and MacBook prompt password for websites that I’ve saved in Safari.

    However, my iPad Pro isn’t.

    They are all synced correctly with iCloud, the password and account settings show the usernames and passwords and they are not any different between the devices.

    However, for example opening a site on my phone which requires login details on my phone correctly prompts the password to appear above the keyboard. Opening the same site on my iPad does nothing and I have to type in both the username and password manually.

    This occurs on every site I have that I need to log in to.

    This worked fine before updating to iOS12 on the iPad, as it I use to access work related features when I cannot use my MacBook Pro. As you can imagine, there are lots of different logins and passwords to remember, which is why I rely on the Keychain.

    Is there anyway of resetting this on the iPad so it can clear up the error, or perhaps clear the cache?

    Thanks
    10-06-2018 02:31 AM
  2. Tartarus's Avatar
    I own a multitude of devices which are all up to date.

    iPhone X with iOS12.
    MacBook Pro 2015 with macOS Mojave.
    iPad Pro 10.5” with iOS12.

    Both my iPhone and MacBook prompt password for websites that I’ve saved in Safari.

    However, my iPad Pro isn’t.

    They are all synced correctly with iCloud, the password and account settings show the usernames and passwords and they are not any different between the devices.

    However, for example opening a site on my phone which requires login details on my phone correctly prompts the password to appear above the keyboard. Opening the same site on my iPad does nothing and I have to type in both the username and password manually.

    This occurs on every site I have that I need to log in to.

    This worked fine before updating to iOS12 on the iPad, as it I use to access work related features when I cannot use my MacBook Pro. As you can imagine, there are lots of different logins and passwords to remember, which is why I rely on the Keychain.

    Is there anyway of resetting this on the iPad so it can clear up the error, or perhaps clear the cache?

    Thanks
    On the iPad, go to Settings > iCloud and see if Keychain is enabled.
    If not, enabling it will fix your issue.

    If it was already enabled, go to TouchID & Passcode in Settings and enable Password Autofill.

    If both steps where already enabled, see if disabling and re-enabling will fix it.
    Annie_8plus and doogald like this.
    10-06-2018 02:45 AM
  3. Graham Lee77's Avatar
    On the iPad, go to Settings > iCloud and see if Keychain is enabled.
    If not, enabling it will fix your issue.

    If it was already enabled, go to TouchID & Passcode in Settings and enable Password Autofill.

    If both steps where already enabled, see if disabling and re-enabling will fix it.
    Yeah did try that.

    At first I thought it was because the main one I use when remote comes up as insecured in the browser, but on my iphone it prompts the username and password for that site, so its not that the browser thinks its insecure.

    I’ve removed the keychain and re-enabled it in the hopes of syncing it again, and checked the options under Touch ID and Passcode and they all look normal.

    Bemused about this one.
    10-07-2018 02:21 AM

Similar Threads

  1. Make computing fun for a senior citizen near you!
    By iMore.com in forum iMore.com News Discussion
    Replies: 12
    Last Post: 10-11-2018, 12:41 PM
  2. Replies: 9
    Last Post: 10-08-2018, 03:44 PM
  3. Should I upgrade my iPad Air 2 or iPhone 6S
    By jtsang777 in forum Ask a Question
    Replies: 11
    Last Post: 10-07-2018, 05:06 AM
  4. Any good cases for 2018 MacBook Pro?
    By JB184351 in forum MacBook Pro
    Replies: 1
    Last Post: 10-05-2018, 07:49 PM
  5. Replies: 2
    Last Post: 10-05-2018, 04:27 PM
LINK TO POST COPIED TO CLIPBOARD