1. ckpeck's Avatar
    My Comcast internet is running at 10-13 mbs, yet when I download a movie from iTunes the download takes many hours.

    I can run a speed test on my Mac and it will say 12 mbs, but run the speed test on my iPhone and it says 1 mbs or less.

    Do I have some setting goofed up? Any ideas why it would be doing this?

    Karen in Colorado
    03-27-2010 12:00 PM
  2. applejosh's Avatar
    Depending on which SpeedTest app you're using (I assume you're using one of these on the iPhone), I would try a different server in the settings. I've had widely diverse results depending on the server being used.
    03-27-2010 02:15 PM
  3. Ol!ver's Avatar
    It's probably down to the iPhone's slow WiFi. Could also be a security thing - turning WEP off on my router and using MAC filtering sped things up for me.
    03-27-2010 03:43 PM
  4. Entrical's Avatar
    I set my phone to DMZ and it sped it up a lot.
    03-27-2010 03:44 PM
  5. Thanuja's Avatar
    I checked my speed here ScanmySpeed : Check my Internet Speed . it provides exact solution at free cost & very good in services
    Last edited by Thanuja; 04-27-2011 at 08:32 PM.
    04-27-2011 08:27 PM
  6. chrisallen's Avatar
    Hi every one, I am newbie to this forum and hope that i might be able to having lot of sharing by the members.
    04-28-2011 06:16 AM
  7. sting7k's Avatar
    My Comcast internet is running at 10-13 mbs, yet when I download a movie from iTunes the download takes many hours.

    I can run a speed test on my Mac and it will say 12 mbs, but run the speed test on my iPhone and it says 1 mbs or less.

    Do I have some setting goofed up? Any ideas why it would be doing this?

    Karen in Colorado
    Reset your modem and router, try putting router in single channel mode and not mixed; either 'g' or 'n' only. Then reset your iPhone and try again. I also have Comcast and get the same 15Mbps on my computers and iPhone.
    04-28-2011 09:47 AM
  8. fftaz336's Avatar
    Dumb question, but is your WIFI on on your phone? Just had to ask sorry. I too have 15mbps ISP and get that on computers and iPhone.

    What kind of router do you have. My experience is that the Belkins do not play nice with Mac products. I had a Belkin and all the PCs could connect and surf. My Macs kept disconnecting after a few seconds. I haven't had a problem since I got rid of the Belkin.


    Sent from my iPhone using Tapatalk
    04-28-2011 07:20 PM
LINK TO POST COPIED TO CLIPBOARD