Reddit for iPhone and iPad now requires iOS 13 or later to work

Printable View