1. Joma1124's Avatar
    recently (may be because of new update 8.4) my imessage sneds photos then ages later I get the "message failed to deliver" also people I have been messaging says they are receiving from my email instead frm my number. I checked online and did EVERYTHING and NOTHING.....its still greyed out. I signed off all (imessage, facetime, icloud) did a network reset, NOTHING please help
    07-02-2015 05:11 PM
  2. bamf-hacker's Avatar
    Did this happen yesterday or just now?

    Yesterday Apple had a site outage that effected a lot of cloud services including iMessage. It was not all customers but some. I was having weird messaging issues for most of the day.
    07-02-2015 05:15 PM
  3. Just_Me_D's Avatar
    I'm experiencing the same thing, but, in my regard, it started with Apple iCloud problems yesterday. I can only assume they are still experiencing issues. Then again, I've yet to reboot my iPhone and it's only happening occasionally. I'm running beta 2 of iOS 9, by the way.
    07-02-2015 05:16 PM
  4. Joma1124's Avatar
    Did this happen yesterday or just now?

    Yesterday Apple had a site outage that effected a lot of cloud services including iMessage. It was not all customers but some. I was having weird messaging issues for most of the day.
    the message failed to deliver would happen very random about a month already, its happened all he time now since the update. my number was never greyed out in the "you can be reached by imessage at"
    07-02-2015 05:22 PM
  5. BreakingKayfabe's Avatar
    For the e-mail address issue:

    Go to Settings - Messages - Send & Receive and SIGN OUT of your Apple ID at the top of that screen. Sign back in and then choose your send & receive addresses. You can uncheck the e-mail address if you don't want that to show up as an address for others.
    07-02-2015 05:27 PM
  6. Joma1124's Avatar
    For the e-mail address issue:

    Go to Settings - Messages - Send & Receive and SIGN OUT of your Apple ID at the top of that screen. Sign back in and then choose your send & receive addresses. You can uncheck the e-mail address if you don't want that to show up as an address for others.
    did that already. If I do that and take away the email, I cant send ANY imessages at all, all that happens is the red exclamation mark with "not delivered'
    07-02-2015 05:31 PM
  7. BreakingKayfabe's Avatar
    did that already. If I do that and take away the email, I cant send ANY imessages at all, all that happens is the red exclamation mark with "not delivered'
    So your phone number doesn't come out as an option?
    07-02-2015 05:41 PM
  8. Ledsteplin's Avatar
    Uncheck email in send and receive! I had to do that on our phones after iOS 8 started.
    07-02-2015 05:44 PM
  9. Joma1124's Avatar
    So your phone number doesn't come out as an option?
    not at all
    07-02-2015 05:46 PM
  10. Joma1124's Avatar
    Uncheck email in send and receive! I had to do that on our phones after iOS 8 started.
    if I do that I cannot send any imessages at all
    07-02-2015 05:47 PM
  11. Ledsteplin's Avatar
    if I do that I cannot send any imessages at all
    The number always looks greyed out. Mine does. That's so it can't be changed to a different number. It should work fine if you uncheck the email addresses. You would only need those if you were using an iPad.
    07-02-2015 05:50 PM
  12. BreakingKayfabe's Avatar
    not at all
    I'm assuming you're using an iPhone.

    This is what seems to be the problem regarding your phone number not showing up. It's not registering for some reason. Best I could recommend is turning off Wifi so you're on a cellular connection, re-boot the phone and then go through the steps I described and see if the phone number shows up as an option. Remember to do this while NOT being connected to Wifi.
    07-02-2015 05:51 PM
  13. Joma1124's Avatar
    I'm assuming you're using an iPhone.

    This is what seems to be the problem regarding your phone number not showing up. It's not registering for some reason. Best I could recommend is turning off Wifi so you're on a cellular connection, re-boot the phone and then go through the steps I described and see if the phone number shows up as an option. Remember to do this while NOT being connected to Wifi.
    I will try that, thanks! hope that does the trick.....so annoyed by this.
    07-02-2015 06:03 PM
  14. Joma1124's Avatar
    I'm assuming you're using an iPhone.

    This is what seems to be the problem regarding your phone number not showing up. It's not registering for some reason. Best I could recommend is turning off Wifi so you're on a cellular connection, re-boot the phone and then go through the steps I described and see if the phone number shows up as an option. Remember to do this while NOT being connected to Wifi.
    that seemed to do the trick! cheers mate! thanks
    BreakingKayfabe likes this.
    07-03-2015 11:50 AM
  15. BreakingKayfabe's Avatar
    that seemed to do the trick! cheers mate! thanks
    You're welcome. Glad you got it fixed.
    07-03-2015 12:55 PM

Similar Threads

  1. Replies: 4
    Last Post: 07-04-2015, 11:27 AM
  2. Why won't iMessage and Facetime let me login?
    By iMore Question in forum iMessage
    Replies: 1
    Last Post: 07-02-2015, 03:30 PM
  3. Whatsapp photos backup problem
    By Zivfr1 in forum WhatsApp
    Replies: 0
    Last Post: 07-01-2015, 05:12 PM
  4. Replies: 8
    Last Post: 07-01-2015, 03:13 PM
  5. Problems with official 8.4
    By Miska Hietala in forum Ask a Question
    Replies: 2
    Last Post: 07-01-2015, 01:35 AM
LINK TO POST COPIED TO CLIPBOARD