Home iMore Q&A > iMessage

Why won't iMessage send from my phone number only my email?

Asked: Apr 06 2015 | 11:21 am EDT 38805 Views 8 Answers View Best Answer

I just load some music onto the phone and now it sends imessages from my email account, not my phone number ... help please :-(


Best Answer

326
Apr 06 2015 | 11:29 am EDT anon6040766

I just load some music onto the phone and now it sends imessages from my email account, not my phone number ... help please :-(
Go to settings, then Messages, the scroll down to Send and Receive, make sure your phone number appears instead of your email. If your email is there, click on it and on the next screen check off your phone number and uncheck email.

More Answers

21,046
Apr 06 2015 | 11:28 am EDT kch50428

Settings...messages...send & receive....start new conversations from... Select your phone number.
52,656
Apr 06 2015 | 12:51 pm EDT Just_Me_D

I just load some music onto the phone and now it sends imessages from my email account, not my phone number ... help please :-(
Loading music your iPhone did not cause the iMessage app from sending & receiving messages via your phone number. You made a change in the settings, probably inadvertently. Anyway, do what has already been suggested and then you should be fine.
43,611
Apr 06 2015 | 3:49 pm EDT Ledsteplin

Go to send and receive and uncheck all the email addresses.


Sent from my ancient but trustworthy iPhone 5. ☮
1
Oct 06 2015 | 10:50 am EDT PisazzCreations

Hi, if I unclick my email it now won't send iMessages.
1
May 28 2016 | 8:28 am EDT Erzi Fantage

I know you probabaly fixed it but with my phone, it won't let me click my phone number and it loads forever!
2
Sep 25 2017 | 3:38 am EDT golden_slumber

Always a spinning wheel in the left of my phone number. Tried lots of method but they didn't work. Frustrating!
16,160
Sep 25 2017 | 4:05 am EDT Tartarus

Always a spinning wheel in the left of my phone number. Tried lots of method but they didn't work. Frustrating!
Log out of iMessage with your Apple ID, disable iMessage, restart your iPhone, enable iMessage and then log in with your Apple ID in iMessage.