1. anon6040766's Avatar
    I recently discovered there is a setting that keeps other platforms from receiving messages from iOS users.

    I have a lot of friends using Android and a few using BlackBerrys. As a new iOS user I was confused when they kept saying they were not getting my messages.

    I called Apple Care and apparently in the Message Settings the default is to send as iMessage only. You have to manually change your phone to "Send as SMS if iMessage Unavailable".

    So essentially none of the texts I sent for like the first week I had my iPhone got to anyone who didn't have an iPhone. To test this out, I text my work phone and wasn't getting messages. Switched the option and started getting them.

    While I really like the iPhone and am glad to have switched, why would they set it so the default wouldn't send texts to other platforms? How many people out there don't know about this?

    You'll see the last setting. If you don't have it turned on then you can't text people without iPhones?

    iOS non-users not getting messages...-imageuploadedbyimore-forums1388901512.327375.jpg

    Sent from my iPhone 5s on VZW from Philly
    serglb likes this.
    01-05-2014 12:59 AM
  2. Just_Me_D's Avatar
    I'm not sure if that's entirely true. In my experience, and it's been a while, I was able to send SMS messages to non-iOS devices whether that option was enabled or not. I was also under the impression that since iMessages is defaulted to send an iMessage to iOS users, the above "Send as SMS" option is more of a fail safe mechanism in case of problems with iCloud or other Apple services that affect the sending of iMessages.
    iOS Gravity and nikkisharif like this.
    01-05-2014 09:42 AM
  3. i7guy's Avatar
    The reason it probably isn't turned on, is so unsuspecting users don't get dinged by carriers on a per-sms charge if there is no sms plan on their account.

    What I don't know, is if the iphone notifies you if sms messages weren't delivered.
    01-05-2014 10:37 AM
  4. Just_Me_D's Avatar
    The reason it probably isn't turned on, is so unsuspecting users don't get dinged by carriers on a per-sms charge if there is no sms plan on their account.

    What I don't know, is if the iphone notifies you if sms messages weren't delivered.
    I don't *think* so.
    01-05-2014 10:53 AM
  5. SwitchBeach's Avatar
    I have that setting turned to "Off" on my iPhone and my text messages get delivered to iOS and non-iOS users just fine.
    01-05-2014 11:20 AM
  6. acerace113's Avatar
    I don't *think* so.
    It won't let you know if the SMS message is delivered but it will let you know if the message failed to send.


    Sent from my iPhone 5S or 5th gen iPod Touch using Tapatalk
    Just_Me_D and Mutt224 like this.
    01-05-2014 11:47 AM
  7. Just_Me_D's Avatar
    You are spot-on. I knew it was something like that. Thank you.
    01-05-2014 11:50 AM
  8. anon6040766's Avatar
    I have a different platform form work. If I don't have the "Send as SMS when iMessage unavailable" enabled, my work phone does not receive the texts I send from my iPhone. When I enable the option I get texts. It's weird...

    The weirder part is my company is now BYOD so lots are switching over to iPhones and nobody is getting their texts.


    Sent from my iPhone 5s on VZW from Philly
    01-05-2014 12:46 PM
  9. Jaguarr40's Avatar
    The first answer the 'D provided about iMessage being sent as default and SMS as a fail safe has always been my impression as well. i have also noticed that when my message starts out as an iMessage because it is in blue and then I look and see it was changed and delivered as SMS because of the green color, The person tells me they were not on WIFI. Now whether this has anything to do or not or just at that time I can't say but that is what is so cool because it is going to know if it is a non-IOS device and send the message accordingly.
    01-05-2014 03:19 PM
  10. iOS Gravity's Avatar
    Agree with D.
    01-05-2014 03:25 PM
  11. tigerinexile's Avatar
    When this matters is if you have friends who had iPhones and have now switched to other platforms. So Apple will think that they can receive iMessages when they actually can't. In those situations the send as SMS setting is good. (it's bad if you're travelling with a local sim without unlimited international texts to back home -- can accidentally get dinged for that intl txt if your friend's phone isnt on to receive an iMessage.)

    Sent from my SGP312 using Tapatalk
    01-07-2014 10:20 AM
  12. hockey1299's Avatar
    I recently discovered there is a setting that keeps other platforms from receiving messages from iOS users.

    I have a lot of friends using Android and a few using BlackBerrys. As a new iOS user I was confused when they kept saying they were not getting my messages.

    I called Apple Care and apparently in the Message Settings the default is to send as iMessage only. You have to manually change your phone to "Send as SMS if iMessage Unavailable".

    So essentially none of the texts I sent for like the first week I had my iPhone got to anyone who didn't have an iPhone. To test this out, I text my work phone and wasn't getting messages. Switched the option and started getting them.

    While I really like the iPhone and am glad to have switched, why would they set it so the default wouldn't send texts to other platforms? How many people out there don't know about this?

    You'll see the last setting. If you don't have it turned on then you can't text people without iPhones?

    Click image for larger version. 

Name:	ImageUploadedByiMore Forums1388901512.327375.jpg 
Views:	128 
Size:	85.7 KB 
ID:	45451

    Sent from my iPhone 5s on VZW from Philly
    Thats why i switched iMessage off i feel more free now.. and no controlled. I dont like iMessage i suggest shutting it off if you have Unlimited Texting it would be the same and texts messages are always available. Also while travelling you will still get texts which is better than waiting for iMessage whoich needs interent which is expensive aborad.
    01-07-2014 10:27 AM
  13. BreakingKayfabe's Avatar
    "Send as SMS" is really a setting to force the phone to eventually send an iMessage as an SMS if the iMessage user eventually
    doesn't receive your message after a set amount of minutes. If you send me an iMessage and I'm in a horrible coverage area
    where I'm getting no data, your message won't be delivered until it eventually is sent as an SMS through the carrier.
    01-08-2014 02:08 PM
  14. anon6040766's Avatar
    "Send as SMS" is really a setting to force the phone to eventually send an iMessage as an SMS if the iMessage user eventually
    doesn't receive your message after a set amount of minutes. If you send me an iMessage and I'm in a horrible coverage area
    where I'm getting no data, your message won't be delivered until it eventually is sent as an SMS through the carrier.
    Correct, but what if I'm an Android or BlackBerry user. The iOS default setting ensures that the message never reaches the intended recipient.

    Here's an example. Let's say I decide tomorrow to switch to a BlackBerry. How do I get texts from iPhones when most Apple users don't know to change the setting?

    Let me just lay it out. I received an iPhone as a gift so gave it a shot. While I like it. I prefer to go back to my BB Z30. But now I know if I switch, I won't be for the most part receiving SMS/text from iPhones...so I'm stuck


    Sent from my iPhone 5s on VZW from Philly
    01-08-2014 02:51 PM
  15. BreakingKayfabe's Avatar

    Here's an example. Let's say I decide tomorrow to switch to a BlackBerry. How do I get texts from iPhones when most Apple users don't know to change the setting?
    Because at some point whenever their phone is turned off or rebooted, the app will recognize that your phone number is no longer active on iMessage. I agree with you though. That setting was always turned on by default since iMessage was introduced and turned off by default when iOS7 hit the public.
    01-08-2014 02:57 PM
  16. jburke82's Avatar
    I'm with JustMe'D....that on/off switch only pertains to iMessages being sent to another iOS device. If "Send as SMS" is "Off", and iMessages are down for one reason or another, the message won't go through. With it switched to "On", the device will try to send an iMessage, but if there is an issue it will convert it and send as an SMS.

    I have had this switch both on and off, and have had no issue texting anyone using an iPhone, Android device, or any other os. Could this be more of an issue with your work network maybe?
    01-10-2014 05:59 PM
  17. anon6040766's Avatar
    I'm with JustMe'D....that on/off switch only pertains to iMessages being sent to another iOS device. If "Send as SMS" is "Off", and iMessages are down for one reason or another, the message won't go through. With it switched to "On", the device will try to send an iMessage, but if there is an issue it will convert it and send as an SMS.

    I have had this switch both on and off, and have had no issue texting anyone using an iPhone, Android device, or any other os. Could this be more of an issue with your work network maybe?
    Nope, problem resolved. It works both ways. Once a phone sends an iMessage or receives an iMessage both phones recognize each other as iDevices. If either party switches to another platform they stop receiving messages from iDevices unless they did one of the following three:

    1) A full reset erase all content back to factory settings
    2) Turned iMessage off before turning their phone off
    3) If they didn't do either they have to go to the Apple Profile Support Site, login and deactivate the device from their iTunes account

    Essentially, everybody here was partially right and I appreciate your insights. Sorry if it seemed like I was disregarding your answers, just knew it was more than a coincidence, that's all!


    Sent from my iPhone 5s on VZW from Philly
    01-10-2014 09:47 PM
  18. Just_Me_D's Avatar
    Nope, problem resolved. It works both ways. Once a phone sends an iMessage or receives an iMessage both phones recognize each other as iDevices. If either party switches to another platform they stop receiving messages from iDevices unless they did one of the following three:

    1) A full reset erase all content back to factory settings
    2) Turned iMessage off before turning their phone off
    3) If they didn't do either they have to go to the Apple Profile Support Site, login and deactivate the device from their iTunes account

    Essentially, everybody here was partially right and I appreciate your insights. Sorry if it seemed like I was disregarding your answers, just knew it was more than a coincidence, that's all!


    Sent from my iPhone 5s on VZW from Philly
    What you stated is true, but you did not present the entire story to us in your initial post. Had you told us then that both phone numbers were previously associated with i-devices and then one transferred to a non-Apple device, this might have been solved then.......Still, I'm glad you got the situation fixed and I appreciate you updating us. Thank you. Enjoy your weekend, by the way...
    01-10-2014 10:06 PM
  19. anon6040766's Avatar
    What you stated is true, but you did not present the entire story to us in your initial post. Had you told us then that both phone numbers were previously associated with i-devices and then one transferred to a non-Apple device, this might have been solved then.......Still, I'm glad you got the situation fixed and I appreciate you updating us. Thank you. Enjoy your weekend, by the way...
    Yeah, you're right. I was trying to skirt around the fact that I was switching from an iPhone and having problems getting messages on my new device. The purpose wasn't to lie, it was to keep the thread on track. You know how it gets sometimes. If I would have said I was switching, the thread would have been about bashing me for leaving. Well, nonetheless...turns out I was hooked. Spent about 3 hours away and came right back to this 5s anyway.


    Sent from my iPhone 5s on VZW from Philly
    01-11-2014 04:19 AM
  20. mynameis's Avatar
    There has been a big problem for people switching from an iPhone to android, blackberry, etc. Because iMessage is on a different server than regular SMS like android and all other phones use.

    Let's use me for an example. I recently switched to a Moto X (Gasp!) I'm sorry, guys. I love the imore community, but I had to try the Moto X and I'm loving it. Anyway. After getting my X, I noticed I wasn't getting messages from other iPhones because my number was still connected to iMessage. Since I no longer have an iPhone or the capability of using iMessage, the messages were sent to the server but had no phone to go actually be sent to. The quickest and easiest way for a non-ios user is to just change your apple ID password. That will fix it.

    I know a good amount about this so if anyone needs anything, don't hesitate to ask!

    Sent from my XT1056 using Tapatalk
    01-11-2014 04:42 AM
  21. mynameis's Avatar
    that is what is so cool because it is going to know if it is a non-IOS device and send the message accordingly.
    This is only the case if the user that is receiving the messages is on a non iOS device and hadn't had one before. If you're coming from iPhone to android, you'll have the problem of "lost text messages" just simply do as I said and change your Apple ID Password and boom botta bing. Fixed.



    Sent from my XT1056 using Tapatalk
    01-11-2014 04:46 AM
  22. mynameis's Avatar
    Correct, but what if I'm an Android or BlackBerry user. The iOS default setting ensures that the message never reaches the intended recipient.

    Here's an example. Let's say I decide tomorrow to switch to a BlackBerry. How do I get texts from iPhones when most Apple users don't know to change the setting?

    Let me just lay it out. I received an iPhone as a gift so gave it a shot. While I like it. I prefer to go back to my BB Z30. But now I know if I switch, I won't be for the most part receiving SMS/text from iPhones...so I'm stuck


    Sent from my iPhone 5s on VZW from Philly
    Change you're Apple ID Password and you're good to go.

    Sent from my XT1056 using Tapatalk
    01-11-2014 04:47 AM
  23. tharley46's Avatar
    I finally ditched my iPhone 5 and went to Samsung Galaxy S4. Now I can't get any text messages from iPhone users and other phones. What the heck happened. HELP


    Sent from my iPad using Tapatalk
    01-11-2014 07:29 PM
  24. anon6040766's Avatar
    I finally ditched my iPhone 5 and went to Samsung Galaxy S4. Now I can't get any text messages from iPhone users and other phones. What the heck happened. HELP


    Sent from my iPad using Tapatalk
    Recently went though this:
    -If you have the iPhone still just it on and turn iMessages off in the settings.
    -Also, go supportprofile.apple.com and sign in with your Apple ID. From the find your device, click on it and click Unregister and confirm.

    You should be good to go...


    Sent from my iPhone 5s on VZW from Philly
    01-11-2014 07:46 PM
  25. tharley46's Avatar
    I also have an iPad. WiFi only, it also does have the iMessage turn on. Should I do same procedure on it as I do on my iPhone?
    Thanx for your help


    Sent from my iPad using Tapatalk
    01-12-2014 07:55 AM
28 12

Similar Threads

  1. Replies: 8
    Last Post: 02-13-2014, 06:44 PM
  2. Viber won't allow me to send messages to people offline
    By iMore Question in forum Ask a Question
    Replies: 4
    Last Post: 01-20-2014, 03:58 PM
  3. thinking of getting i phone
    By iMore Question in forum Ask a Question
    Replies: 6
    Last Post: 01-04-2014, 03:23 PM
  4. Move messages to trash
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 01-04-2014, 01:03 PM
LINK TO POST COPIED TO CLIPBOARD