1. reeneebob's Avatar
    Mine did it yesterday. I had to delete the message thread with my husband before it would stop sending as text.
    09-30-2013 10:12 AM
  2. jobosumm's Avatar
    Having this issue today. At first it was just iMessages. Now even text mssgs are hanging at "sending" for a long time. (5 min or more)
    09-30-2013 10:23 AM
  3. acerace113's Avatar
    Having this issue today. At first it was just iMessages. Now even text mssgs are hanging at "sending" for a long time. (5 min or more)
    That sounds like an issue with your carrier not your phone...


    Sent from my iPod touch (5th generation) using Tapatalk - now Free
    jcochran1977 likes this.
    09-30-2013 12:09 PM
  4. GadgetMomma's Avatar
    This seems to be happening to many people, making it seem like more than just a carrier or settings problem. A friend of mine posted on face book that his iMessage wasn't working, and had many comments from people with the same problem - people in different areas, different networks, wifi, cell data, etc. I wonder what's going on.
    mumfoau and Grabber5.0 like this.
    09-30-2013 12:21 PM
  5. mumfoau's Avatar
    Excellent! I'm not crazy!
    gamergurl89 likes this.
    09-30-2013 12:27 PM
  6. jcochran1977's Avatar
    I've been having periodic issues like this since Saturday morning here in Michigan! The only way I have gotten it to fix is restarting my phone. It fixes it for a little while and then it comes back. Very odd to say the least!
    09-30-2013 01:08 PM
  7. kathrynv1010's Avatar
    Yes, this is what was happening to me and then I opted to send as text message and now I can't change it back. Has this happened to you?
    09-30-2013 01:10 PM
  8. gamergurl89's Avatar
    Mines been doin this quite a bit...
    09-30-2013 01:31 PM
  9. tracy702's Avatar
    I'm not getting text messages now since I updated to the iOS 7 software.
    09-30-2013 01:50 PM
  10. GingerSnapsBack's Avatar
    I'm sad to report that it seems to have started again... 


    Sent from my iPhone using Tapatalk
    This is why I've got iMessage turned off. It's supposed to default to SMS after a set amount of time, but two days later, my phone was still trying to send an iMessage after a friend of mine called me to find out why I never responded to the message I was sent. Half the time it defaults to SMS, half the time it doesn't.
    09-30-2013 02:18 PM
  11. bbmark's Avatar
    I've also had the "hanging iMessage" problem. I also posted it in the iOS7 bugs thread. I did the network settings reset and now one message that had hung went through. Hopefully that is the end of it, but judging from everyone else's threads, likely not
    09-30-2013 03:20 PM
  12. jobosumm's Avatar
    It seems to be working fine for me now after a reset. Fingers crossed....
    09-30-2013 03:27 PM
  13. cwbcpa's Avatar
    My iPhone has been doing this off and on since Friday. Seems random though. My wife and daughter have not had any issues. It's happened to me on wifi and off wifi. I do a hard reset and it fixes it at the time. Has not happened since Sunday morning. Fingers crossed that it's fixed.


    Sent from my iPhone using iMore Forums mobile app
    09-30-2013 03:40 PM
  14. projectman's Avatar
    This has been happening to me (iP5) and my wife (iP4) since late Friday. My brother (iP4S) reported it starting today. In all cases we have turned iMessages off for a minute or so and then rebooted the device. A few minutes after reboot the iMessages start sending and receiving. But then the problem starts all over again later. I have not assessed whether or not it is a daily thing or an every 6 hours thing or what. None of us send many pics - typically just short messages. This began after updating to iOS7. All of us are on AT&T...
    09-30-2013 03:52 PM
  15. wbkm85's Avatar
    rebooting the phone fixes this too

    my at&t one has been doing this since friday too oddly enough
    09-30-2013 03:54 PM
  16. Just_Me_D's Avatar
    rebooting the phone fixes this too

    my at&t one has been doing this since friday too oddly enough
    As I've stated in another thread, I experienced this for the first time early this morning. All I did was turn off my device and then turn it back on and I haven't had a problem with it since.
    09-30-2013 04:07 PM
  17. projectman's Avatar
    As I've stated in another thread, I experienced this for the first time early this morning. All I did was turn off my device and then turn it back on and I haven't had a problem with it since.
    Seems like some of us have to do repeated reboots. Even after the reboot, while I could send an iMessage to one person, a previous conversation (that had finally switched to text) had to be deleted before I could iMessage that person...

    Has Apple even indicated a problem? If not, is there someplace it can be logged so Apple knows that it exists?
    09-30-2013 04:16 PM
  18. acerace113's Avatar
    I haven't had any problems with iMessage at all (including 3G & wifi) since doing a clean restore to iOS 7 GM on September 11th on my 4S. But the "send as SMS" setting has not worked for me since installing iOS 7 beta 5. I also have either wifi or 3G on all the time so I don't get logged out of anything.

    Apples system status page doesn't show any problems with iMessage for the past 3 days

    Carrier: Bell
    Location: Ontario, Canada


    Sent from my iPod touch (5th generation) using Tapatalk - now Free
    Just_Me_D likes this.
    09-30-2013 06:24 PM
  19. Just_Me_D's Avatar
    Seems like some of us have to do repeated reboots. Even after the reboot, while I could send an iMessage to one person, a previous conversation (that had finally switched to text) had to be deleted before I could iMessage that person...

    Has Apple even indicated a problem? If not, is there someplace it can be logged so Apple knows that it exists?
    I would recommend using the form via the following link:

    Apple - iCloud - Feedback
    09-30-2013 06:59 PM
  20. mumfoau's Avatar
    Hmmmm...just as a test I tried to send a pic to my wife and a three minutes later it's still "sending..."


    Sent from my iPhone using Tapatalk
    09-30-2013 07:24 PM
  21. mumfoau's Avatar
    Fudge...I typed up my issue and went into multitasking to try to get the link to this thread to post in my issue and swiped away my safari. Oh well. Guess there won't be a complaint today. Lol


    Sent from my iPad using Tapatalk HD
    09-30-2013 07:36 PM
  22. joshdbeard's Avatar
    I have been having consistent trouble sending iMessages since Friday.

    iPhone 5 running 7.0.2...for a while I turned iMessage off because nothing was sending, on LTE or Wi-Fi. With iMessage back on I had to long press and Send as Text a majority of the time.
    Went ahead and restored my iPhone, seemed to work for a while, however the problems have returned.
    Just Restored Network Settings.

    This has to be a large issue for more than just me.
    10-01-2013 04:56 AM
  23. mumfoau's Avatar
    This has to be a large issue for more than just me.
    I think this thread alone proves that it isn't an isolated occurrence and I'm glad to be among others with the same issue! Nothing worse than seemingly being the only person with an issue! Haha

    And last night I actually did a soft reset and sent myself a picture followed by some test messages both last night and this morning. Both times they went through flawlessly. Didn't try a soft reset before because I used what it was doing while resetting network settings was essentially the same thing.
    10-01-2013 05:29 AM
  24. gamergurl89's Avatar
    I've tried several things and it's so intermittent. How annoying
    10-01-2013 01:40 PM
  25. mumfoau's Avatar
    Been sending iMessages over 3G all day and now that I'm at home things want to start that hanging crap again 😡


    Sent from my iPhone using Tapatalk
    10-01-2013 06:22 PM
89 1234

Similar Threads

  1. iMessage only working for certain contacts?
    By Jessicalt1 in forum iOS 7
    Replies: 8
    Last Post: 09-26-2014, 05:23 PM
  2. iMessage tones
    By Heckface in forum Ask a Question
    Replies: 4
    Last Post: 09-27-2013, 09:45 PM
  3. Group iMessage delivery status missing
    By B1ue_B1aze in forum iPhone 5s
    Replies: 1
    Last Post: 09-27-2013, 07:28 PM
  4. iMessage
    By Joshua Luciani in forum Ask a Question
    Replies: 2
    Last Post: 09-27-2013, 03:06 PM
  5. Replies: 3
    Last Post: 09-27-2013, 12:42 PM
LINK TO POST COPIED TO CLIPBOARD