1. Dean211284's Avatar
    My wife used to receive regular SMS and Imessage both from my normal mobile number.
    Yesterday I had to turn iMessage off to send her an SMS as I had no Internet signal. Now when I send her a imessage it says on her phone I'm sending it from my email address. I've went into settings and tried to remove my email address and use just the phone number but that option is "greyed out" meaning I have to use my email. Why is this? How can I make it send my SMS and iMessage from my phone number?
    Thanks guys.
    03-04-2013 07:47 AM
  2. John Yester's Avatar
    03-04-2013 07:51 AM
  3. Dean211284's Avatar
    Thank you for that link. A good read. However it does not help me here. I still don't know how to send iMessage from my phone number not my email as in settings the option to send from my phone number is 'greyed out' I can only choose my email or another email which I use my sons iPad do he can FaceTime me.
    03-04-2013 08:41 AM
  4. John Yester's Avatar
    Your number will be defaulted to use the number to be reached at.. As well as any other email address you add. Example I have 4 addresses to use for mine, including my number.

    Further down. choose start new conversations from (Your number)

    I also have send as SMS selected, which it will default to in bad data areas...
    03-04-2013 08:49 AM
  5. Alli's Avatar
    Are you using your iPhone or an iPad to do this? Do you have the same iCloud account on multiple devices?
    03-04-2013 08:49 AM
  6. Dean211284's Avatar
    I dont even have that option. Just the .you can be reached by imessage at,
    03-04-2013 12:55 PM
  7. Dean211284's Avatar
    im using my iphone. and yes i am using the same icloud over my sons ipad, which uses his email, my wifes which uses her email but her imessages comes to me from her number, and my phone which only lets me use my email noy my number as its greyed out so i cant tick it.
    03-04-2013 12:57 PM
  8. warcraftWidow's Avatar
    I would try signing out and back in to
    iMessages again.

    Also, on general, you probably don't want multiple people using the same iCloud account. Your wife and son should have their own for iMessages, FaceTime, etc. You can share an AppleID for iTunes and the AppStore though so you only have to purchase stuff once.
    Alli likes this.
    03-04-2013 02:53 PM
  9. Alli's Avatar
    Yes. As Karen said, you don't want to share the same iCloud account or you won't be able to text or FaceTime each other anyway...since everything will originate from the same account. And then you will all get each other's iMessages and FT calls.
    03-04-2013 04:13 PM
  10. Dean211284's Avatar
    Funnily enough we can still all FaceTime each other while using the same iCloud account. We use the same I could account so all of our photos are shared between my phone, the wife's phone and my sons iPad.
    So basically we are saying that we don't know why my phone number is greyed out? I've reset, I've restored, I've tried everything but I can only choose to send Imessage from my email not my phone number as its greyed out.
    This is baffling. Lol.
    03-05-2013 03:38 AM
  11. Alli's Avatar
    Considering this is on your phone, there seems to be something else going on there. You might want to schedule an appointment at your local genius bar.
    Dean211284 likes this.
    03-05-2013 06:07 AM
  12. ridiculocity's Avatar
    It sounds like because you all share the same icloud account you can only have one number associated with it. Since you turned yours off your wife's has defaulted as the main number.

    It's a shame you all don't have your own cloud account because you can now share your photo stream across other users.
    Dean211284 likes this.
    03-05-2013 06:40 AM
  13. Dean211284's Avatar
    So can i set up an icloud account just for my wife and i use my current one and it wont effect us bothj being able to use the same apple account to download apps? thanks guys
    03-06-2013 03:48 AM
  14. warcraftWidow's Avatar
    So can i set up an icloud account just for my wife and i use my current one and it wont effect us bothj being able to use the same apple account to download apps? thanks guys
    Yes. Your iCloud account can be different than the one you use for iTunes and the AppStore.
    03-06-2013 05:41 AM
  15. Wendi Brandao's Avatar
    I have had this same problem the last 2 days. The number is grayed out, but you can click on the email that you have set up in send and receive. After you do that click on delete email. You might have to wait a minute or so, but it will automatically revert back to your phone number. Also, you can just turn off iMessage. I found that taking out the email works better though. And it has nothing to do with iCloud being used by multiple people. I don't share it with anyone. The other person on the cell phone account is not having any issues either. Good luck!
    05-22-2013 01:34 PM
  16. Edison Santana's Avatar
    The solution for this problem is:
    1. Turn off I message for 1 or 2 minutes
    2. Turn I message on again.

    The problem is going to be solved.
    06-03-2013 09:34 AM
  17. mz_emz's Avatar
    I just had the same problem and fixed it!

    Go into settings > messages > receive at > then sign out of your apple ID.

    That fixed it for me
    06-16-2013 04:44 AM
  18. chanel98's Avatar
    This won't work for me
    08-12-2013 06:39 PM
  19. lounico239's Avatar
    same here? it just went away and I don't what to do? I've tried re-entering my phone number manually, I've tried deleting emails from imessage....still nothing. I'm at a lost
    08-29-2013 12:00 AM
  20. Christine Tellam's Avatar
    omg I'm having the same problem
    09-20-2013 03:56 AM
  21. Juidth's Avatar
    me too............ so annoying
    09-20-2013 08:16 AM
  22. Linda Meers's Avatar
    I was having the same problem, and just figured it out. Sign out of iMessage. Sign back in, when it lists your phone number and email address (you'll see the check mark on your email address) tap your email address to uncheck it. Problem solved! It now will send messages from your phone number!
    Jaguarr40 likes this.
    12-03-2013 08:47 PM
  23. Samantha Martinez1's Avatar
    It won't even let me delete the email.. I don't understand this
    04-02-2014 10:42 PM
  24. Just_Me_D's Avatar
    It won't even let me delete the email.. I don't understand this
    What is the "it" you're referring to that won't let you delete the email?
    Last edited by JustMe'D; 06-29-2014 at 11:23 AM. Reason: Made the reply clearer to understand
    04-03-2014 11:36 AM
  25. kari509's Avatar
    We had the same problem.
    Do you have an iPhone?
    Are you trying to set up your cell number on your new iPad and only see space for additional email addresses? If yes do this.
    Go to your iPhone and link in setting under messages your email address, it will allow you to add it, just under your cell phone number.
    An alert will show on your iPad that your iPhone cell number is now linked to messages on your iPad. Your email address must be linked to your iPhone cell number for it to work on your new iPad.
    Open messages on your iPad and you will see your iPhone cell number is there.
    You can now receive messages on iPad thru cell number.
    Jaguarr40 likes this.
    06-29-2014 11:17 AM
29 12

Similar Threads

  1. Replies: 17
    Last Post: 10-20-2012, 10:09 PM
  2. Hide My Phone Number Feature
    By Just_Me_D in forum iOS
    Replies: 2
    Last Post: 08-04-2012, 04:13 PM
  3. ITunes won't recognize my phone
    By San Antone RR#IM in forum iTunes
    Replies: 0
    Last Post: 02-24-2010, 05:18 PM
  4. Is there any web app that allows you to send pictures from your phone?
    By electriicdigits in forum iPhone Apps & Games
    Replies: 23
    Last Post: 05-26-2009, 02:36 PM
  5. How do I save my phone numbers??
    By johnny football hero in forum iPhone 4
    Replies: 2
    Last Post: 11-28-2008, 10:35 AM