1. DomFeeney's Avatar
    Omg its working now on my ipad and my iphone. Yayyyyy finally i could fix it.... U just have to set up "receive at " with both email and phone number on ur devices. Then it will work fine...
    You beat me too it. I was just about to say how it was working exactly as advertised for me.

    I sent an iMessage to my friend from my iPhone 4 and received his reply on both my iPhone 4 and iPad 2 simultaneously. I continued the conversation on my iPad complete with read receipts and typing indicators. I then left the house pulled out my pho e and the whole conversation was right there even though 90% of it was typed on my iPad 2.

    If your having issues it's because it's not correctly setup. There's a recieve at option in the settings, make sure it's set to 2 addresses and that they are your phone number and the email address linked to your iPads iMessage account.


    Sent from my iPhone using Tapatalk
    Ip.fanboy likes this.
    10-15-2011 05:16 AM
  2. DomFeeney's Avatar
    OMG CORRECTION

    Even though it was working perfectly yesterday it is now inexplicably not working!!!

    Nothing has changed, my missus sent me a message it appeared on my iPhone no such luck on my iPad 2. I then sent a message to somebody different from my iPhone. When logging into the app on my iPad it should pull in the message I sent as a new conversation regardless of whether or not I've received a reply

    It didn't nada, nothing

    Actually really pi**** off this was perfect yesterday and a joy to use. Nothing has changed but now it doesn't work. Well it does on iPhone but not on my iPad. Both are on the same wireless network btw.

    What a joke, you could probably start a lawsuit against apple under the old doesn't work as advertised guise....


    Sent from my iPad using Tapatalk
    10-15-2011 05:45 AM
  3. Alli's Avatar
    As for doing the maths, someone in another thread did it already, and I think he came out with something like a million messages to use 1MB of data. Those of you on restricted data plans aren't going to notice a difference.
    Ip.fanboy likes this.
    10-15-2011 07:44 AM
  4. anon(153966)'s Avatar
    Register ALL devices with an email address for iMessage, and it will work as you want it to.

    Now, my only request is that 'Send Read Receipts' should be set to ON by default...
    10-15-2011 07:57 AM
  5. Steve28's Avatar
    Simply put, its ****!

    I have a limited data plan but unlimited text messages... You do the maths
    Here's the 'maths': if you have the 200mb plan, that's about 1.3 million text messages - so I doubt you will even notice the iMessage data use.
    Last edited by Steve28; 10-16-2011 at 09:24 PM.
    10-15-2011 11:10 AM
  6. Snownation's Avatar
    All the answers provided here are somewhat misleading to anyone having the same problem as the OP.

    This is how I interpret the original problem.
    OP complains that the conversation isn't appearing on both iPhone and iPad when people send an iMessage to his carrier mobile number, but confirms that it DOES work when sending to his Apple ID email.

    User expects the latter when people send to his carrier mobile number.


    Solution which everyone above have been giving is; turn on "Receive at" to include the Apple ID email.

    What they all failed to tell you is that they are having success with receiving on both devices because they are using the Apple ID for transmitting, and not the carrier mobile.

    I tried this myself, and I have to admit, only when someone else sends it to my email address can I receive on both devices.
    Problem being, no one uses a person's email to start a convo, it's always the phone number.
    Let's face it, no one associates you with your email address. Your phone number is your next line of contact. And no one is gonna start a convo with your email address in mind just for your benefit of receiving on all devices.

    TL;DR, To be able to receive outside messages on all your iOS 5 devices, the sender MUST use your Apple ID email.
    Last edited by Snownation; 10-16-2011 at 09:18 PM.
    10-16-2011 09:08 PM
  7. jtrevill's Avatar
    I realized that if I start a conversation on my iPad, i can continue the conversations across both the iPad and iPhone with both in sync. However, if I start on the phone, it stays on the phone.... Probably because its using the number. I'm tempted to try to take the phone number out of iMessages on my phone...
    10-16-2011 10:59 PM
  8. jtrevill's Avatar
    Ok, so you can't remove the phone number. However, under messages, and receive at, you can select caller id. If you change it to the email address on the iPhone, it doesn't matter where u start the conversation.
    10-16-2011 11:04 PM
  9. mad6c's Avatar
    I think is is a miss on apple's part. I'm not sure why they couldn't come up with a way to validate my phone number and let me register it on the iPad. They do this when you add an email address. Messages on both devices work only if sent to your email addresss. However you can't control how people start a conversation with you. Hopefully they add this ability in a future update.
    10-25-2011 07:49 PM
  10. iTreHayes's Avatar
    Wow. If you all hate it so much, you can turn it off. Nobody is forcing you to use it.
    I think its just much easier to cry about it for him.
    BLiNK likes this.
    10-26-2011 01:59 AM
  11. anon62607's Avatar
    My only complaint is that it doesn't merge conversations like I thought it might. It's hard to explain, but I have three different threads from one contact: one from his email address, another from another email address, and another from his phone number. All were sent from one iPhone. That doesn't make sense to me. Other than that, I am very pleased with the service and I'm sure Apple will continue to make it better until RIM goes down in flames.
    Your friend needs to set the caller Id for iMessage in each device. That way all messages from him will appear to come from the same address and you will have a single thread.
    10-26-2011 03:41 AM
  12. Waks's Avatar
    I like iMessage. The only thing I dislike about it though, is that if the person you iMessage'd isn't available on iMessage, it takes the phone a few minutes before it sends the text as SMS.
    10-26-2011 08:03 AM
  13. Jonezed7's Avatar
    My only complaint is sometimes messages send as texts instead of iMessage and I really don't understand why.
    10-26-2011 09:01 AM
  14. Waks's Avatar
    My only complaint is sometimes messages send as texts instead of iMessage and I really don't understand why.
    If it does that, it means that the person you sent a message to, probably isn't connected to the internet.
    10-26-2011 09:25 AM
  15. vietalogy's Avatar
    I've turned mine off because I send a lot group texts and iMessage was interrupting it.
    10-26-2011 09:58 AM
  16. Zlannie's Avatar
    I think iMessage is basically for those w/o an iPhone (that would be me-iPod Touch). Like FaceTime, its a way for those using iOS to communicate w/o using a phone.
    10-27-2011 01:46 PM
  17. sd3sign's Avatar
    I quite like it. Have been iMessaging all of my friends and family. Saves lots of money :-)
    10-27-2011 02:17 PM
42 12
LINK TO POST COPIED TO CLIPBOARD