1. magnus1986's Avatar
    Hi. I upgraded my iPhone 4 to iOS 5 from the latest iOS 4 version, Everything seems to be working fine except iMessage. It will not work, no matter how hard I try.

    Whenever I send an iMessage, it says delivery failed after a long while. If I tap the exclamation mark next to the bubble and select the try again option, I get no progress bar unless I go back to home, lock the phone, unlock and open Messaging again. The progress bar then shows and remains stuck at 90% for a long while before failing again. This happens again and again, no matter how many times I retry. I cannot receive any iMessages either. Every other method is working fine, including tweets, emails and text messages. If I add my own phone number as a contact and send an iMessage, it goes through and shows up in as received too almost instantly.

    I have tried with 2 different people for whom it works perfectly when they send iMessages to each other, I have confirmed all settings and methods to be identical. I have confirmed that activation is successful and have reconfirmed my Apple ID and have viewed all details within the configuration options located in the Settings > Messages menu. I have tried over Edge, 3G and Wifi. I have restarted Messaging many times along with turning the iMessages option on and off multiple times. I have tried rebooting the phone and turning iMessages off before and on after and leaving it on during the reboot. I have also tried a factory restore with and without reinstalling my apps on it.

    Nothing fixes the problem and I am very frustrated. How can I fix it? Please help.
    10-13-2011 11:28 AM
  2. mikesa_tx's Avatar
    Tried the hard reset too?
    10-13-2011 11:34 AM
  3. magnus1986's Avatar
    Yes. And a complete factory restore in case that wasn't enough.
    10-13-2011 11:41 AM
  4. big9erfan's Avatar
    So you did a restore and setup as a new device ( not restore from backup ) and it didn't work? Humm...At that point I might suggest an Apple Store appointment.
    10-13-2011 11:56 AM
  5. magnus1986's Avatar
    There's no Apple Store out here in Oman (Middle-East) :|
    10-13-2011 11:58 AM
  6. big9erfan's Avatar
    There's no Apple Store out here in Oman (Middle-East) :|
    Then you'll have to call Apple Support on the phone and go from there.
    10-13-2011 12:00 PM
  7. magnus1986's Avatar
    I will do that later but I don't get why it's not working, it's not like it's a piece of hardware that failed or anything like that.
    10-13-2011 12:09 PM
  8. ja2ed's Avatar
    I had sort of a problem like that yesterday trying it out between my iPhone and iPod. The badges and notification isnt working right
    10-13-2011 12:11 PM
  9. magnus1986's Avatar
    Update: I have tried creating a new AppleID and using that. No use.
    10-13-2011 06:02 PM
  10. ivan1.ruiz's Avatar
    Works perfect on my 3GS


    " Think different"

    ~ Steve Jobs ~
    10-13-2011 06:15 PM
  11. jakej914's Avatar
    Update: I have tried creating a new AppleID and using that. No use.
    So, under Settings-->Messages, iMessage is switched to on, and drilling down to the "Receive At" submenu, your AppleID and settings are configured?

    If that's the case, when you create a new message thread and type in a contact's name who's using iOS 5, is there a blue bubble beside their name?
    10-13-2011 06:47 PM
  12. magnus1986's Avatar
    Yes it is configured and yes there's the blue send bubble as opposed to a green one for my other contacts. And as I previously said, I can send and receive iMessages to and from myself (not the most useful thing in the world I'd say) but not to and from anyone else.
    10-13-2011 07:26 PM
  13. jakej914's Avatar
    Yes it is configured and yes there's the blue send bubble as opposed to a green one for my other contacts. And as I previously said, I can send and receive iMessages to and from myself (not the most useful thing in the world I'd say) but not to and from anyone else.
    Hm. That is really strange. I haven't had that issue :-/
    10-13-2011 07:30 PM
  14. magnus1986's Avatar
    It seems very few people are having it. I'm not the only one but this is not widespread at all. I feel it's a bug in iOS 5 that only rears its head in some conditions but I'm baffled as to why it doesn't work even after a factory restore and before even touching the backups.
    10-13-2011 07:32 PM
  15. magnus1986's Avatar
    Update 2: Upon further testing, I can send to myself if I store my phone number but it fails if I store my email address. For others, it fails for both phone numbers and email addresses.


    This is almost certainly an AppleID problem. What do you say?
    10-13-2011 07:43 PM
  16. magnus1986's Avatar
    Is no one else on the whole of TiPB having any similar issues??
    10-14-2011 06:08 AM
  17. MikeC14's Avatar
    If you can send to your own devices and it works perhaps the other persons (recipient) iMessage isn't set up correctly with their Apple ID
    10-14-2011 07:07 AM
  18. Coach8762's Avatar
    Same problem on Iphone4. I was on the phone with my carrier for 30 min., they couldn't fix it. Directed me to Apple. On phone with them for an hour. They couldn't fix it either. They said there is some bugs they are working on and that I should keep trying, maybe it will get fixed in a couple days. Good thing I'm getting the 4s today, and giving the 4 to my wife. She probably wont use that feature anyways.
    10-14-2011 12:29 PM
  19. char.crotty's Avatar
    I know where to switch the i message on.. however the swipe button does not stay on! Has anyone else had the same problem?
    Cheers
    10-14-2011 04:19 PM
  20. robes1's Avatar
    I've never heard of that problem. I would definitely call Apple. A very nice Rep stayed on the phone with me for almost an hour until my iMessage was working.
    10-14-2011 05:40 PM
  21. kikemichelena's Avatar
    I'm having the same problem but with an iPad 1. Also tried everything you already did but no success...
    10-14-2011 08:18 PM
  22. ujjsarin's Avatar
    I was facing the same problem....iMessages working on iPhone 4 but not on iPad 1. It just wouldn't send or receive messages and would get stuck at 90%.....
    Go to settings....and change your DNS address to 8.8.8.8 and then just log back onto your wifi....switch off iMessages and switch it back on and then try....once I did that it started working....and also I switched back the DNS address to my original DNS and its still working...had this quirky problem with FaceTime on my iPad 2 also....
    See if it works.

    Uj
    10-15-2011 08:31 AM
  23. asinha86's Avatar
    Had been looking for a solution for the last couple of days to eliminate this problem.it works perfectly now.Thanks a lot!
    10-15-2011 11:42 PM
  24. Gooster's Avatar
    I didn't want to clog up the forum with another iMessage thread, but I too am having an issue on my Sprint 4S, I think:

    It's supposed to use wi-fi when available, right? There's nothing wrong with my internet connection as far as I know but messages to people also on iPhone hang and don't get sent. Meanwhile, regular SMS to other phones go through just fine, too, so I don't think it's Sprint. Also, iMessages from my wi-fi-only iPad 2 to iPhones go through just fine. Can anyone please explain what the issue might be? Hardware? I hope not. I'd really appreciate it. Thanks!

    I did a soft reset and reset my network settings. iMessages seem to go through rather slowly, and they don't always go through at all. I hope it's not the hardware. Not in the mood to do yet another restore between this new 4S and my other iPhone 4.
    10-16-2011 04:38 PM
  25. Duvi's Avatar
    Gooster... Just came in here to say that your Avatar is awesome. Great win! #Giants. Lol


    Sent from my iPad using Tapatalk
    Gooster likes this.
    10-16-2011 04:43 PM
35 12
LINK TO POST COPIED TO CLIPBOARD