1. Darth-gamer's Avatar
    Yep. The Gmail through MS exchange is acting up again and not pushing my e-mails. Anyone else?
    03-16-2011 10:08 PM
  2. cevmkv's Avatar
    Mine seems fine
    03-16-2011 10:24 PM
  3. shimojunk's Avatar
    My push gmail was working fine last night - Los Angeles, CA
    03-17-2011 12:16 PM
  4. ivybiznatch's Avatar
    Mines been fine today. Sorry you're having trouble. :/
    03-17-2011 12:34 PM
  5. vietalogy's Avatar
    M4E working fine here.
    03-17-2011 12:54 PM
  6. ReeseyKups's Avatar
    I'm in the same boat today Darth. I only use gmail for calendar and I'm getting the "incorrect password" error message today.
    03-17-2011 01:37 PM
  7. Ipheuria's Avatar
    GMail gives me headaches, sometimes the mail app tells me the servers are unavailable but I'm able to load it up in the browser. I usually just leave it for a couple of hours and everything works again.
    03-17-2011 01:55 PM
  8. garypip's Avatar
    Same here - no push for gmail or hosted email accounts.
    03-17-2011 03:30 PM
  9. jhamilton3's Avatar
    Been very slow at pushing the last few days. Not happy with it.
    03-17-2011 03:43 PM
  10. big9erfan's Avatar
    Working just fine for me.
    03-17-2011 04:06 PM
  11. Alli's Avatar
    I've got all my custom domains on Google Apps and they're working great for me.
    03-17-2011 05:05 PM
  12. aimetti's Avatar
    yea , mine isnt pushing either :/
    03-17-2011 05:18 PM
  13. yaynative's Avatar
    Gmail has been sporadic for the past two weeks. I simply close the mail app and it resolves itself. Gmail on my desktop was having issues today though.
    03-17-2011 06:05 PM
  14. j7469's Avatar
    I'm having an issue pushing to my iPad but not my iPhone. Go figure?
    03-17-2011 06:52 PM
  15. Massie's Avatar
    In three years with an iPhone/Gmail setup I can't remember ever having a problem beyond the missing features I wish I could have. I wonder if there's any chance you folks are in the same area geographically? Maybe there's a hardware issue somewhere near you?
    03-17-2011 11:00 PM
  16. ame's Avatar
    Mine is slow to push. Like I've gotten three emails today that were dated several hours earlier than my phone got them. They'd already been read and deleted even.
    03-18-2011 01:58 PM
  17. dharari's Avatar
    I have been having delayed push issues with gmail and Google Apps accounts for the past few days. They continue today. The average delay for a push is about 20-30 minutes. Is anyone else still seeing push delays?
    03-20-2011 05:38 PM
  18. rstark18's Avatar
    Yes!!! I've been having this problem for about a week now. Push is being delayed for an hour or more. If a mail has landed in Gmail but not on the iPhone, If I turn the iphone off/on it lands. VERY FRUSTRATING. Can't figure out if it's an iOS issue or Google issue. Yahoo mail push is working fine. I'm glad it's not just me. BTW, I'm in Los Angeles if that creates any sort of pattern.
    03-21-2011 04:38 PM
  19. BigLan's Avatar
    Mine is working fine also.
    03-21-2011 04:50 PM
  20. rstark18's Avatar
    For those that are still having this problem (ME), I found a wrokaround. In your exchange settings (for Gmail at least) set your push folder to also look at All Mail. If this doesn't work initially then delete your account, reboot the phone, create the exchange account again and add all mail to push folder.
    03-22-2011 12:18 AM
  21. WrongWay's Avatar
    I don't push any of my mail, but I am always getting this Gmail password error. Is there a fix?
    03-22-2011 08:24 AM
  22. dharari's Avatar
    The "All Mail" workaround seemed to work for me without the need for rebooting the iphone. I added the folder to the push folders. Now, I get the push notification twice and the badge on the mail icon after the second notification.
    I am curious if anyone has tried a restore as a new iphone for the gmail push issue and whether gmail push returned to normal with pushing inbox only.
    03-22-2011 10:53 AM
  23. audit's Avatar
    I haven't had a single problem with it, I have the web gmail open also and everytime I see a new email in the inbox, I hear the tone on my iPhone.
    03-22-2011 11:06 AM
  24. rstark18's Avatar
    The "All Mail" workaround seemed to work for me without the need for rebooting the iphone. I added the folder to the push folders. Now, I get the push notification twice and the badge on the mail icon after the second notification.
    I am curious if anyone has tried a restore as a new iphone for the gmail push issue and whether gmail push returned to normal with pushing inbox only.
    I get the same results with All Mail pushed (2 beeps, badge after 2nd). From that I take it that their is a problem with the inbox registering with exchange. When the All Mail is selected it does a force check of the inbox. The 2 notifications are first the All Mail folder notification and the second is the Inbox notification.
    I have tried doing a full CLEAN restore an that didn't solve anything (except lose my Angry Birds levels).
    03-22-2011 11:48 AM
  25. dharari's Avatar
    Thanks rstark18 for saving me a lot of time by letting me know that clean restore doesn't resolve the issue. I hope the "All Mail" workaround continues to work until this gets fixed by Apple or Google.
    There is another thread in Apple discussions with others having the same issues but I haven't seen anything in the Google gmail discussion group.
    03-22-2011 11:55 AM
28 12
LINK TO POST COPIED TO CLIPBOARD