1. Enders's Avatar
    I noticed that with the new OS 4.0 Gmail doesn't automatically delete an e-mail when you simply swipe from your inbox. It actually archives the email into the "All Mail" section. There IS an option that lets you turn off the Archive function so that when you swipe the email it says DELETE instead of ARCHIVE.

    However even with the archive function switched off in the mail account settings of the iPhone. E-mails that I swipe delete still get archived and I need to actually go into ALL MAIL to delete them again.

    Anyone else know if this is normal or an actual issue Apple is looking at?
    06-22-2010 03:10 AM
  2. catadjuster's Avatar
    I just noticed this today on my phone, not sure if it's been there ever since I updated to 4.01 or if a setting just got changed somewhere.
    08-10-2010 11:02 PM
  3. Massie's Avatar
    Are you talking about Gmail via the web app, or using Gmail in the native mail app? I use it via Exchange, and the only relevant option I have under Settings is "Ask Before Deleting"--no option to Archive or not.

    If I go into the web app, I see the Archive label when swiping, but can't find the Settings dialog. At any rate, yes, this is now the default Gmail behavior under iOS 4.
    08-10-2010 11:37 PM
  4. sting7k's Avatar
    How do you have your Gmail setup?
    08-11-2010 12:18 AM
  5. killthelights32's Avatar
    This isn't new to iOS 4. I have had this issue since 3.0 I haven't figurred out why it does this, but my workaround is this.

    *Go to gmail on your desktop and create a 'To Delete' foler/label

    On your iPhone, simply move messages you want to delete to that folder, and delete them later on your desktop/web browser. It kinda sucks that this is what I have to do but I found it much more annoying to have to go through the 'All Mail' label and find the messages that were meant for the trash.
    08-11-2010 03:31 AM
  6. timmyb457's Avatar
    Go to your mail settings. Click your gmail account and turn off archiving
    08-12-2010 05:14 AM
  7. Pete53's Avatar
    Go to your mail settings. Click your gmail account and turn off archiving
    Had to turn shut iPhone 4 all the way down and restart to get this to work. Had to do on all three iPhone 4's in the family so can't be just me.
    08-27-2010 09:29 PM
  8. noaim's Avatar
    if you set it up as exchange using google sync you get the delete option and it works as delete
    08-27-2010 09:46 PM
  9. Mustang5Oh's Avatar
    Go to your mail settings. Click your gmail account and turn off archiving
    +1 it is that easy. thats all you got to do.
    08-28-2010 02:15 AM
  10. ebedoun's Avatar
    I use google sync through exchange and my messages get archived and not deleted. I don't see any options to change this either.
    08-29-2010 10:13 PM
  11. zhelf's Avatar
    ok heres what you need to do go into your gmail account on your comp then settings then labs then turn on advanced imap controls. then go into folders and you can now disable and delete folders you could not before then just disable all mail from showing in imap this is how i finally fixed it for my iphone and my mail app on my imac.
    08-30-2010 02:06 AM
  12. TampaDude's Avatar
    Yup...I had the same issue...just turn off archiving.
    08-30-2010 11:20 AM
LINK TO POST COPIED TO CLIPBOARD