1. iMore Question's Avatar
    New phone. All data switched over from old phone just fine. However people are telling me when I make a call they don't know it's me. How can I fix this problem so people will actually answer their phone when I call?
    06-20-2016 04:24 PM
  2. Tartarus's Avatar
    Hi, welcome to iMore.

    Simply go to Settings > Phone > Show My Caller ID and make sure it's enabled (green).

    Enjoy iMore and sign up if you have any other questions.
    06-20-2016 04:53 PM
  3. Rob Phillips's Avatar
    Hi, welcome to iMore.

    Simply go to Settings > Phone > Show My Caller ID and make sure it's enabled (green).

    Enjoy iMore and sign up if you have any other questions.
    That setting doesn't show up on my 6s Plus. It must be a carrier-level setting. Either way, OP should also be able to contact his/her carrier directly to have them enable Caller ID.
    Tartarus likes this.
    06-20-2016 05:01 PM

Similar Threads

  1. Replies: 5
    Last Post: 10-27-2016, 08:22 PM
  2. How do I reset my iTunes account
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 06-21-2016, 04:05 PM
  3. Why has my front camera stopped working on iPad mini 4?
    By iMore Question in forum iPad mini 4
    Replies: 2
    Last Post: 06-20-2016, 03:52 PM
  4. Will macOS Sierra work on my Mac?
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 06-20-2016, 03:12 PM
  5. Suddenly my iPhone won't send photos to an e-mail address, why?
    By iMore Question in forum General Apple News & Discussion
    Replies: 1
    Last Post: 06-20-2016, 02:34 PM
LINK TO POST COPIED TO CLIPBOARD