1. BreakingKayfabe's Avatar
    What I mean is, if you go to App Store > Updates > Purchased and download apps from specifically those iCloud purchased apps, are you experiencing extremely slow downloads as opposed to just downloading an app from anyplace else other than the purchased section?

    I started noticing this yesterday when I restored my 6 Plus from an iCloud backup and it was taking forever to download apps. I ended up restoring as new and just started downloading a few apps by simply searching for them. Then I figured I'd scroll through my purchased apps to hit the download button from there and that's where I noticed this problem which explained the initial slow iCloud restore.

    Anyone else experiencing that?
    08-07-2015 11:49 AM
  2. Tartarus's Avatar
    It's because of the multiple updates that were released yesterday.
    08-07-2015 12:09 PM
  3. kch50428's Avatar
    I've not noticed that... seems as normal as ever for me.
    08-07-2015 12:10 PM
  4. BreakingKayfabe's Avatar
    It's because of the multiple updates that were released yesterday.
    I seriously doubt that since it's still ongoing for me as of now. Must be an isolated issue for my iCloud so if it continues I'll call up Apple and see what's going on.
    08-07-2015 01:25 PM
  5. Bigeric23's Avatar
    Yeah, I'm not noticing the issue on my end.
    08-09-2015 09:58 AM
  6. Ledsteplin's Avatar
    I don't have any slow issues downloading from the purchased list.
    08-09-2015 12:01 PM
  7. John Schiff1's Avatar
    Mine has been painfully slow via app and wifi today. Actually got better download via AT&T
    08-15-2015 08:56 PM
  8. Ledsteplin's Avatar
    Mine has been painfully slow via app and wifi today. Actually got better download via AT&T
    Have you tried rebooting your modem/router?
    08-15-2015 09:29 PM
  9. xderiwx's Avatar
    I have been experiencing extremely slow downloads from the App Store as well. Started noticing it maybe a few days ago while trying to reinstall the DarkSky app which is very small in size, and noticed it absolutely crawling along. Been that way with other apps as well. Before and after iOS 8.4.1.

    Also, I'm trying to download iOS 8.4.1 through iTunes on my MBP so I can do a full restore to factory settings, and the download is showing me an estimate of 26 hours to complete. Running speedtest.net while doing the download shows that my download speed is at 25Mbps. Not the fastest, but surely the iTunes download of 8.4.1 shouldn't be estimated at that long. Problems with Apple servers?

    I am not experiencing any download issues using any devices for other things, like browsing, YouTube, etc.

    Posted via the iMore App for Android
    08-16-2015 09:27 AM
  10. Steve Ura's Avatar
    I have not been able to download/update for a few days now. My ISP is CenturyLink. I have discovered through the Apple support pages that many other CenturyLink customers are having the same issue. Do you have CenturyLink too?
    08-17-2015 08:54 PM
  11. Just_Me_D's Avatar
    I have not been able to download/update for a few days now. My ISP is CenturyLink. I have discovered through the Apple support pages that many other CenturyLink customers are having the same issue. Do you have CenturyLink too?
    To whom are you responding? Use the 'quote' feature when replying to a specific comment. Thanks.
    08-17-2015 09:28 PM
  12. koltonh2002's Avatar
    I am having the same exact problem as OP but I'm just gonna deal with it I think
    08-17-2015 10:08 PM
  13. BreakingKayfabe's Avatar
    This issue has been a happening/not happening thing since I made this post.

    I do not use CenturyLink. The issue is prevalent for me on WiFi being on TWC and AT&T as well as AT&T cellular.
    Last edited by BreakingKayfabe; 08-18-2015 at 04:36 PM.
    08-18-2015 02:04 PM
  14. charliecq's Avatar
    Same issue here. My husband and I haven't been able to update any apps on either of our iPads or iPhones (5 or 6) on either our home Wifi (Century Link 40MBps) or on our Sprint LTE network. This started yesterday and hasn't improved. After leaving our devices for hours and overnight to update apps, still nothing. Anyone find any more info yet?
    08-19-2015 09:57 PM
  15. asetiyadi's Avatar
    I found this solution in Apple forum for those who use CenturyLink. It saved my day

    Okay guys I just got all this fixed and even the Century Link was stumped. Here is what he did to fix our problem.
    Under your modem settings under Advanced Setup go to your set DNS type. He had me turn off the Dynamic DNS and type in a public one like google.
    So I clicked Static DNS then under Primary DNS 8.8.8.8 Then the Secondary DNS 8.8.4.4 then click apply. This fixed my issues. I have not gone back to the Dynamic DNS to see if it was fixed under the original settings due to the fact I have to go to work. But I wanted to share this ASAP. The Century Link tech also said he will share this information up the pipeline to help try to fix the original problem.

    I hope this helps everyone!!!!!
    08-19-2015 11:02 PM
  16. xderiwx's Avatar
    This issue has been a happening/not happening thing since I made this post.

    I do not use CenturyLink. The issue is prevalent for me on WiFi being on TWC and AT&T as well as AT&T cellular.
    I'm with TWC (Oceanic) and VZW for cell. For a very short period yesterday everything went back to being fine. With no changes on my part, I was able to download some of my apps back. (Recently did a full restore). Today it is back to being extremely slow. Just trying to download an update for VSCO cam, its been an hour already. Still no issues with other services, like streaming YouTube, upload/download to other sites/services, etc.

    Posted via the iMore App for Android
    08-20-2015 08:04 AM
  17. TriShark's Avatar
    I found this solution in Apple forum for those who use CenturyLink. It saved my day

    Okay guys I just got all this fixed and even the Century Link was stumped. Here is what he did to fix our problem.
    Under your modem settings under Advanced Setup go to your set DNS type. He had me turn off the Dynamic DNS and type in a public one like google.
    So I clicked Static DNS then under Primary DNS 8.8.8.8 Then the Secondary DNS 8.8.4.4 then click apply. This fixed my issues. I have not gone back to the Dynamic DNS to see if it was fixed under the original settings due to the fact I have to go to work. But I wanted to share this ASAP. The Century Link tech also said he will share this information up the pipeline to help try to fix the original problem.

    I hope this helps everyone!!!!!

    I'm not sure why this would work to solve this specific problem. BUT IT DID!!!! Again, centurylink had no resolution but did admit they had an open ticket already for the issue. I changed to the static DNS as outlined above and everything is back to normal.

    Thanks!
    08-21-2015 12:01 AM
  18. Matthew110607's Avatar
    OP, have you fixed this issue? I am not using Century Link, I have tried other DNS, like Google and OpenDNS, and this isn't resolving the issue. I have this issue on both my device and my iTunes on my computer. A song from iTunes takes 10-15 minutes now, most apps are so slow that they time out. Even downloading an iTunes update from within the app is excruciating.
    08-23-2015 08:02 PM
  19. Ledsteplin's Avatar
    Well, downloads are not as slow as they were 3 years ago.
    08-23-2015 09:13 PM
  20. BreakingKayfabe's Avatar
    OP, have you fixed this issue? I am not using Century Link, I have tried other DNS, like Google and OpenDNS, and this isn't resolving the issue. I have this issue on both my device and my iTunes on my computer. A song from iTunes takes 10-15 minutes now, most apps are so slow that they time out. Even downloading an iTunes update from within the app is excruciating.
    I haven't really experienced the problem within the past 10 days or so. I didn't really do anything. It went away on its own and hasn't happened for a good while now.
    08-24-2015 04:13 PM
  21. Matthew110607's Avatar
    Found this solution elsewhere, this fixed it for me:

    Close your iTunes,
    Go to command Prompt -

    (Win 7/Vista) - START/ALL PROGRAMS/ACCESSORIES, right mouse click "Command Prompt", choose "Run as Administrator".

    (Win XP SP2 & above) - START/ALL PROGRAMS/ACCESSORIES/Command Prompt

    In the "Command Prompt" screen, type in

    netsh winsock reset

    Hit "ENTER" key
    Restart your computer.
    If you do get a prompt after restart windows to remap LSP, just click NO.

    Now launch your iTunes and see if it is working now.

    If you are still having these type of problems after trying the winsock reset, refer to this article to identify which software in your system is inserting LSP:

    iTunes 10.5 for Windows: May see performance issues and blank iTunes Store
    http://support.apple.com/kb/TS4123?viewlocale=en_US
    08-25-2015 02:56 AM
  22. qbnkelt's Avatar
    Interesting that I saw this thread.
    I reset my iPhone Monday to get rid of some "Other" data. I then restored from iCloud.
    It literally took hours to get all my music and movies back.
    But....the flip side....I've got everything back the way it was and my "Other" data is gone.


    Sent from my GORGEOUS, SEXY, AWESOME Gold 128G iPhone 6
    08-26-2015 07:34 AM
  23. Benjamin1421's Avatar
    I have serious doubts, as it is still ongoing, so far. Must be my iCloud an isolated problem, so if we continue like this I'll call Apple and see what happened.
    08-28-2015 04:21 AM
  24. Matthew110607's Avatar
    I have no issue after I did the solution two posts above.
    08-28-2015 11:14 AM
  25. Ledsteplin's Avatar
    What is an iCloud app App Store?
    08-28-2015 12:06 PM
26 12

Similar Threads

  1. Replies: 1
    Last Post: 08-07-2015, 01:50 PM
  2. MD276LL/A what model is this phone?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 08-07-2015, 10:54 AM
  3. Apple Watch is now available from Best Buy, both in-store and online
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 08-07-2015, 09:30 AM
  4. How to download and start using iTunes 12 on Windows 10
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 08-07-2015, 08:12 AM
LINK TO POST COPIED TO CLIPBOARD