1. RavenSword's Avatar
    So, I'm noticing that my iPad 4s manual iCloud back up is not working. It keeps giving me an error message saying that the last iCloud back up could not be completed.
    I plugged my iPad into my PC for the first time recently, would that have caused an issue? It's a bit frustrating. I tried deleting my previous back up, but am still getting an error.

    I haven tried to see if it'll back up when I plug it into my charger yet because I don't need to recharge
    . But maybe I'll see if that works.
    03-20-2014 12:32 PM
  2. RavenSword's Avatar
    Soooo now it's working. Seriously, I don't get it. Is there some weird issue with iCloud backup where it'll work and not work half the time? Again, I'm not sure I was even having these back up issues since I plugged the iPad into my PC for the first time. Ecause I was having trouble downloading the 7.1 update. So I did the update through my PC.
    03-20-2014 12:45 PM
  3. kataran's Avatar
    Don't over think it iCloud has issues from time to time it's happened to me and others in the past nothing to worry about most times it's just a connection loss or the Apple Servers are acting up


    iMore Ambassador -iPhone 5s
    03-20-2014 04:35 PM

Similar Threads

  1. How's your iPhone holding up?
    By ajl in forum iPhone 5s
    Replies: 72
    Last Post: 03-31-2014, 07:22 PM
LINK TO POST COPIED TO CLIPBOARD