1. brengla's Avatar
    Hi guys,

    Has anyone noticed that iPhone 4.0 (beta 3) is laggy as anything on the iPhone 3GS.

    Was fine and is now pretty much unusable but only happened after about 1 and a bit weeks.

    Weird!

    B
    05-16-2010 05:38 PM
  2. frog_IM's Avatar
    Beta 1 had the best performance IMO. Beta 2 was a total mess, and beta 3 hasn't gotten performance back to how it was with beta 1!
    05-16-2010 09:14 PM
  3. DataCentre's Avatar
    Can't wait to see what beta 4 has in store for us on Tuesday. Hope the We Rule game works. Tunein Radio was just updated today and now works with beta 3.
    05-17-2010 12:46 AM
  4. iquinn's Avatar
    I'm sure it is laggy, it is after all a private beta. I don't really think that it is fair to complain about performance issues when you are using a beta product.
    05-17-2010 04:05 AM
  5. Jellotime91's Avatar
    I'm sure it is laggy, it is after all a private beta. I don't really think that it is fair to complain about performance issues when you are using a beta product.
    Well they're not complaining about it as consumers, but betas are for testing. If they don't work properly, how can Apple expect people to test their product? It's not like they are saying this is how 4.0 final will be.
    05-17-2010 04:11 AM
  6. brengla's Avatar
    I'm sure it is laggy, it is after all a private beta. I don't really think that it is fair to complain about performance issues when you are using a beta product.
    Sorry, I wasn't complaining, I know what I've got myself into but I wondered if anyone else encountered it. Beta 3 was fine then wasn't. Thought I might have done something
    05-17-2010 07:00 PM
LINK TO POST COPIED TO CLIPBOARD