Home iMore Q&A > Ask a Question

Why am I receiving text messages on my iPad instead of on my Android phone?

Asked: Apr 01 2020 | 3:39 pm EDT 1450 Views 4 Answers View Best Answer

I have an iPad (wifi only) and an android cell phone. Just today (first time ever) I started receiving text messages from my contacts on my iPad instead of my android cell phone. I DO NOT use my iPad for anything except work. I certainly do not iMessage from it, never have. My question is why all the sudden is it getting text messages and how can stop it???


Best Answer

54,438
Apr 01 2020 | 5:34 pm EDT Just_Me_D

I have an iPad (wifi only) and an android cell phone. Just today (first time ever) I started receiving text messages from my contacts on my iPad instead of my android cell phone. I DO NOT use my iPad for anything except work. I certainly do not iMessage from it, never have. My question is why all the sudden is it getting text messages and how can stop it???
Although you may not “not iMessage from it”, some of your friends/co-workers/acquaintances who have Apple products may have seen your name turn blue in their Messages app indicating you have an Apple ID and/or an Apple device capable of receiving text messages. To stop it, remove the checkmark next to your Apple ID in the Send & Receive portion of the Message settings.

More Answers

8,117
Apr 02 2020 | 10:53 am EDT BreakingKayfabe

Settings > Messages and you can turn off iMessage completely from there or customize your send & receive settings.
4,510
Apr 02 2020 | 3:23 pm EDT Lee_Bo

I have an iPad (wifi only) and an android cell phone. Just today (first time ever) I started receiving text messages from my contacts on my iPad instead of my android cell phone. I DO NOT use my iPad for anything except work. I certainly do not iMessage from it, never have. My question is why all the sudden is it getting text messages and how can stop it???
If you need additional help or have more questions or details to share, please join the site so you can reply in this thread. See this link for instructions on how to join iMore.
2,736
Apr 02 2020 | 7:25 pm EDT joemd60

If I am reading this right. My cousin has an Android phone, and an iPad WiFi only. She had the same problem. My texts to her were going to her iPad.
On your iPad, or your Android phone. Go into settings, messages, and text message forwarding, you should be able to disable it.
I am pretty sure it was in the iPad setting. Either way, it worked for her. Good luck.