1. iMore Question's Avatar
    I have about 6 google/gmail accounts I manage and I used to be able to log in and out of each with passwords correctly auto-completing on the log in screen on my MacBook Pro. The past few weeks, if I log into my personal google account, for example, it would autocomplete some other password and then tell me it was the wrong password.

    When I enter the password I know is right, it would then ask me:
    Do you want to update the password saved in your iCloud Keychain for XXXX@gmail.com. Let's just call this Account A. (a completely different account I manage). I would of course say no.

    No matter what account I was logging into, keychain would try to auto-complete the wrong password, I assume the one for Account A and then ask if I want to update Account A.

    So finally last night I just removed Account A from iCloud Keychain.

    NOW, when I log in to the remaining accounts, it it trying to over-ride all passwords with ANOTHER account I manage - my daughter's gmail!!!

    When I look in safari preferences the correct passwords are associated with the correct gmail accounts, but for some reason recently iCloud Keychain has decided to select ONE account to over-ride all the others - and deleting that account just makes iCloud select another one.

    How do I fix this?
    03-09-2018 07:12 AM
  2. JML5150's Avatar
    So even when type in the correct email, it gives you the wrong password?
    03-09-2018 12:22 PM
  3. dimas02's Avatar

    I just tested this. My daughter's account apparently is now the one over-riding everything. When I log in, it works fine - autofills and logs in.

    But if I sign out of her account and try to log in to my personal gmail or any other account I manage, iCloud Keychain is auto-filling her email's password.

    So just to test again. I just deleted her account from the account screen and from iCloud Keychain and tried to log in to my email. And NOW it's auto-completing a password from yet another gmail account I manage - this one for a rescue dog.

    So deleting the account that is auto-filling doesn't fix the issue as keychain will just pick another one to over-ride everything.
    03-09-2018 04:21 PM
  4. kataran's Avatar
    Have you tried turning off Keychain
    03-09-2018 07:58 PM
  5. Ledsteplin's Avatar
    If a hard reset (reboot) doesn't work, try Reset All Settings.

    Go to Settings >General >Reset >Reset All Settings. This resets to default everything in Settings, including notifications, alerts, brightness, and clock settings like wake up alarms.
    You might also try signing out of iCloud, then sign back in.
    03-09-2018 08:40 PM

Similar Threads

  1. What to do if your Nintendo account has been banned
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 03-08-2018, 01:10 PM
  2. It's time to upgrade to a gaming chair with Amazon's big one-day sale
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 03-08-2018, 12:40 PM
  3. How to set up and use OneCast to play Xbox One games on your Mac
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 03-08-2018, 12:10 PM
  4. Replies: 0
    Last Post: 03-06-2018, 03:40 PM
  5. iPhone X crackling over FaceTime/calls
    By atarinerd93 in forum iPhone X
    Replies: 2
    Last Post: 03-06-2018, 02:19 PM