1. JAHall721's Avatar
    My Apple TV 3 Has worked perfectly until I updated my Mac to High Sierra today. Now I have no audio from the ATV. I’ve reset it to factory settings, reset the router, checked all the settings. No change, video is fine but no audio. Everything is affected-iTunes library, Netflix, iTunes Store, etc.
    Any ideas?
    10-13-2017 11:54 PM
  2. firedept10's Avatar
    Welcome to iMore.

    My suggestion now would be to try another hdmi cable. Also check you audio and videos settings under Settings. As well check you don't have the mute button ON on your TV. Just a few things to try. Thanks.
    Sherry_B likes this.
    10-14-2017 09:00 AM
  3. Lee_Bo's Avatar
    My Apple TV 3 Has worked perfectly until I updated my Mac to High Sierra today.
    Curious. Are you using AirPlay to send from your Mac to the Apple TV? If that's the case, do you have your Mac sound settings set to use the ATV for sound?
    10-16-2017 09:51 AM
  4. JAHall721's Avatar
    Airplay to ATV works fine. The problem is when using the ATV alone. Video is perfect but no sound. This includes streaming from iTunes Store, apps like Netflix, or content from the library on the Mac.

    Update: I changed to a different HDMI input on the tv and the sound came back. Yesterday I used airplay from the Mac to listen to music. When I later tried to watch content on ATV the problem recurred. Reset and changing HDMI input again finally got it working. This problem started right after High Sierra install. Coincidence?
    Sherry_B likes this.
    10-16-2017 11:08 AM
  5. JAHall721's Avatar
    Airplay to ATV works fine. The problem is when using the ATV alone. Video is perfect but no sound. This includes streaming from iTunes Store, apps like Netflix, or content from the library on the Mac.

    Update: I changed to a different HDMI input on the tv and the sound came back. Yesterday I used airplay from the Mac to listen to music. When I later tried to watch content on ATV the problem recurred. Reset and changing HDMI input again finally got it working. This problem started right after High Sierra install. Coincidence?
    10-16-2017 11:08 AM

Similar Threads

  1. Replies: 15
    Last Post: 10-25-2017, 06:04 AM
  2. How are you getting on with your Series 3?
    By James Falconer in forum Apple Watch Series 3
    Replies: 10
    Last Post: 10-15-2017, 02:19 PM
  3. Replies: 1
    Last Post: 10-14-2017, 07:17 AM
  4. Give your Apple Watch a fresh look with bands from $6
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-13-2017, 05:20 PM
  5. Apple is working on a fix for GarageBand in iOS 11
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-13-2017, 02:30 PM
LINK TO POST COPIED TO CLIPBOARD