1. iMore Question's Avatar
    I went into a Home Depot today and found my connection extremely slow. Noticed that the WiFi symbol was showing in top left of my iPhone screen so I went to my WiFi settings and saw I had been auto-joined to attwifi.

    When I tapped the "i" for the network there is not an option to turn off Auto-join or to "Forget This Network". This behavior is in iOS11. I'm pretty sure that I could turn this off in iOS10.

    WTF AT&T and Apple!! Forcing customers to connect to crappy WiFi isn't just a bad customer experience, it can be dangerous.

    I live in the city and there are tons of attwifi hotspots around and my phone is constantly connecting to them no matter how weak the signal when I am walking down the street. In iOS10 I could stop this behavior.

    In nearly all cases the attwifi speed is inferior to my LTE connection and I don't want to connect to any WiFi hotspot that I specifically haven't chosen, even AT&T's.

    Does anyone know if there is a way to disable this "feature"?
    10-03-2017 03:12 PM
  2. gtrogue's Avatar
    I posted the original question and should add that Home Depot doesn't have an AT&T WiFi hotspot according to AT&T. Further pointing out the problem with auto-joining unknown networks. The Home Depot is quite far away from any other businesses so who knows where or what I was really connecting to.
    10-03-2017 03:23 PM
  3. TwitchyPuppy's Avatar
    There is a toggle, at the bottom of your connections, that says: Ask to Join Networks. Activate that
    Just_Me_D likes this.
    10-03-2017 03:32 PM
  4. Sherry_B's Avatar
    WTF AT&T and Apple!! Forcing customers to connect to crappy WiFi isn't just a bad customer experience, it can be dangerous.

    Does anyone know if there is a way to disable this "feature"?
    This is a feature by AT&T and has nothing to do with Apple. You'll need to contact AT&T about this, or use "Ask to join network" option recommended by Twitchypuppy.

    A short search shows a few others complaining about this over on the AT&T forums, but AT&T just says to disable wifi if you don't want it automatically connecting. For AT&T to disable the "Forget Network" option for their wifi network is pretty crappy, IMHO.
    10-03-2017 05:59 PM
  5. Rob Phillips's Avatar
    “Forget This Network” as well as a toggle for “auto join” is present in iOS 11.1 dev beta for me. I’m not sure whether or not this is new to 11.1 but it seems to be pretty easy to forget WiFi networks, or at least not automatically join them.

    Are you seeing something different?

    10-03-2017 06:31 PM
  6. Sherry_B's Avatar
    “Forget This Network” as well as a toggle for “auto join” is present in iOS 11.1 dev beta for me. I’m not sure whether or not this is new to 11.1 but it seems to be pretty easy to forget WiFi networks, or at least not automatically join them.
    This is something for people on specific AT&T plans. I believe it has something to do with AT&T Hotspot. Since Apple does not allow carriers to fiddle with iOS, I think this is something activated/deactivated in the sim. That's how it is with Straight Talk anyway. For example, WiFi Calling is typically a free feature for Straight Talk users, but I bought my sim from them before they offered it. The feature is disabled (hidden) on my phone as soon as I stick the sim in. At any rate, perhaps it was something that was deactivated with the install of 11, and somehow was already in the sim.
    Rob Phillips likes this.
    10-03-2017 08:15 PM
  7. Rob Phillips's Avatar
    This is something for people on specific AT&T plans. I believe it has something to do with AT&T Hotspot. Since Apple does not allow carriers to fiddle with iOS, I think this is something activated/deactivated in the sim. That's how it is with Straight Talk anyway. For example, WiFi Calling is typically a free feature for Straight Talk users, but I bought my sim from them before they offered it. The feature is disabled (hidden) on my phone as soon as I stick the sim in
    Interesting. Thanks for clarifying!
    10-03-2017 08:17 PM
  8. gtrogue's Avatar
    There is a toggle, at the bottom of your connections, that says: Ask to Join Networks. Activate that
    Problem with that setting is that I live in a major city and get bombarded with join popups whenever I am outside my home. So many in fact that it makes the phone unusable.
    10-04-2017 11:59 AM
  9. gtrogue's Avatar
    Well, I was at my dentist this morning, which happens to be near a different Home Depot and saw that my phone had again automatically connected to WiFi. I checked and it was attwifi. However, it was labelled as "attwifi - Passpoint".

    When you check the information on that network there are no options to "Auto-join" or "Forget this network" (image).
    Forced to join attwifi since iOS 11!!!!!-img_3285.png

    So I went into settings and turned off WiFi Calling and went back to the network information and lo and behold the "Auto-join" option was back (image).
    Forced to join attwifi since iOS 11!!!!!-img_3286.png

    I disabled the Auto-join and then went back and turned on WiFi Calling and then it no longer automatically connected. I don't know if it is going to reset after a period of time or after restarting my phone. I didn't have a lot of time to test all scenarios at the dentists office.
    10-05-2017 11:09 AM
  10. gtrogue's Avatar
    For whatever reason the forum won't let me post in one long post so I have to continue.

    This "Passpoint" thing had me intrigued so I did some digging and this was a new WiFi setup that AT&T implemented on January 5th, 2016. It uses WPA2 encryption and devices that are configured appropriately will automatically connect and login to these hotspots without any captive portal or user intervention. The idea with these hotspots was to ensure a more secure connection and to eliminate man in the middle spoofing of an AT&T hotspot.

    According to AT&T's info here https://passpoint.attwifi.com/ an iPhone needs a Passpoint profile installed to automatically connect. However, my phone does not have any profile installed. I imagine that they updated the carrier settings to "force" configure the phone to work with Passpoint if WiFi Calling is enabled, perhaps to coincide with the iOS11 release.

    If anybody else finds themselves in this situation and wants to test out my method for disconnecting and not Auto-joining, please do, and report back with their results.
    10-05-2017 11:11 AM

Similar Threads

  1. Official Release iOS 11.0.2
    By Dave Catherall in forum iOS 11
    Replies: 28
    Last Post: 10-11-2017, 01:59 PM
  2. Crackling noise has disappeared with iOS 11.1 beta
    By sangs in forum iPhone 8 Plus
    Replies: 5
    Last Post: 10-04-2017, 07:56 AM
  3. Is it possible to erase a iPhone with out find my phone installed?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 10-03-2017, 06:52 PM
  4. How to use the document scanner on iPhone and iPad
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-03-2017, 02:10 PM
  5. How to reboot and reset your iPhone or iPad
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-03-2017, 12:10 PM
LINK TO POST COPIED TO CLIPBOARD