1. iMore Question's Avatar
    I recently upgraded from an iPhone 6 to the iPhone 7. Prior to upgrading, I connected my iPhone 6 to my laptop and performed a backup. I then connected my iPhone 7 to my laptop and performed a restore of the phone from my backup. Most everything went smoothly.

    The only issue that I ran into was that my apps were taking a very long time to re-install. I'm talking several hours long. Several of my social media apps appeared to be stuck in a waiting state. I felt like this was out of the norm so I decided to touch and hold on each app stuck in the waiting state and simply deleted it. I then went back into the App Store and attempted to download my apps again. However, when I tried to download Twitter for instance, I didn't see a "Get" button or a cloud indicating that I had downloaded this particular app previously. All I see is a round button with a square stop button in the middle of the round button. It's highlighted blue and when I touch it, it greys out the button for several seconds and then becomes highlighted blue again.

    How can I fix this so that I can download these apps again? I've tried power cycling the phone multiple times. Some of the apps that I deleted in its waiting state were able to be downloaded again. Some were not.

    Anyone with any ideas or solutions? Thanks for your time.
    09-26-2016 08:52 AM

Similar Threads

  1. What is the function of backservice.app
    By iMore Question in forum Ask a Question
    Replies: 0
    Last Post: 09-26-2016, 03:30 AM
  2. Default Apps.
    By datafiend in forum iOS 10
    Replies: 6
    Last Post: 09-25-2016, 11:56 PM
  3. Replies: 1
    Last Post: 09-25-2016, 07:21 PM
  4. Replies: 1
    Last Post: 09-25-2016, 04:09 PM
  5. Replies: 1
    Last Post: 09-25-2016, 03:11 PM