1. iMore Question's Avatar
    I have tried solutions from forums. The ones I understand don't work. The others are beyond me!
    08-23-2016 02:03 PM
  2. Quis89's Avatar
    Are you connected to WiFi? If so this would explain why it's only sending to iPhones. It may only be able to send iMessages with a data connection. Try disconnecting from WiFi. This would tell you if there is an issue with your cellular connection. This could be a cellular issue. Try simply restarting your phone. That has fixed issues like this for me in the past. If not, maybe try reseting your Network Settings. If neither of those work you may want to contact your carrier.

    Also, is this happening with everyone you attempt to message who doesn't have an iPhone? Or just one person? That would help determine if its an issue on your end of theirs.
    08-23-2016 02:07 PM
  3. JustMeWhoElse's Avatar
    Is send as SMS enabled on your iPhone?

    Settings - Messages - Send as SMS - turn that on
    08-23-2016 04:17 PM

Similar Threads

  1. Replies: 4
    Last Post: 11-01-2016, 08:52 AM
  2. Replies: 32
    Last Post: 09-06-2016, 03:48 PM
  3. Not Getting Phone Calls
    By Raymond_Walther in forum iOS 10
    Replies: 14
    Last Post: 08-25-2016, 03:44 PM
  4. How to accessorize your rose gold iPhone
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 08-23-2016, 01:12 PM
  5. Replies: 0
    Last Post: 08-23-2016, 12:12 PM