1. iMore Question's Avatar
    All my text, incoming and outgoing, are showing up on multiple phones on my acct? What is the fix?
    07-06-2016 12:23 PM
  2. Vinu Jacob said: Best Answer

    Go to
    • Settings
    • Messages
    • Send & Receive

    select the phone number of the device you are working with. This way, each device can send and receive messages without making them appear on every device under your account. Cheers.
  3. Tartarus's Avatar
    Hi, welcome to iMore
    You are logged in in iMessage on those multiple phones. Simply log out of iMessage on each phone you don't want to see your iMessages appearing.
    07-06-2016 12:30 PM
  4. Vinu Jacob's Avatar
    Go to
    • Settings
    • Messages
    • Send & Receive

    select the phone number of the device you are working with. This way, each device can send and receive messages without making them appear on every device under your account. Cheers.
    pkcable and Tartarus like this.
    07-06-2016 12:39 PM

Similar Threads

  1. What can I do about dust under camera lens?
    By Tom Mane in forum iPhone 6s Plus
    Replies: 6
    Last Post: 07-13-2016, 03:17 PM
  2. Replies: 0
    Last Post: 07-06-2016, 12:22 PM
  3. Replies: 2
    Last Post: 07-06-2016, 11:31 AM
  4. How do I unblock someone on my Samsung Galaxy Edge s6 phone?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 07-06-2016, 11:25 AM
  5. Replies: 0
    Last Post: 07-06-2016, 10:30 AM
LINK TO POST COPIED TO CLIPBOARD