1. Tempanys16's Avatar
    I had to restore and back up my iPhone yesterday because it went crazy and completely stopped working. Up until then my phone connected perfectly to my MacBook. Now when I plug my phone in it charges but iTunes says "the iPhone cannot be used because it requires a newer version of iTunes" I've updated my iTunes and I'm using the newest version but it's still saying the same thing, I've tried restarting both my phone and my laptop, I've reset my phone settings, my laptop software is all up to date but nothing works.
    12-21-2015 05:53 PM
  2. john_v's Avatar
    12-24-2015 11:28 AM

Similar Threads

  1. Anyone using both Iphone and Android?
    By BobPepe in forum iPhone
    Replies: 70
    Last Post: 08-22-2017, 02:03 PM
  2. Replies: 1
    Last Post: 12-21-2015, 09:33 PM
  3. Replies: 0
    Last Post: 12-21-2015, 05:22 PM
  4. Replies: 2
    Last Post: 12-21-2015, 04:48 PM
  5. Replies: 1
    Last Post: 12-21-2015, 03:08 PM
LINK TO POST COPIED TO CLIPBOARD